Topics

Virtual Port change in #APPC pro #appc


Cygnus Hunter
 

This will be my first post, and is unfortunately because I need some assistance.  I thank you for all of the great posts, as they are the reason that I haven’t needed to post.  I apologize a head of time if this has been covered and I happened to have missed it.

I have an AP 1600 with encoders and gtocp4, located in a permanent observatory. Just last night I noticed that my mg box v2 was not connecting on appc pro start up.  I scanned everything and notice that my com21 and com22 virtual ports were missing in the bottom view of acc pro, and in their place was com3 and com4. I have no idea why 21 &22 were replaced with 3 & 4, and assume this created a conflict for the mg box.  I looked in the device manager and still see com21 and com22 under com ports, and they showed to be virtual ports. If I look in the virtual ports tab in acc pro it shows com3 and 4 there.  If I do the pull down port menu where you would create a virtual port, com21 and com22 are not options there. The port choices go from com20 to com23. 21 & 22 are not options to create a new com port, I assume because they already exist in the device manager. I am not sure how to get back up on com21 com22 for my virtual ports.

‘I don’t know how long it has been doing this, as I haven’t paid attention since everything still connected as normal. I recently updated the ascom to the new SP1.  

any assistance would be greatly appreciated. Thanks for the help!


Todd DeGidio


Ray Gralak
 

Hi Todd,

APCC can dynamically allocate virtual ports. It will choose different ports if the previous ports are in use.

It can also automatically reconfigure the ASCOM driver to use the ports APCC chooses, so if everything is working okay, there is nothing you need to do.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Cygnus Hunter
Sent: Tuesday, December 8, 2020 3:31 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] Virtual Port change in #APPC pro

This will be my first post, and is unfortunately because I need some assistance. I thank you for all of the great posts,
as they are the reason that I haven’t needed to post. I apologize a head of time if this has been covered and I
happened to have missed it.

I have an AP 1600 with encoders and gtocp4, located in a permanent observatory. Just last night I noticed that my mg
box v2 was not connecting on appc pro start up. I scanned everything and notice that my com21 and com22 virtual
ports were missing in the bottom view of acc pro, and in their place was com3 and com4. I have no idea why 21 &22
were replaced with 3 & 4, and assume this created a conflict for the mg box. I looked in the device manager and still
see com21 and com22 under com ports, and they showed to be virtual ports. If I look in the virtual ports tab in acc pro
it shows com3 and 4 there. If I do the pull down port menu where you would create a virtual port, com21 and com22
are not options there. The port choices go from com20 to com23. 21 & 22 are not options to create a new com port, I
assume because they already exist in the device manager. I am not sure how to get back up on com21 com22 for my
virtual ports.

‘I don’t know how long it has been doing this, as I haven’t paid attention since everything still connected as normal. I
recently updated the ascom to the new SP1.

any assistance would be greatly appreciated. Thanks for the help!


Todd DeGidio


Cygnus Hunter
 

Ray,
Thank you for that.  Sorry for the delayed response as I was offline for a couple of days.  

In the future, if there ever does become a conflict with other equipment, with those low port numbers that apcc is currently using, then what would the best practice be to assign higher number virtual ports that would be less likely to conflict?  I guess that I’d like to know a path to follow if this happens, and it is on a perfect night at midnight, which is when Murphy usually visits my observatory. It could save a wasted night. Only so many each year as you well know...lol

thank you!

Todd


Ray Gralak
 

Hi Todd,

In the future, if there ever does become a conflict with other equipment, with those low port numbers that apcc is
currently using, then what would the best practice be to assign higher number virtual ports that would be less likely to
APCC allocates virtual ports at runtime, not at system boot. Devices like a USB to Serial converters usually allocate their virtual COM port at system startup, well before APCC runs. APCC will also never use an existing (true) serial port as a virtual port.

When you run APCC, if it finds a virtual port in use that was previously configured for APCC to use, APCC will choose a different virtual port and reconfigure the driver to use that port. So there should not be a problem if you have all of your devices that use COM ports allocated before starting APCC.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Cygnus Hunter
Sent: Thursday, December 10, 2020 10:12 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Virtual Port change in #APPC pro

Ray,
Thank you for that. Sorry for the delayed response as I was offline for a couple of days.

In the future, if there ever does become a conflict with other equipment, with those low port numbers that apcc is
currently using, then what would the best practice be to assign higher number virtual ports that would be less likely to
conflict? I guess that I’d like to know a path to follow if this happens, and it is on a perfect night at midnight, which is
when Murphy usually visits my observatory. It could save a wasted night. Only so many each year as you well
know...lol

thank you!

Todd