Park 1 Error Message #APCC


dnakic@...
 

I uploaded with the latest version of APCC (v1.9.4.3) and every time I enter/exit software I'm getting an amber pop-up about Park 1 Position not being recognized.  There is a check box to have the message not be shown again, but its persistent every time.  In fact when you hit the 'Ok' to clear you need to do it 3 times in a row.  I've not seen this before (if I did I probably used the check box to dismiss it).  For my shed setup, I can only use Park 1.

Any thoughts on what I can do to resolve issue?

Thanks,

Don


Ray Gralak
 

Hi Don,

Park 1 Position not being recognized
That doesn't sound right. Just in case this is the reason, you should make sure that Unpark from "Last Parked" is set (not unpark from "Park 1").

Also, make sure the ASCOM driver is updated to v5.50.01 and that you have the same settings there (unpark from last parked, and park to Park 1).

If the popups persist, you likely have a corrupted settings file. With APCC not running, delete this file:

C:\ProgramData\Astro-Physics\APCC\settings.apcc

-Ray

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of dnakic via groups.io
Sent: Wednesday, March 16, 2022 3:57 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] Park 1 Error Message #APCC

I uploaded with the latest version of APCC (v1.9.4.3) and every time I enter/exit software I'm getting an amber pop-
up about Park 1 Position not being recognized. There is a check box to have the message not be shown again,
but its persistent every time. In fact when you hit the 'Ok' to clear you need to do it 3 times in a row. I've not seen
this before (if I did I probably used the check box to dismiss it). For my shed setup, I can only use Park 1.

Any thoughts on what I can do to resolve issue?

Thanks,

Don


dnakic@...
 

The version of ASCOM driver I'm using is v5.50.03. In my settings I have UnPark from Last Position and Park set to Park 1. This is in the Telescope Setup too. I did delete the C:\ProgramData\Astro-Physics\APCC\settings.apcc. The message still comes up even when I select the Telescope Setup APP. When I hit 'Ok', I have to do it three times. When you select the box to not show again, it still shows.

I'm enclosing screen captures of the issue and settings.


Ray Gralak
 

That message is coming from the driver, not APCC. Please make sure you unpark from APCC and not the driver.

-Ray

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of dnakic via groups.io
Sent: Thursday, March 17, 2022 5:56 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Park 1 Error Message #APCC

The version of ASCOM driver I'm using is v5.50.03. In my settings I have UnPark from Last Position and Park set
to Park 1. This is in the Telescope Setup too. I did delete the C:\ProgramData\Astro-Physics\APCC\settings.apcc.
The message still comes up even when I select the Telescope Setup APP. When I hit 'Ok', I have to do it three
times. When you select the box to not show again, it still shows.

I'm enclosing screen captures of the issue and settings.




dnakic@...
 

I do Unpark/Park from APCC.  I just noticed this message comes up when I open Telescope Setup.  Is there something I have setup incorrectly?


Ray Gralak
 

I do Unpark/Park from APCC. I just noticed this message comes up when I open Telescope Setup. Is there
something I have setup incorrectly?
I'm still trying unsuccessfully to replicate the behavior you are seeing. Why do you want to open Telescope Setup with APCC open? The driver's Telescope setup is meant to be run without the driver and APCC running.

By the way, as an interim solution you can define an Alt/Az park position at Park 1's position and park to the Alt/Az position. This will avoid the driver's Park 1 warnings.

-Ray

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of dnakic via groups.io
Sent: Thursday, March 17, 2022 7:25 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Park 1 Error Message #APCC

I do Unpark/Park from APCC. I just noticed this message comes up when I open Telescope Setup. Is there
something I have setup incorrectly?


dnakic@...
 

I will try this.  I only shown the Telescope Setup to show settings to you.  I don’t use at all.  


Ray Gralak
 

How about a screenshot of APCC's Park tab?

And do you have a way to capture a video of connecting to the mount with APCC and seeing this popup occur?

-Ray

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of dnakic via groups.io
Sent: Friday, March 18, 2022 4:54 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Park 1 Error Message #APCC

I will try this. I only shown the Telescope Setup to show settings to you. I don’t use at all.


dnakic@...
 

Enclosed is a screen shot of APCC Park Screen and video of issue.  Let me know if you need anything else.


Ray Gralak
 

I followed exactly what you did and I do not see the popup's you are seeing. The only reason that popup should show up is if you are unparking from Park 1, however when you connected to the driver in APCC it looks like the mount is already unparked (shown in APCC's status bar) so I don't understand why APCC would be trying any park or unpark operation.

Using APCC's log zipper, please zip the APCC *and* driver logs for the last day and post the zip file here.

-Ray

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of dnakic via groups.io
Sent: Saturday, March 19, 2022 6:34 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Park 1 Error Message #APCC

Enclosed is a screen shot of APCC Park Screen and video of issue. Let me know if you need anything else.


Ray Gralak
 

BTW, if the zip file is too large, you may not be able to post it here, so you will have to share it via a link through DropBox, Google Docs, etc. If you want, you can email the link privately to me at this email:

 

iogroups AT siriusimaging DOT com

 

And to create the zip file, just open APCC and from the Tools menu, select “Log Zipper…”. Here is a screenshot with more details on what to select:


 

-Ray


Ray Gralak
 

One other thing I noticed is all of those Park 1 warning messages are coming from the ASCOM driver, not APCC. It may be that the ASCOM driver's setting file is corrupted or locked.

So, with the ASCOM driver and APCC shutdown:

1. Rename Settings.apdb (full path below) to Settings1.apdb. This will force the driver to create a new settings file the next time it is run.

C:\ProgramData\Astro-Physics\Settings.apdb

2. Run the ASCOM driver's setup and set the Unpark position to Park 1. This will immediately pop up the Park 1 dialog box warning.
3. Check the "Don't Show this warning again" checkbox and close the dialog window.
4. Click "OK" on the driver's setup window to close the window down.
5. Open the driver's setup again. You should not get a Park 1 pop-up warning.
6. Configure the rest of the driver's settings as you had set before and click OK to close the driver's setup.
7. Open APCC as you did before and click the "Now" button in APCC's "AP V2 Driver" group box. This will configure the driver's settings. There will be at least two pop-up windows to which you will need to click OK.
8. Connect APCC to the mount, if not already connected.
9. Connect APCC to the driver. There should be no more pop-up dialogs.

After you try this, please confirm that you no longer get the pop-up dialogs.

-Ray


dnakic@...
 

Here is the Zip file based on the selections you requested.


dnakic@...
 

THIS WORKED!  Many thanks for all your great help!!!!


Ray Gralak
 

THIS WORKED! Many thanks for all your great help!!!!
Okay, excellent! Thanks for letting me know!

I think the settings file must have been locked or corrupted, so the drover wasn't able to save the Park 1 checkbox setting.

-Ray