Mount won't connect to new(er) laptop #APCC


David Woolf
 

Was using an older Dell, "upgraded" to Lenovo because I needed USB3 for my ZWO camera.  Now mount won't connect.  Using APCC Standard and USB connection.  I get "No response from mount"  Swapped cables twice to no effect.  Old laptop connected just fine.  Got it to connect briefly by setting primary port to COM4, which has only appeared in the dropdown list occasionally.  Dev. manager says best drivers are installed.   What's the trick?  


Roland Christen
 

I have a Lenovo also, and i usually use device Manager to find which com port Windows has decided to use for the new USB connection. Once I find that port number, I set APCC to that number. If I'm using just the ASCOM driver, I select that port number in the driver. That always establishes the connection for me.

Rolando

-----Original Message-----
From: David Woolf <go4itbass@...>
To: main@ap-gto.groups.io
Sent: Sun, Jun 20, 2021 4:32 pm
Subject: [ap-gto] Mount won't connect to new(er) laptop #APCC

Was using an older Dell, "upgraded" to Lenovo because I needed USB3 for my ZWO camera.  Now mount won't connect.  Using APCC Standard and USB connection.  I get "No response from mount"  Swapped cables twice to no effect.  Old laptop connected just fine.  Got it to connect briefly by setting primary port to COM4, which has only appeared in the dropdown list occasionally.  Dev. manager says best drivers are installed.   What's the trick?  

--
Roland Christen
Astro-Physics


Jeffc
 

Last night when setting up, I moved some cables around on my Astro computer and couldn’t connect to the Mach2 mount.   So I swapped from (iirc) COM3 to COM4.    Then “connect” worked but things were a bit weird - I didn’t get the normal “initialize mount” dialog.  APCC complained the mount wasn’t at RA 0 / DEC 90. 
I think I ended up doing the Find Home thing, and also restarting APCC. 

Fwiw I also use Device Manager a bunch to figure out COM ports.  Sometimes I unplug the USB device, then plug it in again and see which COM port shows up.  

The only other explanation for “worked for some time” is:  perhaps there is some sort of power saving feature on the Lenovo where the USB ports get powered off after some time.  Iirc there is a setting somewhere on windows to disable such power saving features. 

Hope this helps. 


On Jun 20, 2021, at 2:49 PM, Roland Christen via groups.io <chris1011@...> wrote:


I have a Lenovo also, and i usually use device Manager to find which com port Windows has decided to use for the new USB connection. Once I find that port number, I set APCC to that number. If I'm using just the ASCOM driver, I select that port number in the driver. That always establishes the connection for me.

Rolando

-----Original Message-----
From: David Woolf <go4itbass@...>
To: main@ap-gto.groups.io
Sent: Sun, Jun 20, 2021 4:32 pm
Subject: [ap-gto] Mount won't connect to new(er) laptop #APCC

Was using an older Dell, "upgraded" to Lenovo because I needed USB3 for my ZWO camera.  Now mount won't connect.  Using APCC Standard and USB connection.  I get "No response from mount"  Swapped cables twice to no effect.  Old laptop connected just fine.  Got it to connect briefly by setting primary port to COM4, which has only appeared in the dropdown list occasionally.  Dev. manager says best drivers are installed.   What's the trick?  

--
Roland Christen
Astro-Physics


Peter Bresler
 

You can get an Insignia Ethernet to USB adapter at Best Buy and use an Ethernet cable, which is more reliable anyway.


 

Howdy,

I would say that adding two extra connection points and an extra adapter circuit introduces more reliability issues than simply sticking with one cable. By using a USB to Ethernet adapter, not only have you failed to eliminate reliability issues with USB (after all, you are still fundamentally dependent on USB) but you have added an entire second cable with it's own possible issues. Reliability isn't necessarily defined by what connector is going into the CP4/5.

Windows does have USB power saving settings, although I don't think they would cause this issue. You can check easily by simply turning off the selective port suspension in the settings. This shouldn't affect the CP5 however, since the FTDI chip running the USB is powered by both the CP5 and the computer for maximum performance. 

Do you have the FTDI driver installed? Windows will find a driver but not necessarily the right one every time. You can find those drivers here: https://ftdichip.com/drivers/

One troubleshooting option would be to check that the digital board of the CP5 is fully seated on the main board. Power down the CP5 and use a 3/32" hex key to open up the front cover with the antenna. Inside there is a small circuit board on top of a large circuit board. Press down on the side of the small circuit board closest to the connector panel and see if it seats into place. If so, that might be the cause of your issue. I doubt this is the case, but it isn't a bad place to check.
--
Liam Plybon
Astro-Physics