IP Address of mount


Thomas Giannaccini
 

I was under the impression that the IP address of the mount is static. Several weeks ago I was on the phone with AP and as part of that call my IP address for the mount was determined. I took a picture of it after I typed it in so that I would have it. Now I am trying to access the mount via ASCOM and ASCOM cannot find the mount. I inquired on Cloudy Nights as to what the issue could be (at the time I was using RDP to a headless PC at the mount) and thought that RDP might be the issue. But When I try to ping the mount's IP address from the command prompt it times out (on 2 different computers going pier to pier via ethernet cable directly to the mount.) This is odd because ASCOM worked before when connected pier to pier. So I'm starting to wonder if I have the wrong IP address? I'm typing it with the picture right in front of me.

Ideas?
--
CN: HasAnyoneSeenMyNeblua


ap@CaptivePhotons.com
 

Thomas Giannaccini wrote:

 

  • I was under the impression that the IP address of the mount is static. Several weeks ago I was on the phone with AP and as part of that call my IP address for the mount was determined. I took a picture of it after I typed it in so that I would have it. Now I am trying to access the mount via ASCOM and ASCOM cannot find the mount. I inquired on Cloudy Nights as to what the issue could be (at the time I was using RDP to a headless PC at the mount) and thought that RDP might be the issue. But When I try to ping the mount's IP address from the command prompt it times out (on 2 different computers going pier to pier via ethernet cable directly to the mount.) This is odd because ASCOM worked before when connected pier to pier. So I'm starting to wonder if I have the wrong IP address? I'm typing it with the picture right in front of me.

 

The controller follows networking standards, which means the address can be assigned either via a static address (human set), a DHCP (IP address) server (home routers sometime do that), or via Windows stupid idiotic inane random address generator.  It all depends on details of your setup, and what you did the first time you used it.

 

So yes, it can change.

 

There’s a rather lengthy discussion on the subject in the “Astro-Physics GTO Servo Drive System Model GTOCP4 Operating Instructions” manual starting on page 12 and page 56 (at least in my version).  My recommendation is use ethernet (not wifi) and the first time you use it enter a static IP address and it will stop changing.

 

 


Christopher Erickson
 

Also, the WiFi port and Ethernet port are different networks with different IP addresses. And the CP4 does not route IP traffic between the ports. So if you are connected via Ethernet, for example, the WiFi IP address will be unreachable via the Ethernet network, unless your WiFi and Ethernet networks are bridged at some other point in your network(s).


-Christopher Erickson
Observatory engineer
Waikoloa, HI 96738
www.summitkinetics.com
   

On Sat, Oct 2, 2021, 5:49 PM ap@... <ap@...> wrote:

Thomas Giannaccini wrote:

 

  • I was under the impression that the IP address of the mount is static. Several weeks ago I was on the phone with AP and as part of that call my IP address for the mount was determined. I took a picture of it after I typed it in so that I would have it. Now I am trying to access the mount via ASCOM and ASCOM cannot find the mount. I inquired on Cloudy Nights as to what the issue could be (at the time I was using RDP to a headless PC at the mount) and thought that RDP might be the issue. But When I try to ping the mount's IP address from the command prompt it times out (on 2 different computers going pier to pier via ethernet cable directly to the mount.) This is odd because ASCOM worked before when connected pier to pier. So I'm starting to wonder if I have the wrong IP address? I'm typing it with the picture right in front of me.

 

The controller follows networking standards, which means the address can be assigned either via a static address (human set), a DHCP (IP address) server (home routers sometime do that), or via Windows stupid idiotic inane random address generator.  It all depends on details of your setup, and what you did the first time you used it.

 

So yes, it can change.

 

There’s a rather lengthy discussion on the subject in the “Astro-Physics GTO Servo Drive System Model GTOCP4 Operating Instructions” manual starting on page 12 and page 56 (at least in my version).  My recommendation is use ethernet (not wifi) and the first time you use it enter a static IP address and it will stop changing.

 

 


Thomas Giannaccini
 

Thank you, I did not realize this could be an issue. I'll dig into it.

Tom

On Sat, Oct 2, 2021 at 9:49 AM ap@... <ap@...> wrote:

Thomas Giannaccini wrote:

 

  • I was under the impression that the IP address of the mount is static. Several weeks ago I was on the phone with AP and as part of that call my IP address for the mount was determined. I took a picture of it after I typed it in so that I would have it. Now I am trying to access the mount via ASCOM and ASCOM cannot find the mount. I inquired on Cloudy Nights as to what the issue could be (at the time I was using RDP to a headless PC at the mount) and thought that RDP might be the issue. But When I try to ping the mount's IP address from the command prompt it times out (on 2 different computers going pier to pier via ethernet cable directly to the mount.) This is odd because ASCOM worked before when connected pier to pier. So I'm starting to wonder if I have the wrong IP address? I'm typing it with the picture right in front of me.

 

The controller follows networking standards, which means the address can be assigned either via a static address (human set), a DHCP (IP address) server (home routers sometime do that), or via Windows stupid idiotic inane random address generator.  It all depends on details of your setup, and what you did the first time you used it.

 

So yes, it can change.

 

There’s a rather lengthy discussion on the subject in the “Astro-Physics GTO Servo Drive System Model GTOCP4 Operating Instructions” manual starting on page 12 and page 56 (at least in my version).  My recommendation is use ethernet (not wifi) and the first time you use it enter a static IP address and it will stop changing.

 

 


--
CN: HasAnyoneSeenMyNeblua


Thomas Giannaccini
 

Thank you Christopher; I appreciate the help.

Tom

On Sat, Oct 2, 2021 at 10:00 AM Christopher Erickson <christopher.k.erickson@...> wrote:
Also, the WiFi port and Ethernet port are different networks with different IP addresses. And the CP4 does not route IP traffic between the ports. So if you are connected via Ethernet, for example, the WiFi IP address will be unreachable via the Ethernet network, unless your WiFi and Ethernet networks are bridged at some other point in your network(s).


-Christopher Erickson
Observatory engineer
Waikoloa, HI 96738
www.summitkinetics.com
   

On Sat, Oct 2, 2021, 5:49 PM ap@... <ap@...> wrote:

Thomas Giannaccini wrote:

 

  • I was under the impression that the IP address of the mount is static. Several weeks ago I was on the phone with AP and as part of that call my IP address for the mount was determined. I took a picture of it after I typed it in so that I would have it. Now I am trying to access the mount via ASCOM and ASCOM cannot find the mount. I inquired on Cloudy Nights as to what the issue could be (at the time I was using RDP to a headless PC at the mount) and thought that RDP might be the issue. But When I try to ping the mount's IP address from the command prompt it times out (on 2 different computers going pier to pier via ethernet cable directly to the mount.) This is odd because ASCOM worked before when connected pier to pier. So I'm starting to wonder if I have the wrong IP address? I'm typing it with the picture right in front of me.

 

The controller follows networking standards, which means the address can be assigned either via a static address (human set), a DHCP (IP address) server (home routers sometime do that), or via Windows stupid idiotic inane random address generator.  It all depends on details of your setup, and what you did the first time you used it.

 

So yes, it can change.

 

There’s a rather lengthy discussion on the subject in the “Astro-Physics GTO Servo Drive System Model GTOCP4 Operating Instructions” manual starting on page 12 and page 56 (at least in my version).  My recommendation is use ethernet (not wifi) and the first time you use it enter a static IP address and it will stop changing.

 

 


--
CN: HasAnyoneSeenMyNeblua


W Hilmo
 

For what it's worth, I have two AP mounts, but only one imaging computer.  I also have two different wireless networks, depending on whether I am running at home or in the field (different routers, with different properties).  I connect via Ethernet.

My original plan was to use a static IP address for each mount, but that got to be a hassle, since I could end up with one of 4 different addresses, depending on which mount and router I am using.

So I configured both mounts to be DHCP clients.  I have APCC set up to not connect automatically.  When I start APCC, I use the button that finds the mount, and then connect using IP address (which is a checkbox on the "find mount" screen).

This has been 100% reliable.

If you have a simpler setup than I do, then I would still recommend using DHCP.  I would also configure my router so that the mount gets a permanently reserved lease.  This will cause the mount to get the same IP address each time, so it's as convenient as a static IP address.  If you do that, then you can skip the "find mount" step after the first connection.  If it ever fails to find the mount, you can always try the "find mount" feature again.

I also connect to the mount from my phone via WiFi periodically.  In that case, I have the WiFi on each mount configured to be a hotspot.  I connect directly to the mount's WiFi.  In that case, the IP address of the mount for a wireless connection is the same as the default gateway on the wireless network.

I have never joined the mount directly to any of my wireless networks, and I have never connected via serial or USB, so I can't offer any suggestions on a reliable workflow.  I do assume that the "find mount" steps would work fine if the mount were joined to my main WiFi, and I expect that both serial and USB connections would be pretty seamless (except that you may need to verify the COM port that Windows assigns).

On 10/2/21 9:10 AM, Thomas Giannaccini wrote:
Thank you Christopher; I appreciate the help.

Tom

On Sat, Oct 2, 2021 at 10:00 AM Christopher Erickson <christopher.k.erickson@...> wrote:
Also, the WiFi port and Ethernet port are different networks with different IP addresses. And the CP4 does not route IP traffic between the ports. So if you are connected via Ethernet, for example, the WiFi IP address will be unreachable via the Ethernet network, unless your WiFi and Ethernet networks are bridged at some other point in your network(s).


-Christopher Erickson
Observatory engineer
Waikoloa, HI 96738
www.summitkinetics.com
   

On Sat, Oct 2, 2021, 5:49 PM ap@... <ap@...> wrote:

Thomas Giannaccini wrote:

 

  • I was under the impression that the IP address of the mount is static. Several weeks ago I was on the phone with AP and as part of that call my IP address for the mount was determined. I took a picture of it after I typed it in so that I would have it. Now I am trying to access the mount via ASCOM and ASCOM cannot find the mount. I inquired on Cloudy Nights as to what the issue could be (at the time I was using RDP to a headless PC at the mount) and thought that RDP might be the issue. But When I try to ping the mount's IP address from the command prompt it times out (on 2 different computers going pier to pier via ethernet cable directly to the mount.) This is odd because ASCOM worked before when connected pier to pier. So I'm starting to wonder if I have the wrong IP address? I'm typing it with the picture right in front of me.

 

The controller follows networking standards, which means the address can be assigned either via a static address (human set), a DHCP (IP address) server (home routers sometime do that), or via Windows stupid idiotic inane random address generator.  It all depends on details of your setup, and what you did the first time you used it.

 

So yes, it can change.

 

There’s a rather lengthy discussion on the subject in the “Astro-Physics GTO Servo Drive System Model GTOCP4 Operating Instructions” manual starting on page 12 and page 56 (at least in my version).  My recommendation is use ethernet (not wifi) and the first time you use it enter a static IP address and it will stop changing.

 

 


--
CN: HasAnyoneSeenMyNeblua


Thomas Giannaccini
 

This is very helpful. Thank you

Tom

On Sat, Oct 2, 2021 at 12:09 PM W Hilmo <y.groups@...> wrote:
For what it's worth, I have two AP mounts, but only one imaging computer.  I also have two different wireless networks, depending on whether I am running at home or in the field (different routers, with different properties).  I connect via Ethernet.

My original plan was to use a static IP address for each mount, but that got to be a hassle, since I could end up with one of 4 different addresses, depending on which mount and router I am using.

So I configured both mounts to be DHCP clients.  I have APCC set up to not connect automatically.  When I start APCC, I use the button that finds the mount, and then connect using IP address (which is a checkbox on the "find mount" screen).

This has been 100% reliable.

If you have a simpler setup than I do, then I would still recommend using DHCP.  I would also configure my router so that the mount gets a permanently reserved lease.  This will cause the mount to get the same IP address each time, so it's as convenient as a static IP address.  If you do that, then you can skip the "find mount" step after the first connection.  If it ever fails to find the mount, you can always try the "find mount" feature again.

I also connect to the mount from my phone via WiFi periodically.  In that case, I have the WiFi on each mount configured to be a hotspot.  I connect directly to the mount's WiFi.  In that case, the IP address of the mount for a wireless connection is the same as the default gateway on the wireless network.

I have never joined the mount directly to any of my wireless networks, and I have never connected via serial or USB, so I can't offer any suggestions on a reliable workflow.  I do assume that the "find mount" steps would work fine if the mount were joined to my main WiFi, and I expect that both serial and USB connections would be pretty seamless (except that you may need to verify the COM port that Windows assigns).

On 10/2/21 9:10 AM, Thomas Giannaccini wrote:
Thank you Christopher; I appreciate the help.

Tom

On Sat, Oct 2, 2021 at 10:00 AM Christopher Erickson <christopher.k.erickson@...> wrote:
Also, the WiFi port and Ethernet port are different networks with different IP addresses. And the CP4 does not route IP traffic between the ports. So if you are connected via Ethernet, for example, the WiFi IP address will be unreachable via the Ethernet network, unless your WiFi and Ethernet networks are bridged at some other point in your network(s).


-Christopher Erickson
Observatory engineer
Waikoloa, HI 96738
www.summitkinetics.com
   

On Sat, Oct 2, 2021, 5:49 PM ap@... <ap@...> wrote:

Thomas Giannaccini wrote:

 

  • I was under the impression that the IP address of the mount is static. Several weeks ago I was on the phone with AP and as part of that call my IP address for the mount was determined. I took a picture of it after I typed it in so that I would have it. Now I am trying to access the mount via ASCOM and ASCOM cannot find the mount. I inquired on Cloudy Nights as to what the issue could be (at the time I was using RDP to a headless PC at the mount) and thought that RDP might be the issue. But When I try to ping the mount's IP address from the command prompt it times out (on 2 different computers going pier to pier via ethernet cable directly to the mount.) This is odd because ASCOM worked before when connected pier to pier. So I'm starting to wonder if I have the wrong IP address? I'm typing it with the picture right in front of me.

 

The controller follows networking standards, which means the address can be assigned either via a static address (human set), a DHCP (IP address) server (home routers sometime do that), or via Windows stupid idiotic inane random address generator.  It all depends on details of your setup, and what you did the first time you used it.

 

So yes, it can change.

 

There’s a rather lengthy discussion on the subject in the “Astro-Physics GTO Servo Drive System Model GTOCP4 Operating Instructions” manual starting on page 12 and page 56 (at least in my version).  My recommendation is use ethernet (not wifi) and the first time you use it enter a static IP address and it will stop changing.

 

 


--
CN: HasAnyoneSeenMyNeblua


--
CN: HasAnyoneSeenMyNeblua