Initial GoTo In APCC Pro Cause Nose or Tail Dive


John
 

Aloha All,

  Not sure if I'm doing something wrong or missed a setting somewhere in APCC Pro.  Couldn't find anything in the documentation.  Anyway, after I start apcc, everything connects automatically, the mount unparks (from park 3) and starts tracking.  However, after manually enter a star's coordinates and pressing the 'goto button,' the mach2 mount always does a weird slew (where I have to manually stop it).  At this point I could execute a Park 3, and then press the 'find home' button and then the gotos will work.

  Seems like the only way to avoid this behavior, is to press the 'find home' button first and then do the goto.  Is this the correct procedure that everyone is using?  Just didn't understand why the mount is acting like it's lost, every time it's powered up and initialized via apcc. I think I also tried loading the mount's current ra/dec and then goto that, but that didn't work either.  I don't mind using the 'find home' button each time, I just don't want to break the mount!  :)

  The only reason all of this came up (and the only reason I started trying different goto methods),was because the same thing was happening in Stellarium.

  This isn't a problem with the keypad (with auto connect = yes).  I can power up, the mount will unpark, then I can go into the keypad's objects menu and do a goto without any problem.  Thanks and sorry if this is a repeat question!

      John

 


Ray Gralak
 

John,

If APCC is initializing your Mach 2 you should make sure the Longitude/Latitude/Time Zone are set correctly when APCC initializes the mount. If one of these properties is incorrect, then the mount will not be able to go to the target accurately.

You should also make sure that you are using the latest version of APCC Pro, v1.8.8.9. he direct link is:

http://www.apastrosoftware.com/apcc_download/APCC_Pro_Setup_1.8.8.9.exe

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of John
Sent: Tuesday, December 22, 2020 3:24 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] Initial GoTo In APCC Pro Cause Nose or Tail Dive

Aloha All,

Not sure if I'm doing something wrong or missed a setting somewhere in APCC Pro. Couldn't find anything in the
documentation. Anyway, after I start apcc, everything connects automatically, the mount unparks (from park 3) and
starts tracking. However, after manually enter a star's coordinates and pressing the 'goto button,' the mach2 mount
always does a weird slew (where I have to manually stop it). At this point I could execute a Park 3, and then press the
'find home' button and then the gotos will work.

Seems like the only way to avoid this behavior, is to press the 'find home' button first and then do the goto. Is this the
correct procedure that everyone is using? Just didn't understand why the mount is acting like it's lost, every time it's
powered up and initialized via apcc. I think I also tried loading the mount's current ra/dec and then goto that, but that
didn't work either. I don't mind using the 'find home' button each time, I just don't want to break the mount! :)

The only reason all of this came up (and the only reason I started trying different goto methods),was because the
same thing was happening in Stellarium.

This isn't a problem with the keypad (with auto connect = yes). I can power up, the mount will unpark, then I can go
into the keypad's objects menu and do a goto without any problem. Thanks and sorry if this is a repeat question!

John



Dominique
 

Hi John,
When I received my keypad, I had the same type of problem. Solved by setting the keypad to EXT, which I think gives priority to APCC, but normally if the site initializes on the keypad and APCC there shouldn't be a problem. I did not find any information in the manuals indicating incompatibilities.
Dominique


John
 

Aloha Ray and Dominique,

  Oops, I'm using ver 1.8.8.3.  I'll get the new version installed tonight.  The site location coordinates look good and the time offset is -8.00 for the Pacific time zone.
I'll double check the 'mount location' info in the "Site Tab" after installing the new version and re-connecting to the mount (via Ethernet).  I'm not connected to the mount right now

  What I meant about the keypad, was that I was using the keypad by itself (in stand alone mode with no laptop and no apcc).  As another test (for a goto), I powered up the mount with
just the keypad connected and all the initial gotos worked fine (no nose dive).  I haven't tried using both apcc and the keypad set to EXT yet. 

  I'll reply back after the 1.8.8.9 update,  No big deal if I have to use the 'find home' button first in apcc.  Last night I was thinking that maybe the initial goto nose dives in apcc had to do with me
removing power every night.  Thanks!!

      John

 
 


Roland Christen
 

If that's in the keypad, a -8 puts you somewhere in India or China.

Rolando



-----Original Message-----
From: John <obee11@...>
To: main@ap-gto.groups.io
Sent: Wed, Dec 23, 2020 6:03 pm
Subject: Re: [ap-gto] Initial GoTo In APCC Pro Cause Nose or Tail Dive

Aloha Ray and Dominique,

  Oops, I'm using ver 1.8.8.3.  I'll get the new version installed tonight.  The site location coordinates look good and the time offset is -8.00 for the Pacific time zone.
I'll double check the 'mount location' info in the "Site Tab" after installing the new version and re-connecting to the mount (via Ethernet).  I'm not connected to the mount right now

  What I meant about the keypad, was that I was using the keypad by itself (in stand alone mode with no laptop and no apcc).  As another test (for a goto), I powered up the mount with
just the keypad connected and all the initial gotos worked fine (no nose dive).  I haven't tried using both apcc and the keypad set to EXT yet. 

  I'll reply back after the 1.8.8.9 update,  No big deal if I have to use the 'find home' button first in apcc.  Last night I was thinking that maybe the initial goto nose dives in apcc had to do with me
removing power every night.  Thanks!!

      John

 
 

--
Roland Christen
Astro-Physics


John
 

Aloha All,

  Got the new ver 1.8.8.9 of apcc installed.  The mount is still doing the same thing.  Plug in the power adapter, connected via ethernet, the drivers all connect ok, the
mount unparks automatically from Park 3, and starts tracking.  I enter the coordinates for Capella, press the goto button in apcc and the RA slews about 4 hrs (CW shaft pointed
slightly to the East). and the DEC wants to slew completely around to the south.

  So, I stop the slew.  Park it back to Park 3.  Click the 'find home' button, confirm that by clicking  'yes'  I think this causes the mount to unpark (which is ok).  Then do another
goto, and the mount slews to Capella.

  I thought the offset for the Pacific time zone is UTC -8  China is UTC +8    I'm not sure why the powers to be started using UTC instead of GMT (as in GMT -8).  Doesn't the offset convert
Universal Time Coordinated (UTC) to my Pacific local time.zone?  If it's 2200 in Greenwich England, than it is 2200 - 8.00 hrs or 1400 here in NV...    UTC -7 during the summer    Thanks!

      John


John
 

Aloha All,

  Just looking at this time zone business.  The keypad takes a positive values for the time zone (8 in my case).  As a W was entered earlier to indicate that we are West of the prime
meridian.  I think there's another W in there now (the other W being for Winter)..  APCC takes either a positive or negative value for the offset.

  I just powered up the mount again with just the keypad (by itself) connected to the gtocp5.  The keypad has auto connect = yes, so it is initializing the mount.  The laptop and apcc are not connected
The mount unparks and starts tracking.  The initial goto (using just the keypad) works just fine

  The only issue I'm seeing (if it is an issue), is in apcc.  The only way I can get the initial goto to work in apcc, is by pressing the 'find home' button first and then execute the goto,
which is no big deal, thanks!

      John


Ray Gralak
 

John,

If you correctly initialized the mount with the keypad, then APCC just sends coordinates to the mount. If mount goes in the wrong direction, that implies the keypad initialization was incorrect.

What happens if you let APCC initialize the mount with the keypad not connected? For this test to mean something you must make sure APCC was synched to the mount the last time the mount was powered off.

To make sure you are sending accurate RA/Dec coordinates, you can use a planetarium program to invoke mount slews.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of John
Sent: Wednesday, December 23, 2020 6:54 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Initial GoTo In APCC Pro Cause Nose or Tail Dive

Aloha All,

Just looking at this time zone business. The keypad takes a positive values for the time zone (8 in my case). As a W
was entered earlier to indicate that we are West of the prime
meridian. I think there's another W in there now (the other W being for Winter).. APCC takes either a positive or
negative value for the offset.

I just powered up the mount again with just the keypad (by itself) connected to the gtocp5. The keypad has auto
connect = yes, so it is initializing the mount. The laptop and apcc are not connected
The mount unparks and starts tracking. The initial goto (using just the keypad) works just fine

The only issue I'm seeing (if it is an issue), is in apcc. The only way I can get the initial goto to work in apcc, is by
pressing the 'find home' button first and then execute the goto,
which is no big deal, thanks!

John


Dale Ghent
 

On Dec 23, 2020, at 21:29, John <obee11@gmail.com> wrote:

I thought the offset for the Pacific time zone is UTC -8 China is UTC +8 I'm not sure why the powers to be started using UTC instead of GMT (as in GMT -8). Doesn't the offset convert
Universal Time Coordinated (UTC) to my Pacific local time.zone? If it's 2200 in Greenwich England, than it is 2200 - 8.00 hrs or 1400 here in NV... UTC -7 during the summer Thanks!
Yes, GMT offset is negative to the west, so you are correct there.

UTC and GMT are indeed equivalent, and it might be confusing why both exist when on the surface they seem to be the same thing. But there is a subtle yet important difference - GMT is an actual time zone, where UTC is not. Time zones are the equivalent of political boundaries, but for time. They can change, they are mutable as political, cultural, or other human wants dictate. UTC will always be UTC. It is a fixed, universal time coordinate. Right now, UTC and GMT are the same time reference. It might be in the future that the definition of GMT could change for whatever reason and, if that comes to pass, UTC clocks won't care while things that are pegged to GMT might.

(Modern) Computer clocks run on UTC time. It is the operating system's timezone database that is what converts the UTC time to the local time, general for presentation for the user. Whenever a political whim changes the definition of a time zone, that database needs to be updated lest the users in the affected time zone(s) start seeing the wrong local time. It can see many such changes in a year and why it's impractical for such a database to be included in something like the mount hand controller. Tracking and issuing hand controller firmware updates would be a major time sink, not to mention the amount of limited storage space it would consume to the exclusion of more useful code.

If you're always using your mount with ASCOM/APCC, but still want to use the keypad, then just set the keypad's auto-connect parameter to EXT. This will cause the keypad to NOT be the initializer of the mount and defer to an EXTernal thing to do that job, such as the A-P ASCOM driver or APCC. If your computer's clock is correct and you have the proper timezone specified for under your site's configuration in APCC, then you will not have to worry about manually updating your mount's notion of what local time it is.

/dale


John
 

Aloha Roland and All,

  ok, thanks!  I use to call gmt or utc time zulu (or just Z for short)  as in 22:00Z

  Well, I just noticed something new this morning (regarding the initial goto not working in apcc [no keyapd connected]).

  After connecting to the mount via apcc only (no keypad connected) and unparking, I tried some 'manual' slews, using the N S E W buttons in apcc.  Using the mouse, if I slew the mount
about 20 degrees in DEC (either N or S) and then stop slewing, the current DEC readout (both in apcc and in the driver window) will indicate 00 00 00.  However, while actually pressing
the left mouse button to slew a little more, the correct/current dec value will appear (while slewing and while holding down the left mouse button).  After stopping the slew (by releasing the
left mouse button), the current dec readout will revert back to indicate 00 00 00 again.  This is only occurring with the DEC axis, the RA axis seems to be ok (ie not lost)

  Parking the mount, pressing 'find home' fixes everything again.  I can manually slew the dec about 15 or 20 degrees (either N or S), release the mouse button, and the correct coordinates
are dispalyed in both apcc and in the dirver window.

  For some unknown reason, when connecting via laptop and apcc, the mount isn't keeping it's 'home position.'  It starts up lost (in the dec axis).  Wasn't sure if this was normal.

  It kind of seems like the mount is not initializing correctly with apcc  or if it's not retaining the correct home position (after disconnecting from the mount).  I might unistall both the driver
and apcc and then reinstall both and see if that helps.

      John


Ray Gralak
 

John,

Well, I just noticed something new this morning (regarding the initial goto not working in apcc [no keyapd
connected]).
I'm assuming that you initialized the mount via APCC first?

When you get a chance, use APCC's log zipper and zip all your log files from this morning and post a dropbox (or onedrive or google drive) link to the zip file.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of John
Sent: Thursday, December 24, 2020 10:27 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Initial GoTo In APCC Pro Cause Nose or Tail Dive

Aloha Roland and All,

ok, thanks! I use to call gmt or utc time zulu (or just Z for short) as in 22:00Z

Well, I just noticed something new this morning (regarding the initial goto not working in apcc [no keyapd
connected]).

After connecting to the mount via apcc only (no keypad connected) and unparking, I tried some 'manual' slews,
using the N S E W buttons in apcc. Using the mouse, if I slew the mount
about 20 degrees in DEC (either N or S) and then stop slewing, the current DEC readout (both in apcc and in the
driver window) will indicate 00 00 00. However, while actually pressing
the left mouse button to slew a little more, the correct/current dec value will appear (while slewing and while holding
down the left mouse button). After stopping the slew (by releasing the
left mouse button), the current dec readout will revert back to indicate 00 00 00 again. This is only occurring with
the DEC axis, the RA axis seems to be ok (ie not lost)

Parking the mount, pressing 'find home' fixes everything again. I can manually slew the dec about 15 or 20
degrees (either N or S), release the mouse button, and the correct coordinates
are dispalyed in both apcc and in the dirver window.

For some unknown reason, when connecting via laptop and apcc, the mount isn't keeping it's 'home position.' It
starts up lost (in the dec axis). Wasn't sure if this was normal.

It kind of seems like the mount is not initializing correctly with apcc or if it's not retaining the correct home position
(after disconnecting from the mount). I might unistall both the driver
and apcc and then reinstall both and see if that helps.

John


Roland Christen
 

I would have to let Ray comment on this, as I have never encountered this kind of event. Are you able to park the mount in any of the park positions with the keypad, (not APCC)?

Rolando



-----Original Message-----
From: John <obee11@...>
To: main@ap-gto.groups.io
Sent: Thu, Dec 24, 2020 12:27 pm
Subject: Re: [ap-gto] Initial GoTo In APCC Pro Cause Nose or Tail Dive

Aloha Roland and All,

  ok, thanks!  I use to call gmt or utc time zulu (or just Z for short)  as in 22:00Z

  Well, I just noticed something new this morning (regarding the initial goto not working in apcc [no keyapd connected]).

  After connecting to the mount via apcc only (no keypad connected) and unparking, I tried some 'manual' slews, using the N S E W buttons in apcc.  Using the mouse, if I slew the mount
about 20 degrees in DEC (either N or S) and then stop slewing, the current DEC readout (both in apcc and in the driver window) will indicate 00 00 00.  However, while actually pressing
the left mouse button to slew a little more, the correct/current dec value will appear (while slewing and while holding down the left mouse button).  After stopping the slew (by releasing the
left mouse button), the current dec readout will revert back to indicate 00 00 00 again.  This is only occurring with the DEC axis, the RA axis seems to be ok (ie not lost)

  Parking the mount, pressing 'find home' fixes everything again.  I can manually slew the dec about 15 or 20 degrees (either N or S), release the mouse button, and the correct coordinates
are dispalyed in both apcc and in the dirver window.

  For some unknown reason, when connecting via laptop and apcc, the mount isn't keeping it's 'home position.'  It starts up lost (in the dec axis).  Wasn't sure if this was normal.

  It kind of seems like the mount is not initializing correctly with apcc  or if it's not retaining the correct home position (after disconnecting from the mount).  I might unistall both the driver
and apcc and then reinstall both and see if that helps.

      John

--
Roland Christen
Astro-Physics


John
 

Aloha Roland and Ray,

  Haven't noticed anything unusual when using just the keypad.  It works fine.  No problem with initial gotos and no problems parking the mount.

  Yes I did init the mount first this morning via apcc only (haven't used the keypad this morning)

  The mount is acting lost when initialized via apcc.  Not sure if I was supposed to do this, but I just tried this.   I parked the mount at Park 3, pressed the 'find home' button and
parked the mount again.  Then pressed the 'load mount's ra/dec' button and then pressed the 'sync' button.  After doing all that, I disconnected from the mount, and shutdown apcc,
Then started everything back up, but unfortunately nothing changed.  The mount is still lost.

  Forgot to mention earlier.  After unparking from Park 3 and manually slewing the scope in DEC about 10 degrees (so that the scope is pointed to the East), the yellow counter weight up
notification illuminates in the driver window.  But, the 3d window shows the correct mount scope orientation.  

  Ray, I'll look for the log files and get those out to you (probably on google drive),  I just double checked the lat/long and time zone again in the driver and they're ok.  I also just saw the zipper
button in there.  Thanks for everything!!  And sorry for all the trouble and thanks for the quick reply (on Christmas Eve)...  :)

      John



John
 

Aloha Ray,

  I just sent the log files to your group3 email address.

  I also tried a different ethernet cable, but no luck.  And I swapped the RA and DEC cables (that go from the gtocp5 to the back of the mount).  After doing that,
I was checking to see if the slew issue in DEC would migrate over to the RA axis.  But, nothing changed.  I guess the cables are ok.  Thanks!!

    John


Ray Gralak
 

Hi John,

I just sent the log files to your group3 email address.
I got your zip file of the logs, but the zip only contained ASCOM logs. I need to see the APCC logs as well. I provided a screenshot of how to get them all via the APCC Log zipper.

Note that if the zip file is too large (>10 Mbytes) I may not be able to receive it as an attachment. In that case, please provide a link.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of John
Sent: Thursday, December 24, 2020 12:08 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Initial GoTo In APCC Pro Cause Nose or Tail Dive

Aloha Ray,

I just sent the log files to your group3 email address.

I also tried a different ethernet cable, but no luck. And I swapped the RA and DEC cables (that go from the gtocp5 to
the back of the mount). After doing that,
I was checking to see if the slew issue in DEC would migrate over to the RA axis. But, nothing changed. I guess the
cables are ok. Thanks!!

John


John
 

Aloha Ray,

  2 days worth came out to be about 11mbs.  I just tried sending the zip file via email, thanks!

      John


Ray Gralak
 

Hi John,

After connecting to the mount via apcc only (no keypad connected) and unparking, I tried some 'manual' slews, using
the N S E W buttons in apcc. Using the mouse, if I slew the mount
about 20 degrees in DEC (either N or S) and then stop slewing, the current DEC readout (both in apcc and in the
driver window) will indicate 00 00 00.
I finally had a chance to go through your logs, and unfortunately, I cannot find any indication of the behavior you were seeing.

How about trying this again and taking a screenshot of what you are seeing (Dec=00 00 00)?

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of John
Sent: Thursday, December 24, 2020 3:19 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Initial GoTo In APCC Pro Cause Nose or Tail Dive

Aloha Ray,

2 days worth came out to be about 11mbs. I just tried sending the zip file via email, thanks!

John


John
 

Aloha Ray,

  ok, I'll get some screen shots sent over to you.  I'll just put them all in a MS Word doc.

  I was connecting to it again today, but it's still doing the same thing.  The only thing new (that I noticed) was that the DEC
coordinates displayed correctly whenever the dec was within 10 degrees of Park 3.  In other words, once you slew more than
10 degree in DEC, release the mouse button, then the dec readout indicates 00 00 00.

  I was looking in the APCC PRO user guide to see if I could initialize the mount again (after sending it home), but they may not be an option

  Thanks!

      John


Ray Gralak
 

John,

I just tried unparking from Park 3 and using the move buttons to move more than 10 degrees from (Park 3 dec = +89 59 59)

See attached image.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of John
Sent: Saturday, December 26, 2020 2:42 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Initial GoTo In APCC Pro Cause Nose or Tail Dive

Aloha Ray,

ok, I'll get some screen shots sent over to you. I'll just put them all in a MS Word doc.

I was connecting to it again today, but it's still doing the same thing. The only thing new (that I noticed) was that the
DEC
coordinates displayed correctly whenever the dec was within 10 degrees of Park 3. In other words, once you slew
more than
10 degree in DEC, release the mouse button, then the dec readout indicates 00 00 00.

I was looking in the APCC PRO user guide to see if I could initialize the mount again (after sending it home), but they
may not be an option

Thanks!

John


John
 

Aloha Ray,

  I just sent you the screen shots via email.

  Once I slew more than 10 degrees (in either direction), stop the slew, the DEC reads 00 00 00.  While slewing and holding down the left
mouse button, I can see the DEC coordinates actually slewing/changing.  But after stopping the slew, the DEC coordinates revert to 00 00 00
Kind of strange...

  After pressing the 'find home' button, the DEC displays the coordinates correctly (after the slew stops) and like what you're seeing in your screen shot
Hope the screen shots help, thanks!

      John