Having lots of issues with APCC, Point mapper and other ASCOM products...


Tom Blahovici
 

Hi,
I am not even sure I know where to start here but something is not right. First I need to point out that I have had a perfectly working setup in the past with my AP600 and Voyager and PhD Guider.  All this has changed now that I have APCC Pro.

Tonight is an example.  I startup APCC and connect to the mount with an IP Address.  This works fine. I then started the Point mapper and had to click on the Connect in APCC for the ASCOM driver.  I then had to select the virtual port in the settings for the ASCOM connection in the point mapper.  This connects and works fine.

When the point mapping is complete I close the program and attempt to startup Voyager which in turn starts PhD Guider.  However, Voyager locks up trying to connect to the AP driver.  Same with PhD Guider.  At this point I have to kill the processes and then reboot the computer.  Note that both, are trying to use the virtual port in the AP driver.

If I start from scratch and tell Voyager that I am using the AP Ascom driver the only thing that works is if I select the IP address and NOT the virtual port.  Same thing for PhD guider.  So I now have three applications going direct to the IP address. This is not right, correct?

So my questions besides the fact that the I cannot use the virtual ports with anything other than the point mapper program are the following:
If all devices are going directly to the IP address then are they using the model I created? Or not?

What's the point of the virtual ports if everything connects directly to the IP address?

Does each application need to use their own virtual port?

Why is everything locking up?
Perhaps if all this is explained with how it actually functions I can make some sense out of this.

Thanks for your help.
BTW, All software is the latest, downloaded two days ago.

Tom





Ray Gralak
 

Hi Tom,

This is not a problem with ASCOM or APCC. The problem is that Voyager needs to be run "as administrator", which complicates things because all other of the applications also need to be run "as administrator", which is not the default way applications usually are run.

An application that is running "as administrator" that connects to the AP V2 ASCOM driver opens a *different* instance of the AP V2 driver than if another application connects that is running normally. So, in a setting with mixed normal/administrator applications you can have two instances of the AP V2 ASCOM driver running, and they cannot both share the same virtual COM port. So in that sense, they must use two different virtual COM ports,

This issue has been discussed many, many times, so you might want to do a web search to read more about it if you are interested. But the short answer is that you may need to run all of your astronomy applications "as administrator" if you want to use Voyager.

-Ray

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Tom Blahovici
Sent: Monday, September 20, 2021 7:53 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] Having lots of issues with APCC, Point mapper and other ASCOM products...

Hi,
I am not even sure I know where to start here but something is not right. First I need to point out that I have
had a perfectly working setup in the past with my AP600 and Voyager and PhD Guider. All this has changed
now that I have APCC Pro.

Tonight is an example. I startup APCC and connect to the mount with an IP Address. This works fine. I then
started the Point mapper and had to click on the Connect in APCC for the ASCOM driver. I then had to select
the virtual port in the settings for the ASCOM connection in the point mapper. This connects and works fine.

When the point mapping is complete I close the program and attempt to startup Voyager which in turn starts
PhD Guider. However, Voyager locks up trying to connect to the AP driver. Same with PhD Guider. At this
point I have to kill the processes and then reboot the computer. Note that both, are trying to use the virtual
port in the AP driver.

If I start from scratch and tell Voyager that I am using the AP Ascom driver the only thing that works is if I
select the IP address and NOT the virtual port. Same thing for PhD guider. So I now have three applications
going direct to the IP address. This is not right, correct?

So my questions besides the fact that the I cannot use the virtual ports with anything other than the point
mapper program are the following:
If all devices are going directly to the IP address then are they using the model I created? Or not?

What's the point of the virtual ports if everything connects directly to the IP address?

Does each application need to use their own virtual port?

Why is everything locking up?
Perhaps if all this is explained with how it actually functions I can make some sense out of this.

Thanks for your help.
BTW, All software is the latest, downloaded two days ago.

Tom







Bill Long
 

You can turn off run as admin for Voyager and see if everything functions fine. If it does, no harm done.

If you contact them for support in the future they will ask you to turn run as admin back on. 


From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Tom Blahovici <tom.va2fsq@...>
Sent: Monday, September 20, 2021 7:53 PM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: [ap-gto] Having lots of issues with APCC, Point mapper and other ASCOM products...
 

Hi,
I am not even sure I know where to start here but something is not right. First I need to point out that I have had a perfectly working setup in the past with my AP600 and Voyager and PhD Guider.  All this has changed now that I have APCC Pro.

Tonight is an example.  I startup APCC and connect to the mount with an IP Address.  This works fine. I then started the Point mapper and had to click on the Connect in APCC for the ASCOM driver.  I then had to select the virtual port in the settings for the ASCOM connection in the point mapper.  This connects and works fine.

When the point mapping is complete I close the program and attempt to startup Voyager which in turn starts PhD Guider.  However, Voyager locks up trying to connect to the AP driver.  Same with PhD Guider.  At this point I have to kill the processes and then reboot the computer.  Note that both, are trying to use the virtual port in the AP driver.

If I start from scratch and tell Voyager that I am using the AP Ascom driver the only thing that works is if I select the IP address and NOT the virtual port.  Same thing for PhD guider.  So I now have three applications going direct to the IP address. This is not right, correct?

So my questions besides the fact that the I cannot use the virtual ports with anything other than the point mapper program are the following:
If all devices are going directly to the IP address then are they using the model I created? Or not?

What's the point of the virtual ports if everything connects directly to the IP address?

Does each application need to use their own virtual port?

Why is everything locking up?
Perhaps if all this is explained with how it actually functions I can make some sense out of this.

Thanks for your help.
BTW, All software is the latest, downloaded two days ago.

Tom





Tom Blahovici
 

HI
Ok.  Actually what was happening is that none of the virtual ports were being created.  Now that they are, it seems to be fine.  However, I have some questions.

1. What is the purpose of the AP V2 connect button in APCC? Why does APCC need to connect to the driver? Applications seem to work fine even if this is not connected.
2. Once I have my mapping done, do I need to use the APPM software to do an initial sync and recal before using Voyager?
3. Must all recals be turned off in other software when you are using a model?
4. Tonight I did a 100 point model. When the scope went into the west, clouds rolled in and I only got part of the points there.  Do I need to redo the whole model?  Or can just the missing points be done or added?
I guess that covers the questions for now.

Thanks, Tom


 

Hi Tom

i'm up so i'll take a crack here ;)


1. What is the purpose of the AP V2 connect button in APCC? Why does APCC need to connect to the driver? Applications seem to work fine even if this is not connected.

You definitely want the AP ASCOM driver to connect through APCC, that's how the modeling is transparent to your connecting applications. I always start up APCC first and auto connect ASCOM driver to it.
  
2. Once I have my mapping done, do I need to use the APPM software to do an initial sync and recal before using Voyager?

No - it already did a sync and recal as part of the modeling. If you are doing plate solve/centering in Voyager i assume it will work like other imaging apps and use Sync for centering routines anyways
 
3. Must all recals be turned off in other software when you are using a model?

No - plate solve uses sync which is required when centering a target. See 1. above re: connect the ascom driver through APCC and the model is transparent to applications
 
4. Tonight I did a 100 point model. When the scope went into the west, clouds rolled in and I only got part of the points there.  Do I need to redo the whole model?  Or can just the missing points be done or added?

afaik you can't add to an existing model, you can only re-do it, so i think you need to re-do the model

 
I guess that covers the questions for now.

Thanks, Tom



--
Brian 



Brian Valente


Tom Blahovici
 

Thanks Brian. Answers a lot.

There are a couple of other items.
Voyager has a mount option to not do a recal. It's called "Not sync if using pointing model. " That's why I asked.

Now I used PemPro for the polar alignment. It gave me a drift of 15 arc seconds over 10 minutes in both axis. However after the model, the parameters for the polar alignment said I was off by 1.5 minutes in azimuth. How is this reconciled?

I'm getting there.
Tom


Ray Gralak
 

Hi Tom,

Ok. Actually what was happening is that none of the virtual ports were being created. Now that they are, it
seems to be fine.
APCC's Mount group box settings are set by default to allocate and create the virtual ports when APCC starts. Unless you have a good reason to change the settings, you shouldn't change them. Specifically, you should leave the Mount group box's "Auto-Connect" and "Create Virtual ports first" enabled. Also, the AP V2 Driver's "Auto-Config" should be enabled. This last setting is very important, because it reconfigures the ASCOM driver's port number to whatever virtual ports APCC dynamically allocates.

-Ray

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Tom Blahovici
Sent: Monday, September 20, 2021 9:48 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Having lots of issues with APCC, Point mapper and other ASCOM products...

HI
Ok. Actually what was happening is that none of the virtual ports were being created. Now that they are, it
seems to be fine. However, I have some questions.

1. What is the purpose of the AP V2 connect button in APCC? Why does APCC need to connect to the driver?
Applications seem to work fine even if this is not connected.
2. Once I have my mapping done, do I need to use the APPM software to do an initial sync and recal before
using Voyager?
3. Must all recals be turned off in other software when you are using a model?
4. Tonight I did a 100 point model. When the scope went into the west, clouds rolled in and I only got part of
the points there. Do I need to redo the whole model? Or can just the missing points be done or added?
I guess that covers the questions for now.

Thanks, Tom


Ray Gralak
 

There are a couple of other items.
Voyager has a mount option to not do a recal. It's called "Not sync if using pointing model. " That's why I
asked.
It should be okay to leave that enabled if you want. You can sync (recal) into APCC's model as long as the coordinates are accurate. A bad plate solve (one that "succeeds" but with wrong coordinates) would obviously not do what you want, so APCC provides some protection against this if "Prevent Errant RECALs" is turned on in APCC's advanced settings (which it is by default.)

Now I used PemPro for the polar alignment. It gave me a drift of 15 arc seconds over 10 minutes in both axis.
However after the model, the parameters for the polar alignment said I was off by 1.5 minutes in azimuth. How
is this reconciled?
You don't need to do anything. The model automatically corrects for polar alignment errors.

-Ray


Tom Blahovici
 

Hi
Thanks Ray.  I think all is now cleared up.
Best regards, Tom