Topics

Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver


Howard Hedlund
 
Edited

There is a problem with the latest ASCOM Platform - v. 6.5 that prevents correct plate solutions in APPM.  We hope for a resolution to this problem soon.  In the meantime, please use v.6.4 SP1.https://github.com/ASCOMInitiative/ASCOMPlatform/releases/tag/Build_2695


Terri Zittritsch
 

On Mon, Sep 14, 2020 at 09:32 AM, Howard Hedlund wrote:
here is a problem with the latest ASCOM Platform - v. 6.5 that prevents correct plate solutions in APPM.  We hope for a resolution to this problem soon.  In the meantime, please use v.6.4 SP1.https://github.com/ASCOMInitiative/ASCOMPlatform/releases/tag/Build_2695
Howard, do you know if this is just with APPM?    I noticed this past weekend when I was doing plate solving that platesolve2 in sgpro was having issues (I have ASCOM 6.5 installed).  I thought it was the normal due to the dense star field I was in.   I moved to ASTAP solver based on recommendations from another member and it worked fine, in fact, about 10X faster than Platesolve2.    But I was NOT using APPM.     


Terri


John Stiner
 

Terri, I had a simile experience with plate-solving via PlateSolve2 with SGP. After updating to ASCOM 6.5, when I initiated a sequence, SGP would reflect that the mount was slewing to the target but it was not actually slewing.  When I used APCC to actually slew the scope to the target, after capturing a frame to solve, SGP (or PlateSolve2–not sure which) would indicate it was correcting the scope’s position but it was again staying in the same place. After uninstalling ASCOM 6.5 and reinstalling 6.4, SGP now slews in sequence start-up. I’ll check the plate-solving corrections tonight. 


George LaBelle
 
Edited

So, what is wrong with ASCOM 6.5 - or is there something in SGP/APPM/PlateSolve/???

This has been known about for some time. Is it being worked on?

--
George
Prineville, Oregon


Andrew Jones
 

Hi Howard.

I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same plate solve results for every image. I was about to post the issue here, when I saw your post. Any eta on when this issue will be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP  and other software I am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this issue will be fixed that would be great.

Andrew J


Ray Gralak
 

Hi Andrew,

If you could provide an update on when this issue will be
fixed that would be great.
Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which is in ASCOM, not APCC).

However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed has the fix, then here is the link:

https://download.ascom-standards.org/beta/ASCOMPlatform65.exe

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
Sent: Saturday, October 31, 2020 2:20 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver

Hi Howard.

I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same plate solve
results for every image. I was about to post the issue here, when I saw your post. Any eta on when this issue will
be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP and other software I
am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this issue will be
fixed that would be great.

Andrew J


Yves Laroche
 

Hi Ray,

Did a point run last night and got bad results with ASCOM 6.5 SP2.  Downgraded to version ASCOM 6.4RC1 and everything went fine.

You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused.  Is the beta 6.5RC1 version the same as non-beta 6.5RC1?

Regards,
Yves



Le 31/10/20 12:31, Ray Gralak <groups3@...> a écrit :
Hi Andrew,

> If you could provide an update on when this issue will be
> fixed that would be great.

Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which is in ASCOM, not APCC).

However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed has the fix, then here is the link:

https://download.ascom-standards.org/beta/ASCOMPlatform65.exe

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
> Sent: Saturday, October 31, 2020 2:20 AM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>
> Hi Howard.
>
> I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same plate solve
> results for every image. I was about to post the issue here, when I saw your post. Any eta on when this issue will
> be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP  and other software I
> am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this issue will be
> fixed that would be great.
>
> Andrew J
>







Yves Laroche
 

Hi Ray,

Just did a few mapping points with ASCOM 6.5 SP1 - 6.5.1.3136 (link you provided) and everything is going well.  It's seems that the problem appeared with SP2.

Regards,
Yves



Le 31/10/20 17:19, Yves Laroche <yves.laroche@...> a écrit :
Hi Ray,

Did a point run last night and got bad results with ASCOM 6.5 SP2.  Downgraded to version ASCOM 6.4RC1 and everything went fine.

You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused.  Is the beta 6.5RC1 version the same as non-beta 6.5RC1?

Regards,
Yves



Le 31/10/20 12:31, Ray Gralak <groups3@...> a écrit :
Hi Andrew,

> If you could provide an update on when this issue will be
> fixed that would be great.

Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which is in ASCOM, not APCC).

However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed has the fix, then here is the link:

https://download.ascom-standards.org/beta/ASCOMPlatform65.exe

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
> Sent: Saturday, October 31, 2020 2:20 AM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>
> Hi Howard.
>
> I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same plate solve
> results for every image. I was about to post the issue here, when I saw your post. Any eta on when this issue will
> be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP  and other software I
> am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this issue will be
> fixed that would be great.
>
> Andrew J
>







Ray Gralak
 

Hi Yves,

Did a point run last night and got bad results with ASCOM 6.5 SP2. Downgraded to version ASCOM 6.4RC1 and
everything went fine.
I am not sure what you mean... there is no ASCOM 6.5 SP2. Did you mean SP1?

You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused. Is the beta 6.5RC1 version the same as
non-beta 6.5RC1?
You'll have to ask that question on the ASCOM group. I haven't been keeping track of the changes they make. I was told the link I posted is to the 6.5 SP1 beta.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
Sent: Saturday, October 31, 2020 2:19 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver

Hi Ray,

Did a point run last night and got bad results with ASCOM 6.5 SP2. Downgraded to version ASCOM 6.4RC1 and
everything went fine.

You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused. Is the beta 6.5RC1 version the same as
non-beta 6.5RC1?

Regards,
Yves



Le 31/10/20 12:31, Ray Gralak <groups3@gralak.com> a écrit :

Hi Andrew,

> If you could provide an update on when this issue will be
> fixed that would be great.

Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which is in
ASCOM, not APCC).

However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed has the
fix, then here is the link:

https://download.ascom-standards.org/beta/ASCOMPlatform65.exe

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
> Sent: Saturday, October 31, 2020 2:20 AM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>
> Hi Howard.
>
> I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same plate
solve
> results for every image. I was about to post the issue here, when I saw your post. Any eta on when this
issue will
> be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP and other
software I
> am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this issue
will be
> fixed that would be great.
>
> Andrew J
>









Ray Gralak
 

Just did a few mapping points with ASCOM 6.5 SP1 - 6.5.1.3136 (link you provided) and everything is going well.
It's seems that the problem appeared with SP2.
Again, I don't even think ASCOM 6.5 SP1 has been released, so are you sure there is a 6.5 SP2?

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
Sent: Saturday, October 31, 2020 4:15 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver

Hi Ray,

Just did a few mapping points with ASCOM 6.5 SP1 - 6.5.1.3136 (link you provided) and everything is going well.
It's seems that the problem appeared with SP2.

Regards,
Yves



Le 31/10/20 17:19, Yves Laroche <yves.laroche@videotron.ca> a écrit :

Hi Ray,

Did a point run last night and got bad results with ASCOM 6.5 SP2. Downgraded to version ASCOM
6.4RC1 and everything went fine.

You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused. Is the beta 6.5RC1 version the same
as non-beta 6.5RC1?

Regards,
Yves



Le 31/10/20 12:31, Ray Gralak <groups3@gralak.com> a écrit :

Hi Andrew,

> If you could provide an update on when this issue will be
> fixed that would be great.

Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which
is in ASCOM, not APCC).

However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed
has the fix, then here is the link:

https://download.ascom-standards.org/beta/ASCOMPlatform65.exe

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
> Sent: Saturday, October 31, 2020 2:20 AM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC
#ASCOM_V2_Driver
>
> Hi Howard.
>
> I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same
plate solve
> results for every image. I was about to post the issue here, when I saw your post. Any eta on
when this issue will
> be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP and
other software I
> am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this
issue will be
> fixed that would be great.
>
> Andrew J
>









Yves Laroche
 

Hi Ray,

Yes, there was an ASCOM 6.5RC2.  Just checked the GitHub web site but no executable file found anymore even if it's written 6.5RC2.

I already got this file on my USB key and initiated an installation to be sure it is version 6.5RC2 and it was.  This was the version with I've tested APPM last night but without success.

Regards,
Yves

.


Le 31/10/20 21:35, Ray Gralak <groups3@...> a écrit :
Hi Yves,

> Did a point run last night and got bad results with ASCOM 6.5 SP2.  Downgraded to version ASCOM 6.4RC1 and
> everything went fine.

I am not sure what you mean... there is no ASCOM 6.5 SP2. Did you mean SP1?

> You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused.  Is the beta 6.5RC1 version the same as
> non-beta 6.5RC1?

You'll have to ask that question on the ASCOM group. I haven't been keeping track of the changes they make. I was told the link I posted is to the 6.5 SP1 beta.
 
-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
> Sent: Saturday, October 31, 2020 2:19 PM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>
> Hi Ray,
>
> Did a point run last night and got bad results with ASCOM 6.5 SP2.  Downgraded to version ASCOM 6.4RC1 and
> everything went fine.
>
> You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused.  Is the beta 6.5RC1 version the same as
> non-beta 6.5RC1?
>
> Regards,
> Yves
>
>
>
> Le 31/10/20 12:31, Ray Gralak <groups3@...> a écrit :
>
>  Hi Andrew,
>
>  > If you could provide an update on when this issue will be
>  > fixed that would be great.
>
>  Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which is in
> ASCOM, not APCC).
>
>  However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed has the
> fix, then here is the link:
>
https://download.ascom-standards.org/beta/ASCOMPlatform65.exe
>
>  -Ray Gralak
>  Author of PEMPro
>  Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
>  Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
>
>  > -----Original Message-----
>  > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
>  > Sent: Saturday, October 31, 2020 2:20 AM
>  > To: main@ap-gto.groups.io
>  > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>  >
>  > Hi Howard.
>  >
>  > I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same plate
> solve
>  > results for every image. I was about to post the issue here, when I saw your post. Any eta on when this
> issue will
>  > be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP  and other
> software I
>  > am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this issue
> will be
>  > fixed that would be great.
>  >
>  > Andrew J
>  >
>
>
>
>
>
>
>
>
>







Yves Laroche
 

Ray,

Here is the proof without a doubt why I was confused about the ASCOM Release Candidate version.

On the attached ASCOM diagnostics window it's written 6.5RC2 - 6.5.0.3035.  Maybe it should be written 6.5.2.3035 if it was a true RC2 version.  My executable file always referred to RC2 during the installation process too.

Hope this will help clarify things.

Regards,
Yves





Le 31/10/20 21:37, Ray Gralak <groups3@...> a écrit :
> Just did a few mapping points with ASCOM 6.5 SP1 - 6.5.1.3136 (link you provided) and everything is going well.
> It's seems that the problem appeared with SP2.

Again, I don't even think ASCOM 6.5 SP1 has been released, so are you sure there is a 6.5 SP2?

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
> Sent: Saturday, October 31, 2020 4:15 PM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>
> Hi Ray,
>
> Just did a few mapping points with ASCOM 6.5 SP1 - 6.5.1.3136 (link you provided) and everything is going well.
> It's seems that the problem appeared with SP2.
>
> Regards,
> Yves
>
>
>
> Le 31/10/20 17:19, Yves Laroche <yves.laroche@...> a écrit :
>
>  Hi Ray,
>
>  Did a point run last night and got bad results with ASCOM 6.5 SP2.  Downgraded to version ASCOM
> 6.4RC1 and everything went fine.
>
>  You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused.  Is the beta 6.5RC1 version the same
> as non-beta 6.5RC1?
>
>  Regards,
>  Yves
>
>
>
>  Le 31/10/20 12:31, Ray Gralak <groups3@...> a écrit :
>
>          Hi Andrew,
>
>          > If you could provide an update on when this issue will be
>          > fixed that would be great.
>
>          Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which
> is in ASCOM, not APCC).
>
>          However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed
> has the fix, then here is the link:
>
>          https://download.ascom-standards.org/beta/ASCOMPlatform65.exe
>
>          -Ray Gralak
>          Author of PEMPro
>          Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
>          Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
>
>          > -----Original Message-----
>          > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
>          > Sent: Saturday, October 31, 2020 2:20 AM
>          > To: main@ap-gto.groups.io
>          > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC
> #ASCOM_V2_Driver
>          >
>          > Hi Howard.
>          >
>          > I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same
> plate solve
>          > results for every image. I was about to post the issue here, when I saw your post. Any eta on
> when this issue will
>          > be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP  and
> other software I
>          > am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this
> issue will be
>          > fixed that would be great.
>          >
>          > Andrew J
>          >
>
>
>
>
>
>
>
>
>







Ray Gralak
 

Yes, there was an ASCOM 6.5RC2.
That's not what you wrote... You wrote "SP2", not "RC2".

(SP = Service Pack) (RC = Release Candidate)

They have completely different meanings.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
Sent: Saturday, October 31, 2020 6:47 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver

Hi Ray,

Yes, there was an ASCOM 6.5RC2. Just checked the GitHub web site but no executable file found anymore even
if it's written 6.5RC2.

I already got this file on my USB key and initiated an installation to be sure it is version 6.5RC2 and it was. This
was the version with I've tested APPM last night but without success.

Regards,
Yves

.

Le 31/10/20 21:35, Ray Gralak <groups3@gralak.com> a écrit :

Hi Yves,

> Did a point run last night and got bad results with ASCOM 6.5 SP2. Downgraded to version ASCOM
6.4RC1 and
> everything went fine.

I am not sure what you mean... there is no ASCOM 6.5 SP2. Did you mean SP1?

> You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused. Is the beta 6.5RC1 version the
same as
> non-beta 6.5RC1?

You'll have to ask that question on the ASCOM group. I haven't been keeping track of the changes they
make. I was told the link I posted is to the 6.5 SP1 beta.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
> Sent: Saturday, October 31, 2020 2:19 PM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>
> Hi Ray,
>
> Did a point run last night and got bad results with ASCOM 6.5 SP2. Downgraded to version ASCOM
6.4RC1 and
> everything went fine.
>
> You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused. Is the beta 6.5RC1 version the
same as
> non-beta 6.5RC1?
>
> Regards,
> Yves
>
>
>
> Le 31/10/20 12:31, Ray Gralak <groups3@gralak.com> a écrit :
>
> Hi Andrew,
>
> > If you could provide an update on when this issue will be
> > fixed that would be great.
>
> Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which is
in
> ASCOM, not APCC).
>
> However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed has
the
> fix, then here is the link:
>
> https://download.ascom-standards.org/beta/ASCOMPlatform65.exe
>
> -Ray Gralak
> Author of PEMPro
> Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
> Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
>
> > -----Original Message-----
> > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
> > Sent: Saturday, October 31, 2020 2:20 AM
> > To: main@ap-gto.groups.io
> > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC
#ASCOM_V2_Driver
> >
> > Hi Howard.
> >
> > I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same plate
> solve
> > results for every image. I was about to post the issue here, when I saw your post. Any eta on when
this
> issue will
> > be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP and other
> software I
> > am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this
issue
> will be
> > fixed that would be great.
> >
> > Andrew J
> >
>
>
>
>
>
>
>
>
>









 

I think that was 2nd version of release candidate for 6.5 platform.

then the 6.5 release happened, which superseded that. 

6.5 SP1 beta is after this initial release

On Sat, Oct 31, 2020 at 6:46 PM Yves Laroche <yves.laroche@...> wrote:
Hi Ray,

Yes, there was an ASCOM 6.5RC2.  Just checked the GitHub web site but no executable file found anymore even if it's written 6.5RC2.

I already got this file on my USB key and initiated an installation to be sure it is version 6.5RC2 and it was.  This was the version with I've tested APPM last night but without success.

Regards,
Yves

.

Le 31/10/20 21:35, Ray Gralak <groups3@...> a écrit :
Hi Yves,

> Did a point run last night and got bad results with ASCOM 6.5 SP2.  Downgraded to version ASCOM 6.4RC1 and
> everything went fine.

I am not sure what you mean... there is no ASCOM 6.5 SP2. Did you mean SP1?

> You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused.  Is the beta 6.5RC1 version the same as
> non-beta 6.5RC1?

You'll have to ask that question on the ASCOM group. I haven't been keeping track of the changes they make. I was told the link I posted is to the 6.5 SP1 beta.
 
-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
> Sent: Saturday, October 31, 2020 2:19 PM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>
> Hi Ray,
>
> Did a point run last night and got bad results with ASCOM 6.5 SP2.  Downgraded to version ASCOM 6.4RC1 and
> everything went fine.
>
> You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused.  Is the beta 6.5RC1 version the same as
> non-beta 6.5RC1?
>
> Regards,
> Yves
>
>
>
> Le 31/10/20 12:31, Ray Gralak <groups3@...> a écrit :
>
>  Hi Andrew,
>
>  > If you could provide an update on when this issue will be
>  > fixed that would be great.
>
>  Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which is in
> ASCOM, not APCC).
>
>  However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed has the
> fix, then here is the link:
>
https://download.ascom-standards.org/beta/ASCOMPlatform65.exe
>
>  -Ray Gralak
>  Author of PEMPro
>  Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
>  Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
>
>  > -----Original Message-----
>  > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
>  > Sent: Saturday, October 31, 2020 2:20 AM
>  > To: main@ap-gto.groups.io
>  > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>  >
>  > Hi Howard.
>  >
>  > I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same plate
> solve
>  > results for every image. I was about to post the issue here, when I saw your post. Any eta on when this
> issue will
>  > be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP  and other
> software I
>  > am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this issue
> will be
>  > fixed that would be great.
>  >
>  > Andrew J
>  >
>
>
>
>
>
>
>
>
>








--
Brian 



Brian Valente


Yves Laroche
 

Sorry Ray,  a typo error...I meant RC2 !!!

Yves



Le 31/10/20 23:19, Ray Gralak <groups3@...> a écrit :
> Yes, there was an ASCOM 6.5RC2.

That's not what you wrote... You wrote "SP2", not "RC2".

(SP = Service Pack) (RC = Release Candidate)

They have completely different meanings.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
> Sent: Saturday, October 31, 2020 6:47 PM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>
> Hi Ray,
>
> Yes, there was an ASCOM 6.5RC2.  Just checked the GitHub web site but no executable file found anymore even
> if it's written 6.5RC2.
>
> I already got this file on my USB key and initiated an installation to be sure it is version 6.5RC2 and it was.  This
> was the version with I've tested APPM last night but without success.
>
> Regards,
> Yves
>
> .
>
> Le 31/10/20 21:35, Ray Gralak <groups3@...> a écrit :
>
>  Hi Yves,
>
>  > Did a point run last night and got bad results with ASCOM 6.5 SP2.  Downgraded to version ASCOM
> 6.4RC1 and
>  > everything went fine.
>
>  I am not sure what you mean... there is no ASCOM 6.5 SP2. Did you mean SP1?
>
>  > You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused.  Is the beta 6.5RC1 version the
> same as
>  > non-beta 6.5RC1?
>
>  You'll have to ask that question on the ASCOM group. I haven't been keeping track of the changes they
> make. I was told the link I posted is to the 6.5 SP1 beta.
>
>  -Ray Gralak
>  Author of PEMPro
>  Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
>  Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
>
>
>  > -----Original Message-----
>  > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
>  > Sent: Saturday, October 31, 2020 2:19 PM
>  > To: main@ap-gto.groups.io
>  > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>  >
>  > Hi Ray,
>  >
>  > Did a point run last night and got bad results with ASCOM 6.5 SP2.  Downgraded to version ASCOM
> 6.4RC1 and
>  > everything went fine.
>  >
>  > You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused.  Is the beta 6.5RC1 version the
> same as
>  > non-beta 6.5RC1?
>  >
>  > Regards,
>  > Yves
>  >
>  >
>  >
>  > Le 31/10/20 12:31, Ray Gralak <groups3@...> a écrit :
>  >
>  >  Hi Andrew,
>  >
>  >  > If you could provide an update on when this issue will be
>  >  > fixed that would be great.
>  >
>  >  Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which is
> in
>  > ASCOM, not APCC).
>  >
>  >  However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed has
> the
>  > fix, then here is the link:
>  >
>  >  https://download.ascom-standards.org/beta/ASCOMPlatform65.exe
>  >
>  >  -Ray Gralak
>  >  Author of PEMPro
>  >  Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
>  >  Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
>  >
>  >  > -----Original Message-----
>  >  > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
>  >  > Sent: Saturday, October 31, 2020 2:20 AM
>  >  > To: main@ap-gto.groups.io
>  >  > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC
> #ASCOM_V2_Driver
>  >  >
>  >  > Hi Howard.
>  >  >
>  >  > I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same plate
>  > solve
>  >  > results for every image. I was about to post the issue here, when I saw your post. Any eta on when
> this
>  > issue will
>  >  > be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP  and other
>  > software I
>  >  > am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this
> issue
>  > will be
>  >  > fixed that would be great.
>  >  >
>  >  > Andrew J
>  >  >
>  >
>  >
>  >
>  >
>  >
>  >
>  >
>  >
>  >
>
>
>
>
>
>
>
>
>







Ray Gralak
 

Hi Yves,

Sorry Ray, a typo error...I meant RC2 !!!
Okay, thanks. That *almost* clears things up. :-)

Since ASCOM 6.5 platform has been released, any RC (release candidate) would be older than the current release.

So, if you are using APCC Pro you must use one of the following ASCOM versions:

1. ASCOM 6.4 SP2
2. ASCOM 6.5 SP1 Beta (the link I provided).
3. The as yet unreleased, ASCOM 6.5 SP1

Where again, "SP" stands for "Service Pack".

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
Sent: Saturday, October 31, 2020 8:40 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver

Sorry Ray, a typo error...I meant RC2 !!!

Yves



Le 31/10/20 23:19, Ray Gralak <groups3@gralak.com> a écrit :

> Yes, there was an ASCOM 6.5RC2.

That's not what you wrote... You wrote "SP2", not "RC2".

(SP = Service Pack) (RC = Release Candidate)

They have completely different meanings.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
> Sent: Saturday, October 31, 2020 6:47 PM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>
> Hi Ray,
>
> Yes, there was an ASCOM 6.5RC2. Just checked the GitHub web site but no executable file found
anymore even
> if it's written 6.5RC2.
>
> I already got this file on my USB key and initiated an installation to be sure it is version 6.5RC2 and it
was. This
> was the version with I've tested APPM last night but without success.
>
> Regards,
> Yves
>
> .
>
> Le 31/10/20 21:35, Ray Gralak <groups3@gralak.com> a écrit :
>
> Hi Yves,
>
> > Did a point run last night and got bad results with ASCOM 6.5 SP2. Downgraded to version ASCOM
> 6.4RC1 and
> > everything went fine.
>
> I am not sure what you mean... there is no ASCOM 6.5 SP2. Did you mean SP1?
>
> > You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused. Is the beta 6.5RC1 version the
> same as
> > non-beta 6.5RC1?
>
> You'll have to ask that question on the ASCOM group. I haven't been keeping track of the changes they
> make. I was told the link I posted is to the 6.5 SP1 beta.
>
> -Ray Gralak
> Author of PEMPro
> Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
> Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
>
>
> > -----Original Message-----
> > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
> > Sent: Saturday, October 31, 2020 2:19 PM
> > To: main@ap-gto.groups.io
> > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC
#ASCOM_V2_Driver
> >
> > Hi Ray,
> >
> > Did a point run last night and got bad results with ASCOM 6.5 SP2. Downgraded to version ASCOM
> 6.4RC1 and
> > everything went fine.
> >
> > You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused. Is the beta 6.5RC1 version the
> same as
> > non-beta 6.5RC1?
> >
> > Regards,
> > Yves
> >
> >
> >
> > Le 31/10/20 12:31, Ray Gralak <groups3@gralak.com> a écrit :
> >
> > Hi Andrew,
> >
> > > If you could provide an update on when this issue will be
> > > fixed that would be great.
> >
> > Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which
is
> in
> > ASCOM, not APCC).
> >
> > However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed
has
> the
> > fix, then here is the link:
> >
> > https://download.ascom-standards.org/beta/ASCOMPlatform65.exe
> >
> > -Ray Gralak
> > Author of PEMPro
> > Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
> > Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
> >
> > > -----Original Message-----
> > > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
> > > Sent: Saturday, October 31, 2020 2:20 AM
> > > To: main@ap-gto.groups.io
> > > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC
> #ASCOM_V2_Driver
> > >
> > > Hi Howard.
> > >
> > > I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same
plate
> > solve
> > > results for every image. I was about to post the issue here, when I saw your post. Any eta on when
> this
> > issue will
> > > be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP and
other
> > software I
> > > am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this
> issue
> > will be
> > > fixed that would be great.
> > >
> > > Andrew J
> > >
> >
> >
> >
> >
> >
> >
> >
> >
> >
>
>
>
>
>
>
>
>
>









Yves Laroche
 

Hi Ray,

Thanks for your explanation even if I always understood the naming protocol.

That said... I never being diagnosed but I suffer a kind of dyslexia...unfortunately it seems even worse with age and if I'm reading text too fast and/or having a lack of sleep.  :-)

Best regards,
Yves



Le 01/11/20 09:28, Ray Gralak <groups3@...> a écrit :
Hi Yves,

> Sorry Ray,  a typo error...I meant RC2 !!!

Okay, thanks. That *almost* clears things up.  :-)

Since ASCOM 6.5 platform has been released, any RC (release candidate) would be older than the current release.

So, if you are using APCC Pro you must use one of the following ASCOM versions:

1. ASCOM 6.4 SP2
2. ASCOM 6.5 SP1 Beta (the link I provided).
3. The as yet unreleased, ASCOM 6.5 SP1

Where again, "SP" stands for "Service Pack".

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
> Sent: Saturday, October 31, 2020 8:40 PM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>
> Sorry Ray,  a typo error...I meant RC2 !!!
>
> Yves
>
>
>
> Le 31/10/20 23:19, Ray Gralak <groups3@...> a écrit :
>
>  > Yes, there was an ASCOM 6.5RC2.
>
>  That's not what you wrote... You wrote "SP2", not "RC2".
>
>  (SP = Service Pack) (RC = Release Candidate)
>
>  They have completely different meanings.
>
>  -Ray Gralak
>  Author of PEMPro
>  Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
>  Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
>
>
>  > -----Original Message-----
>  > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
>  > Sent: Saturday, October 31, 2020 6:47 PM
>  > To: main@ap-gto.groups.io
>  > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>  >
>  > Hi Ray,
>  >
>  > Yes, there was an ASCOM 6.5RC2.  Just checked the GitHub web site but no executable file found
> anymore even
>  > if it's written 6.5RC2.
>  >
>  > I already got this file on my USB key and initiated an installation to be sure it is version 6.5RC2 and it
> was.  This
>  > was the version with I've tested APPM last night but without success.
>  >
>  > Regards,
>  > Yves
>  >
>  > .
>  >
>  > Le 31/10/20 21:35, Ray Gralak <groups3@...> a écrit :
>  >
>  >  Hi Yves,
>  >
>  >  > Did a point run last night and got bad results with ASCOM 6.5 SP2.  Downgraded to version ASCOM
>  > 6.4RC1 and
>  >  > everything went fine.
>  >
>  >  I am not sure what you mean... there is no ASCOM 6.5 SP2. Did you mean SP1?
>  >
>  >  > You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused.  Is the beta 6.5RC1 version the
>  > same as
>  >  > non-beta 6.5RC1?
>  >
>  >  You'll have to ask that question on the ASCOM group. I haven't been keeping track of the changes they
>  > make. I was told the link I posted is to the 6.5 SP1 beta.
>  >
>  >  -Ray Gralak
>  >  Author of PEMPro
>  >  Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
>  >  Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
>  >
>  >
>  >  > -----Original Message-----
>  >  > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
>  >  > Sent: Saturday, October 31, 2020 2:19 PM
>  >  > To: main@ap-gto.groups.io
>  >  > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC
> #ASCOM_V2_Driver
>  >  >
>  >  > Hi Ray,
>  >  >
>  >  > Did a point run last night and got bad results with ASCOM 6.5 SP2.  Downgraded to version ASCOM
>  > 6.4RC1 and
>  >  > everything went fine.
>  >  >
>  >  > You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused.  Is the beta 6.5RC1 version the
>  > same as
>  >  > non-beta 6.5RC1?
>  >  >
>  >  > Regards,
>  >  > Yves
>  >  >
>  >  >
>  >  >
>  >  > Le 31/10/20 12:31, Ray Gralak <groups3@...> a écrit :
>  >  >
>  >  >  Hi Andrew,
>  >  >
>  >  >  > If you could provide an update on when this issue will be
>  >  >  > fixed that would be great.
>  >  >
>  >  >  Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which
> is
>  > in
>  >  > ASCOM, not APCC).
>  >  >
>  >  >  However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed
> has
>  > the
>  >  > fix, then here is the link:
>  >  >
>  >  >  https://download.ascom-standards.org/beta/ASCOMPlatform65.exe
>  >  >
>  >  >  -Ray Gralak
>  >  >  Author of PEMPro
>  >  >  Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
>  >  >  Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
>  >  >
>  >  >  > -----Original Message-----
>  >  >  > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
>  >  >  > Sent: Saturday, October 31, 2020 2:20 AM
>  >  >  > To: main@ap-gto.groups.io
>  >  >  > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC
>  > #ASCOM_V2_Driver
>  >  >  >
>  >  >  > Hi Howard.
>  >  >  >
>  >  >  > I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same
> plate
>  >  > solve
>  >  >  > results for every image. I was about to post the issue here, when I saw your post. Any eta on when
>  > this
>  >  > issue will
>  >  >  > be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP  and
> other
>  >  > software I
>  >  >  > am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this
>  > issue
>  >  > will be
>  >  >  > fixed that would be great.
>  >  >  >
>  >  >  > Andrew J
>  >  >  >
>  >  >
>  >  >
>  >  >
>  >  >
>  >  >
>  >  >
>  >  >
>  >  >
>  >  >
>  >
>  >
>  >
>  >
>  >
>  >
>  >
>  >
>  >
>
>
>
>
>
>
>
>
>







Andrew Jones
 

Hi Ray. I will will give the ASCOM 6.5 SP1 Beta a try. Thanks for the update.

Andrew J


Dale Ghent
 

I'll take "Why Microsoft-inspired versioning habits are terrible" for $200, Alex.

;)

/dale

On Nov 1, 2020, at 9:28 AM, Ray Gralak <groups3@gralak.com> wrote:

Hi Yves,

Sorry Ray, a typo error...I meant RC2 !!!
Okay, thanks. That *almost* clears things up. :-)

Since ASCOM 6.5 platform has been released, any RC (release candidate) would be older than the current release.

So, if you are using APCC Pro you must use one of the following ASCOM versions:

1. ASCOM 6.4 SP2
2. ASCOM 6.5 SP1 Beta (the link I provided).
3. The as yet unreleased, ASCOM 6.5 SP1

Where again, "SP" stands for "Service Pack".

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
Sent: Saturday, October 31, 2020 8:40 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver

Sorry Ray, a typo error...I meant RC2 !!!

Yves



Le 31/10/20 23:19, Ray Gralak <groups3@gralak.com> a écrit :

> Yes, there was an ASCOM 6.5RC2.

That's not what you wrote... You wrote "SP2", not "RC2".

(SP = Service Pack) (RC = Release Candidate)

They have completely different meanings.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
> Sent: Saturday, October 31, 2020 6:47 PM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC #ASCOM_V2_Driver
>
> Hi Ray,
>
> Yes, there was an ASCOM 6.5RC2. Just checked the GitHub web site but no executable file found
anymore even
> if it's written 6.5RC2.
>
> I already got this file on my USB key and initiated an installation to be sure it is version 6.5RC2 and it
was. This
> was the version with I've tested APPM last night but without success.
>
> Regards,
> Yves
>
> .
>
> Le 31/10/20 21:35, Ray Gralak <groups3@gralak.com> a écrit :
>
> Hi Yves,
>
> > Did a point run last night and got bad results with ASCOM 6.5 SP2. Downgraded to version ASCOM
> 6.4RC1 and
> > everything went fine.
>
> I am not sure what you mean... there is no ASCOM 6.5 SP2. Did you mean SP1?
>
> > You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused. Is the beta 6.5RC1 version the
> same as
> > non-beta 6.5RC1?
>
> You'll have to ask that question on the ASCOM group. I haven't been keeping track of the changes they
> make. I was told the link I posted is to the 6.5 SP1 beta.
>
> -Ray Gralak
> Author of PEMPro
> Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
> Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
>
>
> > -----Original Message-----
> > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Yves Laroche
> > Sent: Saturday, October 31, 2020 2:19 PM
> > To: main@ap-gto.groups.io
> > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC
#ASCOM_V2_Driver
> >
> > Hi Ray,
> >
> > Did a point run last night and got bad results with ASCOM 6.5 SP2. Downgraded to version ASCOM
> 6.4RC1 and
> > everything went fine.
> >
> > You mentioned ASCOM 6.5 SP1 beta version but I'm a bit confused. Is the beta 6.5RC1 version the
> same as
> > non-beta 6.5RC1?
> >
> > Regards,
> > Yves
> >
> >
> >
> > Le 31/10/20 12:31, Ray Gralak <groups3@gralak.com> a écrit :
> >
> > Hi Andrew,
> >
> > > If you could provide an update on when this issue will be
> > > fixed that would be great.
> >
> > Actually, I reported on this a couple of weeks ago. ASCOM 6.5 Service Pack 1 will fix the bug (which
is
> in
> > ASCOM, not APCC).
> >
> > However, if you want to try the beta version of ASCOM 6.5 SP1, which I have tested and confirmed
has
> the
> > fix, then here is the link:
> >
> > https://download.ascom-standards.org/beta/ASCOMPlatform65.exe
> >
> > -Ray Gralak
> > Author of PEMPro
> > Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
> > Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
> >
> > > -----Original Message-----
> > > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Andrew Jones
> > > Sent: Saturday, October 31, 2020 2:20 AM
> > > To: main@ap-gto.groups.io
> > > Subject: Re: [ap-gto] Do NOT use ASCOM Platform v. 6.5 with APCC Pro #APCC
> #ASCOM_V2_Driver
> > >
> > > Hi Howard.
> > >
> > > I spent half the night trying to create a new APPM model using ASCOM 6.5 and getting the same
plate
> > solve
> > > results for every image. I was about to post the issue here, when I saw your post. Any eta on when
> this
> > issue will
> > > be resolved? I am kind of caught in a catch-22 at the moment as the latest version of SGP and
other
> > software I
> > > am using to control my rig now requires ASCOM 6.5. If you could provide an update on when this
> issue
> > will be
> > > fixed that would be great.
> > >
> > > Andrew J
> > >
> >
> >
> >
> >
> >
> >
> >
> >
> >
>
>
>
>
>
>
>
>
>













Dean Jacobsen
 

Is this thread now obsolete?  If so, then the title is confusing/misleading.
--
Dean Jacobsen
http://astrophoto.net/wp/
Image Gallery - http://astrophoto.net/wp/image-gallery/
Astrobin Image Gallery - https://www.astrobin.com/users/deanjacobsen/ 
Amateur Radio Call Sign - W6DBJ