CP4 not creating a COM port...


Khushrow Machhi
 

I have had my CP4 box for about a year, and have been using it with my 1100GTO with AE.  Tonight for the first time I am not able to connect to my CP4, when I plug it into a USB port there is no indication of a connection being made and when I check device manager there is no COM port being generated.  I have tried multiple cables and also tried to make a connection with two other laptops.  No success and no com port being generated when I check in device manager.  Is there something else I can check or could the COM port have become defective?
Thanks,
Khushrow


Cheng-Yang Tan
 

Hi Khushrow

   The main board may have come loose from its socket. See this topic:

On Monday, September 6, 2021, 1:26 AM, Khushrow Machhi via groups.io <kmachhi@...> wrote:

I have had my CP4 box for about a year, and have been using it with my 1100GTO with AE.  Tonight for the first time I am not able to connect to my CP4, when I plug it into a USB port there is no indication of a connection being made and when I check device manager there is no COM port being generated.  I have tried multiple cables and also tried to make a connection with two other laptops.  No success and no com port being generated when I check in device manager.  Is there something else I can check or could the COM port have become defective?
Thanks,
Khushrow


Khushrow Machhi
 

That was it.  Not sure how the board worked lose, I am the original owner and have never dropped it. I reseated the board and now when I plug in to the USB port I get a confirming beep when I plug the CP4 in.  However when I open device manager there is still no com port showing up, there is an other devices with a FT32R device that says the driver is not correctly installed.  This device disappears when I unplug the CP4.  I do not recall updating a driver when I originally installed the CP4, so any assistance on which driver I need to update will help.
Khushrow


Khushrow Machhi
 

It's all good now.  Reseated the board, downloaded the CP4 FTDI driver and everything is back to normal.