Topics

Change Mount COM Port


dang.astro
 

Hello,

Maybe this isn't an AP question but hoping someone here would know...  My CP4 connects to my laptop via a usb-serial adapter and shows up as COM Port 5. Is there a way to change the COM Port number to something else? When I try to plug in something else (in my case a solar guider) to my laptop it also wants to connect to COM Port 5. Not sure why it's trying to use the same Port.

Thanks!
Dan


Mike Dodd
 

On 12/1/2020 7:36 AM, dang.astro wrote:
Hello,

Maybe this isn't an AP question but hoping someone here would know...
My CP4 connects to my laptop via a usb-serial adapter and shows up as
COM Port 5. Is there a way to change the COM Port number to something
else?
That depends on the type of USB-serial adapter. My Edgeport USB-serial box lets me specify what port to use, but Control panel -> Device Manager on my Windows 8.1 machine doesn't.

When I try to plug in something else (in my case a solar guider)
to my laptop it also wants to connect to COM Port 5. Not sure why it's
trying to use the same Port
That sounds like an application setting. All the software I use has a setting that allows me to specify the COM port to use. This is saved in the app's configuration, so it always uses that port.

I suggest first checking your solar guider settings; then you'll know why it's trying to connect to a specific port.

HTH.

--- Mike


dang.astro
 

Thanks Mike for the reply,

When I go the solar guider settings, it only has a single Port listed which is the same one the mount uses. I plugged the solar guider into another USB port on my laptop but it keeps showing up as COM Port 5 and no other COM ports are listed. Haven't found a whole lot of documentation on the Hinode Solar Guider to be honest

Thanks again,
Dan


Mike Dodd
 

On 12/1/2020 9:28 AM, dang.astro wrote:
Thanks Mike for the reply,

When I go the solar guider settings, it only has a single Port listed
which is the same one the mount uses.

I plugged the solar guider into
another USB port on my laptop but it keeps showing up as COM Port 5 and
no other COM ports are listed.
Try this:
1. Turn on the mount and plug the USB-serial dongle for it.

2. Open Control Panel->Device Manager->Ports COM and LPT (see attached screen shot).

3. You should see COM5 listed.

4. Now plug the Solar Guider into a USB port. How does the list of ports change in Device Manager?

I don't know anything about the Solar Guider. Is it a camera with its own USB cable? If so, then Device Manager should show a new port when you plug that cable.

*** If it does not, then your laptop does not recognize that device. In that case, you probably need to install a Solar Guider device driver.

Do you see any message in the Windows System Tray (lower-right) when you plug the Solar Guider? That could be a clue that the device driver is missing. Or perhaps Device Manager shows a new port with a yellow question mark that indicates the device is not working.

As far as I know, Device Manager should display a port for every USB cable plugged into the PC. If it does not -- and only the mount's COM5 port is shown -- that explains why the Solar Guider software is choosing COM5. You need to get Solar Guider's port to show up.

--- Mike


dang.astro
 

Thank you Mike! I will give this a try and report back

Best,
Dan


dang.astro
 

Heya Mike,

Finally got a chance to try this. The first time I connected the solar guider it wouldn't show up as any port and was throwing an error. Unplugged and replugged back in and it came up as its own separate COM port from the CP4. Not sure what was going on but it seems to be working now. 

Greatly appreciate your time and help!
Dan


Mike Dodd
 

On 12/6/2020 4:16 PM, dang.astro wrote:
Heya Mike,

Finally got a chance to try this. The first time I connected the solar
guider it wouldn't show up as any port and was throwing an error.
Unplugged and replugged back in and it came up as its own separate COM
port from the CP4. Not sure what was going on but it seems to be working
now.

Greatly appreciate your time and help!
Glad to hear it's working. Windows is picky about USB drivers. The fundamental rule of thumb is, install the driver software BEFORE plugging in the equipment. Maybe if finally figured out what driver to us for your solar guider.

--- Mike
http;//astronomy.mdodd.com