Camera selection in Pempro


legendtrail@...
 

Mr. Gralak,
Some time ago I had changed the camera selection in Pempro (build 4732) from ASI1 to ASI2 for another issue, but afterwards neglected to change it back. Normally, ASI1 is a 6200mm (main) and ASI2 is a 1600mm (guider). I noticed the difference last night while starting up a PA. When I clicked select, the popup let me select ASI1, but the assigned camera is still shown as ASI2. I ignorred it, did the PA, and took some pictures, so I only know the window indicated it was using ASI2. Later, I looked at the Paimage fits headers and they indicate the INSTRUMENT was ASI2. I have a usable workaround for now.

best regards,
Ray H


Ray Gralak
 

Hi Ray,

The naming of both ASI camera ASCOM drivers has "ASICamera2" as part of their driver names.

"ASI Camera (1)" ==> "ASCOM.ASICamera2.Camera"
"ASI Camera (2)" ==> "ASCOM.ASICamera2_2.Camera"

If the first line is what you saw, then that is correct. The "friendly" names you see in the ASCOM drop-down list and the ASCOM driver names come from the driver and are not something that PEMPro controls.

-Ray

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of legendtrail via groups.io

Mr. Gralak,
Some time ago I had changed the camera selection in Pempro (build 4732) from ASI1 to ASI2 for another issue,
but afterwards neglected to change it back. Normally, ASI1 is a 6200mm (main) and ASI2 is a 1600mm (guider). I
noticed the difference last night while starting up a PA. When I clicked select, the popup let me select ASI1, but
the assigned camera is still shown as ASI2. I ignorred it, did the PA, and took some pictures, so I only know the
window indicated it was using ASI2. Later, I looked at the Paimage fits headers and they indicate the
INSTRUMENT was ASI2. I have a usable workaround for now.

best regards,
Ray H