APCC Pro Error FindFreeQacindex: no free entries!


Chris White
 

I have no idea what this error means.  I just changed my weather monitoring from using ASCOM Conditions Hub using a combination of Pegasus Sensors and API's to using a Lunatico Rain Sensor which has Rain, Clouds, Temperature, Sky Temp, Barometer, Relative Humidity...   I'm still using the ASCOM conditions hub, but with this new gear list.  Now I'm getting this error and not sure how to resolve it. 

Thank you,


Ray Gralak
 

This can happen when messages are getting queued up and cannot be sent out to the mount.

Does this not happen when you disconnect from the ASCOM conditions hub?

-Ray

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Chris White
Sent: Tuesday, November 2, 2021 4:46 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] APCC Pro Error FindFreeQacindex: no free entries!

I have no idea what this error means. I just changed my weather monitoring from using ASCOM Conditions
Hub using a combination of Pegasus Sensors and API's to using a Lunatico Rain Sensor which has Rain,
Clouds, Temperature, Sky Temp, Barometer, Relative Humidity... I'm still using the ASCOM conditions hub,
but with this new gear list. Now I'm getting this error and not sure how to resolve it.

Thank you,



Chris White
 

Ray.  It seems to happen when I am either accessing or closing the ASCOM Hub Properties.  I switchde from using the ASCOM Hub to the ASCOM Lunatico driver and I dont seem to get the error anymore.  I'm not sure it is able to access all the data that the device can generate, but I get RH, Temp, Barometer and Dew Point.. so I guess that is sufficient for the purposes of APCC. 


Ray Gralak
 

It sounds like the ASCOM hub is blocking APCC in some way. I'll see if it is possible to move the hub off to another thread so they won't interfere. If I can do that, it will be in the next build.

-Ray

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Chris White
Sent: Wednesday, November 3, 2021 4:13 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] APCC Pro Error FindFreeQacindex: no free entries!

Ray. It seems to happen when I am either accessing or closing the ASCOM Hub Properties. I switchde from
using the ASCOM Hub to the ASCOM Lunatico driver and I dont seem to get the error anymore. I'm not sure it
is able to access all the data that the device can generate, but I get RH, Temp, Barometer and Dew Point.. so I
guess that is sufficient for the purposes of APCC.


Chris White
 

Well, in any event it sounds like its not serious.  Thanks for looking.


David Johnson
 

I’ve gotten the same error recently.  It happened when building my APPM model, not while acquiring data.  It didn’t seem to have any effect on the process. 

Minor complaint about error windows in APCC.  I often can’t access the error window.  It appears to be hidden by the main APCC window.  Even using Alt Tab to cycle through the windows doesn’t work.  I do not not have the box for APCC to always be on top checked.  There’s an easy workaround, which is to go to the bottom of the screen and close the window by right clicking on the tab, then click the show errors to bring it up again on top, but it is annoying and has happened multiple times. Seems like there would be an easy fix. 


Ray Gralak
 

Hi David,

 

> Minor complaint about error windows in APCC.  I often can’t access the error window.  It appears to be hidden

> by the main APCC window. 

 

The Error Log Window is set to be a "top most" window, so it will be in front of APCC's main window if APCC is not also set to be on top.

 

That said, clicking the Tools->Error Log menu item (see screenshot below) will bring the error log window to the front of any windows, even if it is in the background.

 

 

-Ray

 

 

> -----Original Message-----

> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of David Johnson

> Sent: Thursday, November 4, 2021 6:15 AM

> To: main@ap-gto.groups.io

> Subject: Re: [ap-gto] APCC Pro Error FindFreeQacindex: no free entries!

>

> I’ve gotten the same error recently.  It happened when building my APPM model, not while acquiring data.  It

> didn’t seem to have any effect on the process.

>

> Minor complaint about error windows in APCC.  I often can’t access the error window.  It appears to be hidden

> by the main APCC window.  Even using Alt Tab to cycle through the windows doesn’t work.  I do not not have

> the box for APCC to always be on top checked.  There’s an easy workaround, which is to go to the bottom of

> the screen and close the window by right clicking on the tab, then click the show errors to bring it up again on

> top, but it is annoying and has happened multiple times. Seems like there would be an easy fix.

>


David Johnson
 

Thanks.  I have an even more minor complaint and am in need of advice.  Very often, the Emergency Stop window persists after slewing is complete, and when it would normally disappear.   It just happened to me tonight.   Is there any possible problem with just closing it using the "X" box?


Ray Gralak
 

Thanks. I have an even more minor complaint and am in need of advice. Very often, the Emergency Stop
window persists after slewing is complete, and when it would normally disappear. It just happened to me
tonight. Is there any possible problem with just closing it using the "X" box?
David, sure you can close the window like that.

-Ray


David Johnson
 

Thanks


John Upton
 

David,

   I had that happen to me last night for the first time. After seeing it happen a few times, I found that it appears to be caused by the mouse hovering over that emergency stop window when the slew completes. The windows turns yellow(ish) when the mouse hovers over it. If the mouse is not over the window, it closes and goes away but when the mouse is hovering over the window, it remains on screen and doesn't automatically close until you manually dismiss it. At least that is what I was observing last night...

John


David Johnson
 

Thanks