#APCC #Mach2 - 3D viewer weird scope position while it is parked (or even while slewing sometimes) #apcc #APCC


Sébastien Doré
 

Hi,

When I use the 3D viewer in APPC (which is a great feature), it seems to get de-synchronized from the mount position sometimes. Like in the example  below where the mount was parked at park 2 at around 9:30 AM (time of the screenshot is 12:30). 

One thing that might explains this is I do not quite fully understand what "correctly calibrated with the night sky" means in the warning window when the 3D viewer is launched. 

I would have thought "Find Home" (encoder tab) would be a valid calibration process for encoder mount in this regards. Or maybe the sync at the beginning of an APPM run, or from a third party software, but it doesn't seem to prevent that from happening, so obviously I'm missing something. My prerogative was that since the mount (with encoders) always knows where it is at, the 3D viewer should too, but it seems that at least in my case, it does not. 

From the manual, I understand this warning/pre-requisite is probably there for non-encoder mount when clutches are loosen but I couldn't find any information relative to this for encoder mounts or more specifically for the Mach2 (which is one of a kind species in itself, I know). But I might have missed it too. 



Hitting Sync -> Re-sync 3D view does fix it but it would be nice (and less scary, especially when slewing at 1800X) if it were always showing the correct orientation. 

Still, it works 95% of the time. Just trying to understand how I can get the last 5%... I can provide logs if required, but I feel it's just me not doing something I should. Anybody can pinpoint where I need to correctly "calibrate on the night sky", if that is indeed my issue ?

Thanks,

Sébastien




Roland Christen
 

The Mach2 mount always parks the actual telescope at the same gear angle - that is controlled by the internal encoders. The parks are independent of time or hour angle. Same with Home.

APCC calculates scope position using time and hour angle. Any error in sync or recal will affect where the scope is shown in the viewer. In your case it appears that your computer clock time is off by 6 hours. It doesn't appear that you did an errant sync because the viewer shows the Dec axis to be correct. Just the RA axis is off by 6 hours, so I suspect either a 6 hour clock time offset somewhere in your applications or you have a 6 hour error in the longitude.

Roland

-----Original Message-----
From: Seb@stro <sebastiendore1@...>
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Sent: Wed, Oct 6, 2021 12:53 pm
Subject: [ap-gto] #APCC #Mach2 - 3D viewer weird scope position while it is parked (or even while slewing sometimes) #apcc

Hi,

When I use the 3D viewer in APPC (which is a great feature), it seems to get de-synchronized from the mount position sometimes. Like in the example  below where the mount was parked at park 2 at around 9:30 AM (time of the screenshot is 12:30). 

One thing that might explains this is I do not quite fully understand what "correctly calibrated with the night sky" means in the warning window when the 3D viewer is launched. 

I would have thought "Find Home" (encoder tab) would be a valid calibration process for encoder mount in this regards. Or maybe the sync at the beginning of an APPM run, or from a third party software, but it doesn't seem to prevent that from happening, so obviously I'm missing something. My prerogative was that since the mount (with encoders) always knows where it is at, the 3D viewer should too, but it seems that at least in my case, it does not. 

From the manual, I understand this warning/pre-requisite is probably there for non-encoder mount when clutches are loosen but I couldn't find any information relative to this for encoder mounts or more specifically for the Mach2 (which is one of a kind species in itself, I know). But I might have missed it too. 



Hitting Sync -> Re-sync 3D view does fix it but it would be nice (and less scary, especially when slewing at 1800X) if it were always showing the correct orientation. 

Still, it works 95% of the time. Just trying to understand how I can get the last 5%... I can provide logs if required, but I feel it's just me not doing something I should. Anybody can pinpoint where I need to correctly "calibrate on the night sky", if that is indeed my issue ?

Thanks,

Sébastien




--
Roland Christen
Astro-Physics


Sébastien Doré
 

Hi Roland,

Thanks for your reply. My computer is permanently connected to Internet and time is correct. 

One important thing I omitted in my previous message is that, at the time I park the mount, the 3d viewer shows the correct position (park 2). But sometimes, like this morning, it gets pretty obvious. It looks like the 3d viewer shows the mount is still tracking even if it is not. See for yourself below. I am positive it still is parked at park2 right now (and not at the position showed, obviously).

Sébastien




De : main@ap-gto.groups.io <main@ap-gto.groups.io> de la part de Roland Christen via groups.io <chris1011@...>
Envoyé : 6 octobre 2021 14:43
À : main@ap-gto.groups.io <main@ap-gto.groups.io>
Objet : Re: [ap-gto] #APCC #Mach2 - 3D viewer weird scope position while it is parked (or even while slewing sometimes) #apcc #apcc #mach2
 
The Mach2 mount always parks the actual telescope at the same gear angle - that is controlled by the internal encoders. The parks are independent of time or hour angle. Same with Home.

APCC calculates scope position using time and hour angle. Any error in sync or recal will affect where the scope is shown in the viewer. In your case it appears that your computer clock time is off by 6 hours. It doesn't appear that you did an errant sync because the viewer shows the Dec axis to be correct. Just the RA axis is off by 6 hours, so I suspect either a 6 hour clock time offset somewhere in your applications or you have a 6 hour error in the longitude.

Roland
_._,_._,_


Sébastien Doré
 

Correction: the mount is at *park3* right now (moved it with the keypad to do my flats this morning). Re-attached screenshot, so you can see in decent resolution. Maybe that is the issue (re-parking from the keypad) ?
 

Hi Roland,

Thanks for your reply. My computer is permanently connected to Internet and time is correct. 

One important thing I omitted in my previous message is that, at the time I park the mount, the 3d viewer shows the correct position (park 3). But sometimes, like this morning, it gets pretty obvious. It looks like the 3d viewer shows the mount is still tracking even if it is not. See for yourself below. I am positive it still is parked at park3 right now (and not at the position showed, obviously).

Sébastien


Roland Christen
 

Nope. Makes no difference how you park it. Mach 2 ALWAYS parks the scope at the correct gear angle determined internally via the two absolute encoders. Doesn't matter where the park command comes from. Doesn't matter if it was sent to an errant position due to invalid sync or whatever, by any external client including the keypad.

APCC does NOT use the internal encoder park positions to determine the 3d Viewer orientation. It uses time and location to determine the mount's hour angle based on the last object that you synced to. Therefore the two can be out of sync by any of the three that could be in error (time, location and sync)

Roland

-----Original Message-----
From: Seb@stro <sebastiendore1@...>
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Sent: Wed, Oct 6, 2021 3:09 pm
Subject: Re: [ap-gto] #APCC #Mach2 - 3D viewer weird scope position while it is parked (or even while slewing sometimes) #apcc #apcc #mach2

Correction: the mount is at *park3* right now (moved it with the keypad to do my flats this morning). Re-attached screenshot, so you can see in decent resolution. Maybe that is the issue (re-parking from the keypad) ?
 
Hi Roland,

Thanks for your reply. My computer is permanently connected to Internet and time is correct. 

One important thing I omitted in my previous message is that, at the time I park the mount, the 3d viewer shows the correct position (park 3). But sometimes, like this morning, it gets pretty obvious. It looks like the 3d viewer shows the mount is still tracking even if it is not. See for yourself below. I am positive it still is parked at park3 right now (and not at the position showed, obviously).

Sébastien


--
Roland Christen
Astro-Physics


Roland Christen
 

Check your keypad time setting. It has to be the same as your computer time if you are going to switch back and forth between the two.

Roland

-----Original Message-----
From: Seb@stro <sebastiendore1@...>
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Sent: Wed, Oct 6, 2021 3:09 pm
Subject: Re: [ap-gto] #APCC #Mach2 - 3D viewer weird scope position while it is parked (or even while slewing sometimes) #apcc #apcc #mach2

Correction: the mount is at *park3* right now (moved it with the keypad to do my flats this morning). Re-attached screenshot, so you can see in decent resolution. Maybe that is the issue (re-parking from the keypad) ?
 
Hi Roland,

Thanks for your reply. My computer is permanently connected to Internet and time is correct. 

One important thing I omitted in my previous message is that, at the time I park the mount, the 3d viewer shows the correct position (park 3). But sometimes, like this morning, it gets pretty obvious. It looks like the 3d viewer shows the mount is still tracking even if it is not. See for yourself below. I am positive it still is parked at park3 right now (and not at the position showed, obviously).

Sébastien


--
Roland Christen
Astro-Physics


Sébastien Doré
 

Here's what I get. Everything synced to the second (look at the Ottawa time on my cell phone).

When I attempt to check Location on the keypad, I get the following message: "Keypad in EXT mode". I did initialize the mount with APCC and just checked it too has the correct time & date and location as you can see in the screenshot.

So not sure what else I can have wrongly set. If it were a bad sync, it wouldn't get fixed when I click on "Resync 3D viewer", wouldn't it ? 

Just to make sure I'm making myself understood correctly, please notice that the scope position in the 3D viewer has been changing continously during all day, even if the scope is Parked right now and has been parked all day.

Anyway, I would have noticed such a big offset while imaging (successfully) at 2000 mm for the last three nights. I set everything up on monday, and weather has been cooperating since then so I have not touched a thing except perhaps refining PA (for at most +/- 10 arc-sec) from night to night.

Here's a link to my logs anyway:


Sébastien


De : main@ap-gto.groups.io <main@ap-gto.groups.io> de la part de Roland Christen via groups.io <chris1011@...>
Envoyé : 6 octobre 2021 16:43
À : main@ap-gto.groups.io <main@ap-gto.groups.io>
Objet : Re: [ap-gto] #APCC #Mach2 - 3D viewer weird scope position while it is parked (or even while slewing sometimes) #apcc #apcc #mach2
 
Check your keypad time setting. It has to be the same as your computer time if you are going to switch back and forth between the two.

Roland


Roland Christen
 

I would have to let Ray take a look.

Rolando

-----Original Message-----
From: Seb@stro <sebastiendore1@...>
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Sent: Wed, Oct 6, 2021 4:55 pm
Subject: Re: [ap-gto] #APCC #Mach2 - 3D viewer weird scope position while it is parked (or even while slewing sometimes) #apcc #apcc #mach2

Here's what I get. Everything synced to the second (look at the Ottawa time on my cell phone).

When I attempt to check Location on the keypad, I get the following message: "Keypad in EXT mode". I did initialize the mount with APCC and just checked it too has the correct time & date and location as you can see in the screenshot.

So not sure what else I can have wrongly set. If it were a bad sync, it wouldn't get fixed when I click on "Resync 3D viewer", wouldn't it ? 

Just to make sure I'm making myself understood correctly, please notice that the scope position in the 3D viewer has been changing continously during all day, even if the scope is Parked right now and has been parked all day.

Anyway, I would have noticed such a big offset while imaging (successfully) at 2000 mm for the last three nights. I set everything up on monday, and weather has been cooperating since then so I have not touched a thing except perhaps refining PA (for at most +/- 10 arc-sec) from night to night.

Here's a link to my logs anyway:


Sébastien


De : main@ap-gto.groups.io <main@ap-gto.groups.io> de la part de Roland Christen via groups.io <chris1011@...>
Envoyé : 6 octobre 2021 16:43
À : main@ap-gto.groups.io <main@ap-gto.groups.io>
Objet : Re: [ap-gto] #APCC #Mach2 - 3D viewer weird scope position while it is parked (or even while slewing sometimes) #apcc #apcc #mach2
 
Check your keypad time setting. It has to be the same as your computer time if you are going to switch back and forth between the two.

Roland

--
Roland Christen
Astro-Physics


Ray Gralak
 

APCC reads the mount’s mechanical position in both axes and returns that relative to each axis’ offset value to the 3DViewer. The axis offset value is what gets saved when the 3D viewer is synced. It’s incredibly straightforward and works the same way for ALL mounts. Nothing is different for the Mach 2.

 

An incorrect 3D position can arise if you move the scope manually and sync/recal the mount, or possibly when you home the mount. The solution is to resync the 3D Viewer after homing, moving the scope manually,  or unparking from one of the Park positions instead of the last-parked position.

 

-Ray

 

From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Seb@stro
Sent: Wednesday, October 6, 2021 10:54 AM
To: main@ap-gto.groups.io
Subject: [ap-gto] #APCC #Mach2 - 3D viewer weird scope position while it is parked (or even while slewing sometimes) #apcc

 

Hi,

 

When I use the 3D viewer in APPC (which is a great feature), it seems to get de-synchronized from the mount position sometimes. Like in the example  below where the mount was parked at park 2 at around 9:30 AM (time of the screenshot is 12:30). 

 

One thing that might explains this is I do not quite fully understand what "correctly calibrated with the night sky" means in the warning window when the 3D viewer is launched. 

 

I would have thought "Find Home" (encoder tab) would be a valid calibration process for encoder mount in this regards. Or maybe the sync at the beginning of an APPM run, or from a third party software, but it doesn't seem to prevent that from happening, so obviously I'm missing something. My prerogative was that since the mount (with encoders) always knows where it is at, the 3D viewer should too, but it seems that at least in my case, it does not. 

 

From the manual, I understand this warning/pre-requisite is probably there for non-encoder mount when clutches are loosen but I couldn't find any information relative to this for encoder mounts or more specifically for the Mach2 (which is one of a kind species in itself, I know). But I might have missed it too. 

 

 

Hitting Sync -> Re-sync 3D view does fix it but it would be nice (and less scary, especially when slewing at 1800X) if it were always showing the correct orientation. 

 

Still, it works 95% of the time. Just trying to understand how I can get the last 5%... I can provide logs if required, but I feel it's just me not doing something I should. Anybody can pinpoint where I need to correctly "calibrate on the night sky", if that is indeed my issue ?

 

Thanks,

 

Sébastien

 

 


Sébastien Doré
 

Hi, just to let people know that Roland and Team (yes, with a capital T, they deserve it !) are kindly working with me in the background on this, which is why the thread has gone silent.

Quadruple 'A' service from AP, as usual.

Clear skies,
Sébastien