APCC Error connecting to AP V2 ASCOM


S Berrada
 

Hi 

I am having another type of problem connecting to my AP1100.

I am using a computer where virtual ports used to work ; now I get an error when I try to connect “ APCC Error connecting to AP V2 ASCOM …. (See image)

When I try to use the IP Address selection in ASCOM, it gives me an error that I have not seen before “run time error 402 - must close or hide topmost modal first” (see image).  Not sure what “topmost modal “ is?

Yet when I go into ASCOM, I am able to confirm that it finds the mount  with virtual port.  So I when try to go back to virtual port in ASCOM, it gives me same error “run time error 402 - must close or hide topmost modal first”.

So this run time error is preventing me from connecting either with ASCOM or virtual port.

 Any help would be appreciated 

Sam


Ray Gralak
 

Time to reboot your computer, as something seems corrupted. Those types of errors should never happen.

 

-Ray

 

From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of S Berrada
Sent: Sunday, October 2, 2022 5:36 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] APCC Error connecting to AP V2 ASCOM

 

Hi 

I am having another type of problem connecting to my AP1100.

I am using a computer where virtual ports used to work ; now I get an error when I try to connect “ APCC Error connecting to AP V2 ASCOM …. (See image)

When I try to use the IP Address selection in ASCOM, it gives me an error that I have not seen before “run time error 402 - must close or hide topmost modal first” (see image).  Not sure what “topmost modal “ is?

Yet when I go into ASCOM, I am able to confirm that it finds the mount  with virtual port.  So I when try to go back to virtual port in ASCOM, it gives me same error “run time error 402 - must close or hide topmost modal first”.

So this run time error is preventing me from connecting either with ASCOM or virtual port.

 Any help would be appreciated 

Sam


S Berrada
 

Hi Ray,

thank you for the response 

I must have rebooted the computer 10 times but still getting the error.

The workaround which seems to get the mount working with NINA / ASCOM  (but still showing error):
- load APCC and connect to mount
- The APCC ‘connect’ button for APV2 Driver does not work,
- so I go directly to NINA and click on ‘ telescope / mount settings’ which gets the ASCOM window to pop up (albeit gives same 402 error)
- afterwards I click on NIna ‘connect mount’ and it seems to connect to ASCOM and get the mount working 

Only then can I get PHD to connect to mount.
But APCC still can not connect the APV2 driver.

Everything worked fine in this computer until yesterday.

Thanks
Sam


 

Hi Sam

When you have APCC running but ASCOM not yet connected, have you tried clicking the auto config option for the ascom driver first?



On Sun, Oct 2, 2022 at 9:10 PM S Berrada <sberrada19@...> wrote:
Hi Ray,

thank you for the response 

I must have rebooted the computer 10 times but still getting the error.

The workaround which seems to get the mount working with NINA / ASCOM  (but still showing error):
- load APCC and connect to mount
- The APCC ‘connect’ button for APV2 Driver does not work,
- so I go directly to NINA and click on ‘ telescope / mount settings’ which gets the ASCOM window to pop up (albeit gives same 402 error)
- afterwards I click on NIna ‘connect mount’ and it seems to connect to ASCOM and get the mount working 

Only then can I get PHD to connect to mount.
But APCC still can not connect the APV2 driver.

Everything worked fine in this computer until yesterday.

Thanks
Sam




Bill Long
 

Do this:
  1. Kill the AP v2 driver, by double clicking on the "Client" part of the driver window.
  2. In APCC, click on the Virtual Port tab, and make sure the ports are created. If they aren't, click the create button for each
  3. On the connection section of APCC, click the Now button to auto-configure the v2 driver.
  4. Then you should be able to connect the driver to APCC.
  5. If this works, check the box to auto-create the Virtual Ports in APCC.
-Bill


From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of S Berrada <sberrada19@...>
Sent: Sunday, October 2, 2022 9:10 PM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: Re: [ap-gto] APCC Error connecting to AP V2 ASCOM
 
Hi Ray,

thank you for the response 

I must have rebooted the computer 10 times but still getting the error.

The workaround which seems to get the mount working with NINA / ASCOM  (but still showing error):
- load APCC and connect to mount
- The APCC ‘connect’ button for APV2 Driver does not work,
- so I go directly to NINA and click on ‘ telescope / mount settings’ which gets the ASCOM window to pop up (albeit gives same 402 error)
- afterwards I click on NIna ‘connect mount’ and it seems to connect to ASCOM and get the mount working 

Only then can I get PHD to connect to mount.
But APCC still can not connect the APV2 driver.

Everything worked fine in this computer until yesterday.

Thanks
Sam


Ray Gralak
 

Hi Sam,

 

> “run time error 402 - must close or hide topmost modal first” (see image). Not sure what “topmost modal “ is?

 

The 402 error is not normal, and suggests the driver is displaying a modal dialog somewhere that needs to be closed. (For example, the driver's Settings window)

 

> But APCC still can not connect the APV2 driver.

 

But, you do not need to connect APCC to the ASCOM driver. The option is removed in the next APCC build, as some people have assumed it is required. Its only purpose is to speed up ASCOM client connections and disconnects by keeping one client (APCC) connected to the driver. But, APCC communicates to the mount directly and does not need the driver. It is the driver that communicates through APCC to the mount.

 

I suggest you configure APCC like the screenclip below and not open the driver’s Settings window, if that was what you were doing.

 

 

-Ray

 


W Hilmo
 

Ray,

Can you please be more specific regarding this statement?

"The option is removed in the next APCC build, as some people have assumed it is required. Its only purpose is to speed up ASCOM client connections and disconnects by keeping one client (APCC) connected to the driver."

My workflow is to start APCC Pro before any other software, with the ASCOM driver "Auto-Connect" unchecked.  After I initialize the mount from APCC, I then use the "Connect" button to connect the ASCOM driver.  When the ASCOM driver is connected, I go out and remove the dust cap from the scope before using the ASCOM driver UI to re-park the mount at Park 5.

I do it this way because we have lots of birds on the property, and they occasionally land on the scope in the evening.  When the inevitable happens, I don't want the lens on the scope fouled.  So I never have the dust cap off, unless the scope is horizontal.  Sometimes I do this well before I set up any other software for the session.

After I'm done the next morning, the last software that I shut down is APCC Pro.  This workflow gives me complete control over the lifetime of the ASCOM driver, and ensures that the log files are not locked when I collect them with the other imaging data for the session.

I would hate to see the ability to do that go away.

Thanks,
-Wade



On 10/3/22 07:10, Ray Gralak wrote:

Hi Sam,

 

> “run time error 402 - must close or hide topmost modal first” (see image). Not sure what “topmost modal “ is?

 

The 402 error is not normal, and suggests the driver is displaying a modal dialog somewhere that needs to be closed. (For example, the driver's Settings window)

 

> But APCC still can not connect the APV2 driver.

 

But, you do not need to connect APCC to the ASCOM driver. The option is removed in the next APCC build, as some people have assumed it is required. Its only purpose is to speed up ASCOM client connections and disconnects by keeping one client (APCC) connected to the driver. But, APCC communicates to the mount directly and does not need the driver. It is the driver that communicates through APCC to the mount.

 

I suggest you configure APCC like the screenclip below and not open the driver’s Settings window, if that was what you were doing.

 

 

-Ray

 

Attachments:



Ray Gralak
 

Hi Wade,

I would hate to see the ability to do that go away.
The decision to remove the option to connect to the ASCOM driver was made by Astro-Physics because it generates a lot of support questions.

Why can't you just park the mount to Park 5 using APCC?

-Ray


S Berrada
 

Hi 

Thanks for your suggestions.

To Brian’s question 
 When you have APCC running but ASCOM not yet connected, have you tried clicking the auto config option for the ascom driver first?”
The answer is yes I have clicked ‘autoconfig’ first (and it appears to be successful )  but afterwards when I try to connect to ASCOM it fails with same error messages. 

I also tried Bill Long’s suggestion, but it does not allow me to use APCC to connect to ASCOM, again with same errors:
  1. Kill the AP v2 driver, by double clicking on the "Client" part of the driver window.
  2. In APCC, click on the Virtual Port tab, and make sure the ports are created. If they aren't, click the create button for each
  3. On the connection section of APCC, click the Now button to auto-configure the v2 driver.
  4. Then you should be able to connect the driver to APCC.
  5. If this works, check the box to auto-create the Virtual Ports in APCC

To Ray’s point about not needing to use APCC to connect to ASCOM, I can only connect Nina to mount when I prompt the ASCOM settings from Nina.  It seems to fail the first attempt and pops up the errors messages (402), but it connects to the mount the second attempt.

So although I can connect to the mount, something is still not quite right.

I normally use a usb  cable to connect mount to computer, but given this issue I used an Ethernet cable to see if it helps.  Again, I could  connect APCC to mount, but could not start ASCOM driver from APCC.

As a further point, I tried powering down the mount and restarting computer several times , with the same outcome.

So not sure what to do next.

thanks 
sam




W Hilmo
 

To answer your question directly, I simply like the ASCOM driver UI for parking and unparking better than the APCC UI.  It "feels" really clean to me to have APCC be the software that controls the lifetime of the ASCOM driver.

Beyond that, there are times that I want to work with the mount when I am not going to be doing any image capture with the system.  After the change you are describing, NINA would mostly be the software that controls the lifetime of the ASCOM driver - but not all the time.  On occasion, it might be PHD2, or TheSkyX or something else.

I'm (more than) a bit OCD - especially with software.  I want the exact same behavior every time I use the mount.  Frankly, when this change happens, I'll almost certainly end up writing a shim ASCOM client that does nothing more than connect and disconnect from the ASCOM driver.  I may even end up having it start APCC for me, and disconnect when APCC terminates.

It just makes sense to me for mount software to control the lifetime of the mount's ASCOM driver, and not some random ASCOM client.

It would not bother me to put the ASCOM connect button somewhere that is not so obvious in APCC.  But I would ask you and the Astro-Physics folks to reconsider removing it completely.

Thanks,
-Wade

On 10/3/22 19:27, Ray Gralak wrote:
Hi Wade,

I would hate to see the ability to do that go away.
The decision to remove the option to connect to the ASCOM driver was made by Astro-Physics because it generates a lot of support questions.

Why can't you just park the mount to Park 5 using APCC?

-Ray






Roland Christen
 

I think you're doing something backwards. I always connect APCC to the mount first and initialize the mount. The ASCOM driver will not come up at that point, but APCC is now ready to accept external software commands from clients such as SkyX or Nina. Connecting SkyX to the "mount" (actually APCC) brings up the ASCOM driver - that is the way ASCOM is supposed to work. SkyX and other software are clients that automatically bring up the driver. APCC is NOT a client - it connects directly to the mount with no ASCOM driver between it and the mount.

Roland Christen

-----Original Message-----
From: S Berrada <sberrada19@...>
To: main@ap-gto.groups.io
Sent: Mon, Oct 3, 2022 10:00 pm
Subject: Re: [ap-gto] APCC Error connecting to AP V2 ASCOM

Hi 

Thanks for your suggestions.

To Brian’s question 
 When you have APCC running but ASCOM not yet connected, have you tried clicking the auto config option for the ascom driver first?”
The answer is yes I have clicked ‘autoconfig’ first (and it appears to be successful )  but afterwards when I try to connect to ASCOM it fails with same error messages. 

I also tried Bill Long’s suggestion, but it does not allow me to use APCC to connect to ASCOM, again with same errors:
  1. Kill the AP v2 driver, by double clicking on the "Client" part of the driver window.
  2. In APCC, click on the Virtual Port tab, and make sure the ports are created. If they aren't, click the create button for each
  3. On the connection section of APCC, click the Now button to auto-configure the v2 driver.
  4. Then you should be able to connect the driver to APCC.
  5. If this works, check the box to auto-create the Virtual Ports in APCC

To Ray’s point about not needing to use APCC to connect to ASCOM, I can only connect Nina to mount when I prompt the ASCOM settings from Nina.  It seems to fail the first attempt and pops up the errors messages (402), but it connects to the mount the second attempt.

So although I can connect to the mount, something is still not quite right.

I normally use a usb  cable to connect mount to computer, but given this issue I used an Ethernet cable to see if it helps.  Again, I could  connect APCC to mount, but could not start ASCOM driver from APCC.

As a further point, I tried powering down the mount and restarting computer several times , with the same outcome.

So not sure what to do next.

thanks 
sam




--
Roland Christen
Astro-Physics


Bill Long
 

With every AP mount I have used (400, Mach 1, Mach 2, 1100) I open APCC and connect that and initialize the mount. Then I allow my other software components to instantiate the v2 driver themselves. 

Sometimes, I forget to open APCC first, and when the V2 driver launches it automatically opens APCC and does its thing. The only problem that can arise is when the mount has not been initialized. Then APCC is asking you to initialize the mount, and the V2 driver wont connect until you do. Which makes perfect sense to me. 

@Sam - I am still not sure why you are experiencing a problem. Maybe a screenshot would help us understand what is going on?


From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Roland Christen via groups.io <chris1011@...>
Sent: Monday, October 3, 2022 9:06 PM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: Re: [ap-gto] APCC Error connecting to AP V2 ASCOM
 
I think you're doing something backwards. I always connect APCC to the mount first and initialize the mount. The ASCOM driver will not come up at that point, but APCC is now ready to accept external software commands from clients such as SkyX or Nina. Connecting SkyX to the "mount" (actually APCC) brings up the ASCOM driver - that is the way ASCOM is supposed to work. SkyX and other software are clients that automatically bring up the driver. APCC is NOT a client - it connects directly to the mount with no ASCOM driver between it and the mount.

Roland Christen

-----Original Message-----
From: S Berrada <sberrada19@...>
To: main@ap-gto.groups.io
Sent: Mon, Oct 3, 2022 10:00 pm
Subject: Re: [ap-gto] APCC Error connecting to AP V2 ASCOM

Hi 

Thanks for your suggestions.

To Brian’s question 
 When you have APCC running but ASCOM not yet connected, have you tried clicking the auto config option for the ascom driver first?”
The answer is yes I have clicked ‘autoconfig’ first (and it appears to be successful )  but afterwards when I try to connect to ASCOM it fails with same error messages. 

I also tried Bill Long’s suggestion, but it does not allow me to use APCC to connect to ASCOM, again with same errors:
  1. Kill the AP v2 driver, by double clicking on the "Client" part of the driver window.
  2. In APCC, click on the Virtual Port tab, and make sure the ports are created. If they aren't, click the create button for each
  3. On the connection section of APCC, click the Now button to auto-configure the v2 driver.
  4. Then you should be able to connect the driver to APCC.
  5. If this works, check the box to auto-create the Virtual Ports in APCC

To Ray’s point about not needing to use APCC to connect to ASCOM, I can only connect Nina to mount when I prompt the ASCOM settings from Nina.  It seems to fail the first attempt and pops up the errors messages (402), but it connects to the mount the second attempt.

So although I can connect to the mount, something is still not quite right.

I normally use a usb  cable to connect mount to computer, but given this issue I used an Ethernet cable to see if it helps.  Again, I could  connect APCC to mount, but could not start ASCOM driver from APCC.

As a further point, I tried powering down the mount and restarting computer several times , with the same outcome.

So not sure what to do next.

thanks 
sam




--
Roland Christen
Astro-Physics


robert.l.wahlstrom@...
 

I have similar problems and have tried now for 2 weeks. Worked great in the old computer in Virtual Port but the computer is wrong so must have another computer... And in the new computer Virtual Port does not work.
 
Will see if it goes well. George in Astro-Physics will help in TeamViewer.
 
/ Robert


Ray Gralak
 

Hi Sam,

You wrote:
To Ray’s point about not needing to use APCC to connect to ASCOM, I can only connect Nina to mount when I
prompt the ASCOM settings from Nina.
As I said previously, you must close the ASCOM driver's Setup window before connecting. If you leave the AP V2 driver Setup window open NINA may not be able to connect to the driver as the window is a modal window, meaning it must be closed first before another window in the driver can be opened..

-Ray


Tom Blahovici
 

Hi
I have no issues with this however it has always been somewhat unclear as to how all of this works.
For example, the ascom v2 driver in a given application allows you to connect to a serial port or a network connection. Could you just bypass any virtual ports by just connecting via ethernet in the ascom driver?
Also just what does the various buttons do in Apcc? Like the now buttons.
One thing that would be useful and a big help is a diagram like a flow chart showing exactly what happens starting from launching apcc, initialization, and connecting of a driver and so on.
Tom


 


Howard Hedlund
 

Hi Gang.  Good thread here with good questions and comments for those of us working with Ray on development.  Let me clarify a few things:
  • ASCOM Standards is its own organization with its own rules and requirements.  Our AP V2 driver is subject to those rules and requirements.
  • Virtually ALL astro-software relies on the ASCOM Platform and individual companies' ASCOM compliant drivers.  Basically, in the Windows realm, connecting any mount to any software involves ASCOM.
  • The AP V2 driver is fully functional as a hub to connect multiple software programs to a single mount.
  • APCC adds a host of capabilities and advantages that are way beyond the scope of what ASCOM allows, or that planetarium programs etc. should support.
  • APCC is not just a side job, however.  It is designed to work WITH the driver - NOT just alongside it.
  • To do this, all the back-and-forth communication between the external software (SGPro, SkyX, PHD2, NINA, Maxim, etc.) must go THROUGH APCC.
  • This is the reason that the entire connection process can be so challenging.
I'm posting this for now, but will come back with more on this topic.


ap@CaptivePhotons.com
 

On Tue, Oct 4, 2022 at 11:39 AM, Tom Blahovici wrote:
I have no issues with this however it has always been somewhat unclear as to how all of this works.

The nice feature is also a problem: The ASCOM driver does not need APCC.  That means there is a lot of apparent redundancy.  Here is what I think I have figured out if you are using APCC in what i think of as a "normal" configuration.

Keep this in mind:   Application(s) -> ASCOM V2 -> APCC -> Mount

APCC talks directly to the mount, via USB or wifi or ethernet (depends on controller).  If you have your computer on the mount and a CP4, I'd recommend ethernet - solid, just works. 

ASCOM V2 talks to APCC on the right side, and to any and all programs on the left.  So NINA, Stellarium, SGP, etc. will create a connection to ASCOM V2.  It acts as a hub, that means it can handle multiple simultaneous connections.  So if you (as I do) use Stellarium and NINA both, both connect, both can read the mount information (via mount -> APCC -> ASCOM V2) and control the mount in the other direction.  No virtual ports are needed, this is done as a software connection to the driver.  It is important to have the right bit-ness loaded (64 vs 32) but that seems magic in Ray's install kit.  It is perfectly OK to have a 64 bit app (say NINA) connecting to the 32 bit APCC, all that magic is handled behind the scenes.   PHD2 also connects to the ASCOM V2 driver in the same way, so in my normal night if Stellarium is running 3 clients are talking to the ASCOM V2 driver. 

ASCOM V2 talks to APCC via either COM ports or the REST interface.  The REST interface is an IP based interface that is handled entirely within the computer, no COM ports are used.  It must be enabled in APCC under the advanced setup tab, and then you can do away entirely with virtual COM ports if you are on a current version. If you also have a CP4 with ethernet that means no COM ports needed at all, period.  Nice.

There are multiple points of initial connection.  The mount "initializes" on power on and connection to something.  If you have a handheld I have no idea; I do not.  With APCC that initial connection is a mount initialization, and certain things happen then which are different than if you simply disconnect APCC and reconnect.  So to do a mount initialization it must power cycle. There are also things that happen on the ASCOM V2 connection.  As an example: 

APCC, Settings, Mount Initialization, there is a "Set tracking rate" which can be set (mine is zero), as well as an "Unpark from" which can also be "Don't unpark". 

Under ASCOM V2 driver setup, Advanced, there is a "Enable mount tracking on Unpark". 

These seem redundant, but are a bit different.  The mount initialization only happens once, on power up.  The ASCOM V2 is going to happen if the application (or the ASCOM V2 UI) unparks the mount, and so can happen multiple times, whereas (per power cycle) the initialization happens once.  So these can be set differently.

When these things happen depend on various settings.  I have APCC set (Connection pane) to "Auto connect" under the mount, but not the Ascom V2 driver.  This means if I start APCC manually it contacts the mount, and if needed initializes the mount (doing its stuff set there).  It does not start ASCOM V2 itself (I see no need). 

When I start NINA (for example), it connects to ASCOM V2, starting it if needed.  ASCOM V2 connects to APCC, starting it if needed (and if it wasn't started it connects to the mount, sees if it needs to initialize, etc.)  My normal path is to click on APCC and NINA together, both take a bit of time to start, by the time I'm connecting in NINA APCC is already up and ready -- but it doesn't need to be, it can start automagically. 

ASCOM drivers (generally, and ASCOM V2 in particular) start themselves when something connects to them, and when the last one disconnects they stop running. Absent that Auto-connect setting or a manual connection from APCC, Ascom V2 does the same.  There is really no need to start it manually, or stop it manually. 

In this setup there is a lot of apparent redundancy, for example NINA can park the mount, but so can APCC (from the GUI), and the mount itself will park if it stops communicating with APCC.  This actually can be handy -- the ASCOM standard does not permit a specification of a park position, the command is simply "Park".  Both ASCOM V2 and APCC can specify a default park position.  I set ASCOM V2 to position 2, and I park manually in APCC to position 3.  Position 3 is my load/unload position, so if I'm closing up in the morning I want it there.  Position 2 is where ASCOM will park if NINA tells it to, and NINA does so in a safety park (e.g. rain) or at the end of the night.  Position 2 is horizontal, so if rain or dew is present, there is less danger to the optics.  So this seeming duplication is actually handy (for me anyway). 

The key, I think (and this is just what I've figured out, not been doing this long) is keep in mind the chain:  Application -> ASCOM V2 -> APCC -> Mount.  The human can intervene in any of these.  The setup and defaults are usually specific to one entry point, and may be different for another entry point (e.g. initialization vs initial connection, or my park examples). 

Hope that helps.  Corrections welcome, most of this learned by train and error and occasional manual reads. 

Linwood


Howard Hedlund
 

Linwood, that is truly a wonderful summation.  May I steal some of your text?

 

Mag. 7 or Better Skies!

 

Howard Hedlund

Astro-Physics, Inc.

AP Phone: 815-282-1513

Direct Mobile Phone:  815-315-7015

Video Tutorials:  https://www.youtube.com/astrophysicscorp

www.astro-physics.com

Please include this e-mail with your response.

 

P Consider the environment before printing this e-mail.

 

From: main@ap-gto.groups.io <main@ap-gto.groups.io> On Behalf Of ap@...
Sent: Tuesday, October 4, 2022 11:21
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] APCC Error connecting to AP V2 ASCOM

 

On Tue, Oct 4, 2022 at 11:39 AM, Tom Blahovici wrote:

I have no issues with this however it has always been somewhat unclear as to how all of this works.

The nice feature is also a problem: The ASCOM driver does not need APCC.  That means there is a lot of apparent redundancy.  Here is what I think I have figured out if you are using APCC in what i think of as a "normal" configuration.

Keep this in mind:   Application(s) -> ASCOM V2 -> APCC -> Mount

APCC talks directly to the mount, via USB or wifi or ethernet (depends on controller).  If you have your computer on the mount and a CP4, I'd recommend ethernet - solid, just works. 

ASCOM V2 talks to APCC on the right side, and to any and all programs on the left.  So NINA, Stellarium, SGP, etc. will create a connection to ASCOM V2.  It acts as a hub, that means it can handle multiple simultaneous connections.  So if you (as I do) use Stellarium and NINA both, both connect, both can read the mount information (via mount -> APCC -> ASCOM V2) and control the mount in the other direction.  No virtual ports are needed, this is done as a software connection to the driver.  It is important to have the right bit-ness loaded (64 vs 32) but that seems magic in Ray's install kit.  It is perfectly OK to have a 64 bit app (say NINA) connecting to the 32 bit APCC, all that magic is handled behind the scenes.   PHD2 also connects to the ASCOM V2 driver in the same way, so in my normal night if Stellarium is running 3 clients are talking to the ASCOM V2 driver. 

ASCOM V2 talks to APCC via either COM ports or the REST interface.  The REST interface is an IP based interface that is handled entirely within the computer, no COM ports are used.  It must be enabled in APCC under the advanced setup tab, and then you can do away entirely with virtual COM ports if you are on a current version. If you also have a CP4 with ethernet that means no COM ports needed at all, period.  Nice.

There are multiple points of initial connection.  The mount "initializes" on power on and connection to something.  If you have a handheld I have no idea; I do not.  With APCC that initial connection is a mount initialization, and certain things happen then which are different than if you simply disconnect APCC and reconnect.  So to do a mount initialization it must power cycle. There are also things that happen on the ASCOM V2 connection.  As an example: 

APCC, Settings, Mount Initialization, there is a "Set tracking rate" which can be set (mine is zero), as well as an "Unpark from" which can also be "Don't unpark". 

Under ASCOM V2 driver setup, Advanced, there is a "Enable mount tracking on Unpark". 

These seem redundant, but are a bit different.  The mount initialization only happens once, on power up.  The ASCOM V2 is going to happen if the application (or the ASCOM V2 UI) unparks the mount, and so can happen multiple times, whereas (per power cycle) the initialization happens once.  So these can be set differently.

When these things happen depend on various settings.  I have APCC set (Connection pane) to "Auto connect" under the mount, but not the Ascom V2 driver.  This means if I start APCC manually it contacts the mount, and if needed initializes the mount (doing its stuff set there).  It does not start ASCOM V2 itself (I see no need). 

When I start NINA (for example), it connects to ASCOM V2, starting it if needed.  ASCOM V2 connects to APCC, starting it if needed (and if it wasn't started it connects to the mount, sees if it needs to initialize, etc.)  My normal path is to click on APCC and NINA together, both take a bit of time to start, by the time I'm connecting in NINA APCC is already up and ready -- but it doesn't need to be, it can start automagically. 

ASCOM drivers (generally, and ASCOM V2 in particular) start themselves when something connects to them, and when the last one disconnects they stop running. Absent that Auto-connect setting or a manual connection from APCC, Ascom V2 does the same.  There is really no need to start it manually, or stop it manually. 

In this setup there is a lot of apparent redundancy, for example NINA can park the mount, but so can APCC (from the GUI), and the mount itself will park if it stops communicating with APCC.  This actually can be handy -- the ASCOM standard does not permit a specification of a park position, the command is simply "Park".  Both ASCOM V2 and APCC can specify a default park position.  I set ASCOM V2 to position 2, and I park manually in APCC to position 3.  Position 3 is my load/unload position, so if I'm closing up in the morning I want it there.  Position 2 is where ASCOM will park if NINA tells it to, and NINA does so in a safety park (e.g. rain) or at the end of the night.  Position 2 is horizontal, so if rain or dew is present, there is less danger to the optics.  So this seeming duplication is actually handy (for me anyway). 

The key, I think (and this is just what I've figured out, not been doing this long) is keep in mind the chain:  Application -> ASCOM V2 -> APCC -> Mount.  The human can intervene in any of these.  The setup and defaults are usually specific to one entry point, and may be different for another entry point (e.g. initialization vs initial connection, or my park examples). 

Hope that helps.  Corrections welcome, most of this learned by train and error and occasional manual reads. 

Linwood


ap@CaptivePhotons.com
 

Howard Hedlund wrote:

 

  • Linwood, that is truly a wonderful summation.  May I steal some of your text?

 

You can steal, or accept it as a gift, or better yet borrow the words, put them into a better order so it makes more sense, add some more for flavoring, and send them back.  😊

 

Linwood

 

 

From: main@ap-gto.groups.io <main@ap-gto.groups.io> On Behalf Of Howard Hedlund via groups.io
Sent: Tuesday, October 4, 2022 3:08 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] APCC Error connecting to AP V2 ASCOM

 

 

Mag. 7 or Better Skies!

 

Howard Hedlund

Astro-Physics, Inc.

AP Phone: 815-282-1513

Direct Mobile Phone:  815-315-7015

Video Tutorials:  https://www.youtube.com/astrophysicscorp

www.astro-physics.com

Please include this e-mail with your response.

_._,_._,_


S Berrada
 

Hi Everyone,

I appreciate the great explanations and insight.

In my specific case, it appears to be an issue where my primary computer remains stuck with old ASCOM /APCC settings (corruption?) no matter what I do - I will explain.

In summary I got the connections to work perfectly with my back up computer, but not with my primary computer which keeps giving me errors (details and images below).  The primary computer had been working well for several months.  Both computers use windows 10.

As well, as further information, I always start APCC first.   

After connecting APCC to the mount, I used to get the ASCOM driver started by clicking on the ‘connect’ APV2 driver in APCC; but after this thread I continue to connect APCC first, but get ASCOM started through NINA (click on Nina mount connection settings button which triggers ASCOM settings to pop up).

I talked to George earlier today and as usual he provided excellent support and gave me some great advice.

However, unfortunately the primary computer kept giving me errors.

Following the repeated errors (402), I deleted both APCC and the ASCOM driver, and then reinstalled both.  I will show below the connection steps, sequence of errors and corresponding screen images, but before I do that I will explain something  of interest. After reloading APCC and ASCOM driver, I changed a few APCC settings (such as Park 5 instead of Park 1) but for some reason the error codes kept coming from ASCOM settings window (error 402) as well as warnings which relate to old settings (e.g. park 1 warning) .  Although I reloaded both softwares, It appears that the computer still held on to the old APCC / ASCOM settings?

Here is my sequence and images:
1) Power mount 
2) Load APCC and connect to mount - see image 1 (note:  I used USB connection in this case, but have also used Ethernet cable connection with same errors)
3) Click on “auto-config” now in APCC - see image 2, 3 and 4
- image 2 shows the pop up asking me if I want to configure the ASCOM settings
- image 3 shows the ‘402 error’ as well as a warning about park 1 position (although I had reloaded APCC and changed to park 5)
- image 4 shows “driver successfully configured’ (in spite of the pop ups just before)
4) I load NINA and click on settings which triggers the ASCOM settings window - image 5.
- of interest, I keep getting the park 1 warning (Although APCC is set to P5)
- I also keep getting the “IP address” checked (although I changed APCC to USB connection )
- so ASCOM seems to remember some old settings 
5) In the ASCOM settings window, I unclick “IP addr” and click on “use ASCOM serial object” to use the virtual port 30.   When I click on  “ check port”, I get a pop up which confirms that the mount was found - see image 6
6) After step 5, I click on “OK” in the ASCOM settings window, but immediately get the dreaded “402 error” as well as the park 1 warning (although APCC was changed to P5) - see image 7
- normally the ‘OK’ should make the settings changes and close the ASCOM settings window; but instead I get the errors so although do not see the ASCOM settings window anymore, I wonder if it was able to close it due to the errors ?

After multiple attempts, including powering down mount and restarting windows, the same errors kept coming so I gave up and changed to my back up computer which worked fine.

So the obvious questions:
- The primary computer worked fine for several months, so what happened to bring the errors ?
- How did the primary computer remember the old APCC / ASCOM settings although I deleted and reinstalled both softwares ?
- what is the best course of action for the primary computer (other the erasing all the disk and reinstalling everything)?

PS: I also have a Mach2 which works perfectly with a third computer.

thanks
Sam