APCC Environmental Settings do not stick #APCC


Eric Claeys
 

When I try to enable an ASCOM ObservingConditions source in the Environmental Configuration/Status dialog box, clicking on "Test" shows the temp, humidity, and dew point (my device doesn't save pressure to the file).
However, when I click on "OK" then get back into the dialog box, it lost my settings and "THUM" is selected.  The Driver I'm using is "ASCOM SkyAlert ObservingConditions", which works fine in SGP.  I also tried the ASCOM simulator, and it did the same thing.

Am I doing something wrong, or is this a bug?  APPC Pro version 1.8.8.17.

Eric


Ray Gralak
 

Hi Eric,

It could be that your settings file has gotten corrupted. With APCC not running, try deleting or renaming, C:\ProgramData\Astro-Physics\APCC\settings.apcc, then start APCC.

You will have to re-enter your settings if that was the problem. Or, you can try loading one of apcc's backup files in:

C:\ProgramData\Astro-Physics\APCC\Backups

The backup files are date-coded in the filenames so you can try picking backups progressively back in time until you find one that works.

-Ray

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Eric Claeys
Sent: Thursday, May 27, 2021 11:46 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] APCC Environmental Settings do not stick #APCC

When I try to enable an ASCOM ObservingConditions source in the Environmental Configuration/Status dialog
box, clicking on "Test" shows the temp, humidity, and dew point (my device doesn't save pressure to the file).
However, when I click on "OK" then get back into the dialog box, it lost my settings and "THUM" is selected. The
Driver I'm using is "ASCOM SkyAlert ObservingConditions", which works fine in SGP. I also tried the ASCOM
simulator, and it did the same thing.

Am I doing something wrong, or is this a bug? APPC Pro version 1.8.8.17.

Eric


Eric Claeys
 

That worked Ray.  Thanks.
There were 4 <HorizonLimit> sections and multiple <PointingModel>, <Initialize>, and other sections.  I assume that shouldn't be the case?
Eric


Ray Gralak
 

Hi Eric,

That worked Ray. Thanks.
There were 4 <HorizonLimit> sections and multiple <PointingModel>, <Initialize>, and other sections. I assume
that shouldn't be the case?
Correct, there should not be multiple sections with the same tag. The settings file was corrupted.

-Ray

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Eric Claeys
Sent: Friday, May 28, 2021 4:21 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] APCC Environmental Settings do not stick #APCC

That worked Ray. Thanks.
There were 4 <HorizonLimit> sections and multiple <PointingModel>, <Initialize>, and other sections. I assume
that shouldn't be the case?
Eric