APCC does not allow me to delete unwanted virtual port


drgert1
 

Hi,

APCC has com3 and com12 in its list of virtual ports it creates. I don't want com3. I only have one serial port com5 connected to the mount. So the mapping should go from com5 to com12 (see my other post for my question to un-do that mapping in the AP driver). But this one is about the com3.   Many times I have clicked on delete and/or changed the setting to 'None'. I exit APCC even reboot the PC and upon start APCC has com3 again in the list. How do I get rid of it?

There should be a tutorial for APCC newbies to prevent them from unknowingly making hard modifications to the laptop that are unwanted.Or at least some big red popup  that some setting in APCC is non-usual and user should not 'OK' it.



Thanks & Clear Skies,
Gert


Bill Long
 

What Ray should do, as I told him before is not use low level ports that common devices will bind to.  😋 

From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of drgert1 via groups.io <drgert1@...>
Sent: Wednesday, August 24, 2022 9:00 PM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: [ap-gto] APCC does not allow me to delete unwanted virtual port
 
Hi,

APCC has com3 and com12 in its list of virtual ports it creates. I don't want com3. I only have one serial port com5 connected to the mount. So the mapping should go from com5 to com12 (see my other post for my question to un-do that mapping in the AP driver). But this one is about the com3.   Many times I have clicked on delete and/or changed the setting to 'None'. I exit APCC even reboot the PC and upon start APCC has com3 again in the list. How do I get rid of it?

There should be a tutorial for APCC newbies to prevent them from unknowingly making hard modifications to the laptop that are unwanted.Or at least some big red popup  that some setting in APCC is non-usual and user should not 'OK' it.



Thanks & Clear Skies,
Gert


Ray Gralak
 

Hi Bill,

A user can manually select high numbered ports if they want, otherwise APCC selects from the lower ports first. If Microsoft Windows has some policy to not use COM3 even though it is unused, please share it. :-) As for other usb devices, if they use the same port, then they should be connected first so that apcc will select a different port.

-Ray

-----Original Message-----
What Ray should do, as I told him before is not use low level ports that common devices will bind to. 😋
________________________________

Hi,

APCC has com3 and com12 in its list of virtual ports it creates. I don't want com3. I only have one serial port com5
connected to the mount. So the mapping should go from com5 to com12 (see my other post for my question to un-
do that mapping in the AP driver). But this one is about the com3. Many times I have clicked on delete and/or
changed the setting to 'None'. I exit APCC even reboot the PC and upon start APCC has com3 again in the list.
How do I get rid of it?

There should be a tutorial for APCC newbies to prevent them from unknowingly making hard modifications to the
laptop that are unwanted.Or at least some big red popup that some setting in APCC is non-usual and user should
not 'OK' it.



Thanks & Clear Skies,
Gert


Bill Long
 

Windows does not have an affinity per se to COM3. Device drivers tend to want to bind to lower ports, and when people change gear around, those ports get changed, etc.

All you need to do is just bind at high numerical ports that no device would ever care about. Silly problem solved. 

From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Ray Gralak <iogroups@...>
Sent: Wednesday, August 24, 2022 11:35 PM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: Re: [ap-gto] APCC does not allow me to delete unwanted virtual port
 
Hi Bill,

 A user can manually select high numbered ports if they want, otherwise APCC selects from the lower ports first. If Microsoft Windows has some policy to not use COM3  even though it is unused, please share it. :-) As for other usb devices, if they use the same port, then they should be connected first so that apcc will select a different port.

-Ray

> -----Original Message-----
> What Ray should do, as I told him before is not use low level ports that common devices will bind to.  😋
> ________________________________
>
> Hi,
>
> APCC has com3 and com12 in its list of virtual ports it creates. I don't want com3. I only have one serial port com5
> connected to the mount. So the mapping should go from com5 to com12 (see my other post for my question to un-
> do that mapping in the AP driver). But this one is about the com3.   Many times I have clicked on delete and/or
> changed the setting to 'None'. I exit APCC even reboot the PC and upon start APCC has com3 again in the list.
> How do I get rid of it?
>
> There should be a tutorial for APCC newbies to prevent them from unknowingly making hard modifications to the
> laptop that are unwanted.Or at least some big red popup  that some setting in APCC is non-usual and user should
> not 'OK' it.
>
>
>
> Thanks & Clear Skies,
> Gert
>







Ray Gralak
 

All you need to do is just bind at high numerical ports that no device would ever care about. Silly problem solved.
The goal was to make the virtual COM ports available to all applications. APCC does not start with higher port numbers because there are non-ASCOM applications that do not have the ability to select higher COM port numbers (e.g. PulseGuide and older versions of TheSky).

While APCC is running, users can plug and unplug devices that create virtual COM ports as needed. As a compromise, if a device needs to be on a specific COM port, the user should plug in the device before APCC allocates virtual COM ports. Once APCC starts and dynamically allocates virtual ports, APCC won't change them unless restarted.

Or, the user, knowing he will never use an application other than the ASCOM driver connected directly to one of APCC's virtual COM ports, can manually configure high virtual port numbers if they want. APCC will remember them and use them when starting unless they are already in use by something else.

-Ray


drgert1
 

Hello All,

Trying a modern times method of communicating the issue. :-) I've recorded some screen share in zoom showing what I was reporting.
Hope the video plays for you (it's the mp4 format as exported by zoom) Let me know if it works. :-)

https://www.skywatcher.space/download/video1668129897.mp4

Thanks & Clear Skies,
Gert


Ray Gralak
 

https://www.skywatcher.space/download/video1668129897.mp4
Sorry but the deleted virtual port is not going to stay deleted when you also have "Create Virtual Ports first" enabled :-) APCC is just going to pick the first port available starting from COM3.

Instead, with "Create Virtual Ports first" enabled, manually set the port numbers to whatever you want, say COM40 and COM41.

Then, exit APCC, restart APCC, and watch in amazement when APCC uses COM40 and COM41. :-)

-Ray


drgert1
 

Hi Ray,

Thanks for checking my screencapture (with eagle eyes) and finding the setting. Looking in the docs they say that it is recommended to leave this box checked.

But why two virtual ports. It was my effort to simplify handling these virtual ports as much as possible and I was thinking that one port is enough.

Under the premise that APCC always want two virtual com ports then I can understand it's behavior upon me deleting com3 which was the second port it upon restart created it at the lowest free number (com3) again to get back to the desired two ports. But why two?

Anyway thanks for clarifying.

Cheers,
Gert


Ray Gralak
 

Hi Gert,

There are two ports for a reason. When an application that has been run "as administrator" invokes the driver it will start a completely separate instance of the ASCOM driver than an application run as a normal user. Mixing applications run as administrator and not can thus invoke two instances of a driver, thus the need for two virtual ports. Using APCC as a serial port hub the two ASCOM driver instances can be active simultaneously controlling the same mount, each using its own virtual COM port. I believe because of APCC's serial port hub APCC, the AP V2 driver is the only ASCOM driver that can do this.

-Ray

-----Original Message-----
Hi Ray,

Thanks for checking my screencapture (with eagle eyes) and finding the setting. Looking in the docs they say that
it is recommended to leave this box checked.

But why two virtual ports. It was my effort to simplify handling these virtual ports as much as possible and I was
thinking that one port is enough.

Under the premise that APCC always want two virtual com ports then I can understand it's behavior upon me
deleting com3 which was the second port it upon restart created it at the lowest free number (com3) again to get
back to the desired two ports. But why two?

Anyway thanks for clarifying.

Cheers,
Gert