I cannot connect the AP V2 driver using APCC #APCC #Mach2GTO


Marcelo Figueroa
 

Update:
 
I tried both suggestions, the loading a backup configuration and the "Now" button in Auto-Config and it worked. Now the driver can be launched from APCC again.


Greg McCall
 

BTW, are you exiting APPM after finishing a model as it connects to the mount and is separate to APCC and will hold up the ASCOM driver 

On Thu, 4 Aug 2022 at 12:44 pm, Chris White <chris.white@...> wrote:
Good tip Ray. I'll notice that in the future. Thank you, -chris


Chris White
 

Good tip Ray. I'll notice that in the future. Thank you, -chris


Ray Gralak
 

Hi Chris,

Every time I've had thus issue I've never had anything connected to the driver. I always close everything before
closing apcc.

There is a bug either with apcc or ascom. The only way to resolve it when things freeze is to kill the driver in
background processes in task manager.
More likely, there may be a bug in one of the client applications you are running. Specifically, an application may not be disconnecting from the driver before closing down. The "clients" count in the driver shows how many connections there are at any time, so watch that. If it is non-zero something is still connected.

-Ray


Chris White
 

Ray,

Every time I've had thus issue I've never had anything connected to the driver. I always close everything before closing apcc. 

There is a bug either with apcc or ascom.  The only way to resolve it when things freeze is to kill the driver in background processes in task manager.

I'm trying to figure out what causes the issue in the first place. It's either 1) an issue where the v2 driver didn't close properly when previously launched or 2) a problem caused by the autoconnect feature in apcc where the driver process starts but does not complete. 


Ray Gralak
 

I had the same problem for a while and reported it. It happened again last night. What happens is the v2 driver is
not closing properly from your previous shut down.
The driver cannot close itself if an application is still connected to the driver. Also, if you "kill" an application connected to the driver, or that application crashes, then the application never properly disconnected from the driver and the driver cannot shut itself down.

So, you should be careful to disconnect all applications from the driver. It will automatically close when all clients disconnect, including APCC, if it was connected to the driver. If you need to forcibly shut down the driver because of an ASCOM client application crash you can double click the "Clients" label in the driver's window.

-Ray


ap@CaptivePhotons.com
 

On Wed, Aug 3, 2022 at 09:22 PM, Chris White wrote:
One more thing to consider, is that it might not be an issue where the driver didnt close properly from a previous session
If it's ascom that keeps you from closing normally, you can click on the ... I think it's a bar near the top with the counts?  Sorry, my NUC/mount is put away for visitors coming, can't look, but there's a place you click that allows you to force close ASCOM even if it thinks a client is connected.  With ASCOM closed APCC should close.

Linwood


Chris White
 

On Wed, Aug 3, 2022 at 03:59 PM, Chris White wrote:
I had the same problem for a while and reported it. It happened again last night. What happens is the v2 driver is not closing properly from your previous shut down. If you go to task manager check under background processes you will see that the v2 driver is still a running process. End this task and apcc will then be able to connect.  You do not need to end apcc. As soon as you end that driver in the background processes it will unfreeze on its own. 
One more thing to consider, is that it might not be an issue where the driver didnt close properly from a previous session, but rather the driver isnt opening properly if "auto connect" is enabled.  I've got to test this out a bit more on my end, but chatting with Bill, he has never seen the issue and has autoconnect disabled. 

Ray, could this be the culprit? 


Marcelo Figueroa
 

Thank you all, I will try what you suggested next time.


Chris White
 

I had the same problem for a while and reported it. It happened again last night. What happens is the v2 driver is not closing properly from your previous shut down. If you go to task manager check under background processes you will see that the v2 driver is still a running process. End this task and apcc will then be able to connect.  You do not need to end apcc. As soon as you end that driver in the background processes it will unfreeze on its own. 


Mike Hanson
 

Marcelo,

Since it works when the ASCOM client launches the driver, but not when APCC launches it, that implies the COM port settings in the driver "Setup Telescope" might not match the driver settings in APCC.  The driver may be set to use a physical port, whereas a virtual or (or ReST API) is needed to connect from APCC.  Did you click the "NOW" button to ask APCC to configure the driver?

Regards,
Mike


Ray Gralak
 

Hi Marcelo,

Since a few days ago, when in APCC I click the connect driver button nothing happens (and sometimes APCC
freezes and I have to do a forced quit). Now if after connecting the mount in APCC I go to SGP and connect the
mount from there, it launches the driver correctly and everything works fine.
I doubt this has anything to do with the firmware or the driver would not connect with SGPro. There was likely a popup message hidden behind another window that you didn't notice. This would make APCC appear unresponsive.

Killing APCC through task manager runs the risk of corrupting its settings file, which may have happened already. You might try restoring settings from an earlier date from APCC's backups folder.


To load a backup, disconnect APCC from the mount, then in APCC's file menu click, "Load Settings...". Then in the dialog box, navigate to this folder and pick a backup file from this folder:

C:\ProgramData\Astro-Physics\APCC\Backups

Each backup's filename has a date in its filename so you can choose an appropriate date to restore settings.

-Ray


Marcelo Figueroa
 

The procedure I have always used to connect my Mach 2 is as follows: Launch APCC, connect the mount and then connect the AP V2 driver. Afterwards I go to my imaging program (SGP) and connect everything, so far it always worked.
 
Since a few days ago, when in APCC I click the connect driver button nothing happens (and sometimes APCC freezes and I have to do a forced quit). Now if after connecting the mount in APCC I go to SGP and connect the mount from there, it launches the driver correctly and everything works fine.
 
The only change made recently is the GTOCP5 firmware upgrade, does it have something to do with this? 
 
The APCC and driver versions are the latest available.