APCC Virtual Ports intermittenly not working

Rory Clarke

I am running APCC from Windows 10 from a USB connection on an AP Mach 1 using a G4 controller. My issue is my virtual comm ports don't work most of the time, but every once in awhile after testing various comm ports it will work for a session, but when I restart my computer it will not work anymore. I am always trying comm ports greater than 21, but I Have used lower number ports as well (in this picture below I tried 5 and 6). I have spent several nights (3 or 4 entire nights) attempting to trouble shoot this. I have click all the buttons (create virtual ports first, auto connect, auto-config, auto start) in every combination possible and have reset my computer countless times. Like I said, every once in a while I'll get lucky and the comm port will recognize, but it is not repeatable. When it works, it's great. 

Howard Hedlund

Hi Rory,
I would pull a *ditch and switch.*  Ditch the virtual ports and switch to using the ReST API to connect the driver to APCC
Set up APCC for the ReST API in the API tab of the Advanced Settings window.  You will need to restart APCC.
Set up the ReST API in the driver.
Done.  Call me if you have further questions.

Rory Clarke

Thanks you, I will give that a try and get back, it's going to be a couple days before I can make it out to my observatory though.

Much appreciated!

Stacey Mills

"Ditch & switch" is probably the best solution.  However, you might want to go to Device Manager in Windows (with APCC closed) and see if your virtual ports were properly terminated the last time APCC closed.  I've been down this route.  If APCC isn't allowed to close properly the virtual ports will not be properly closed and next time you run APCC they won't work.  You can delete the ports from Device Manager and start over. 

Rory Clarke

On Mon, Jun 6, 2022 at 09:49 AM, Howard Hedlund wrote:
ReST API to connect the driver to APCC

Working great so far! Thanks for the advice!


PS. Do you post your images anywhere? 

Rory Clarke

Yes, I had deleted all my virtual ports, restarted the computer, updated APCC, numerous times and nothing worked (actually, it would occasionally work and then quit working on a computer restart, even if everything was shut dow properly). "Ditch & Switch" has been working great so far.


Thanks for your replay! @Stacey Mills

Stacey Mills

Glad your problem has been solved.  I'll stick with the virtual ports for now since they're working, but great to have an alternative.
If you were asking about my images, most of them are at:  www.astrobin.com/users/w4sm

-Stacey (W4SM)