Unable to update firmware of CP4


sroberts84
 

Hello Mike,
Can you share the production timeframe involved?
Or, better yet - is there a check one can make to determine if a CP4 unit has the version of silicon? 

Thanks., 


Alex
 

Ok, Mike remoted in via TeamViewer and updated the firmware.  Excellent support from AP as usual.  I should be able to update myself in the future.

Alex


Konstantin v. Poschinger
 

Thanks Mike,

Konstantin 

Von meinem iPhone gesendet

Am 27.05.2022 um 18:36 schrieb Mike Hanson <mikeh@...>:

Hi Konstantin,

The symptoms have nothing to do with P02-08.  They are related to differences in silicon.

We received a different version of silicon than we specified a while back.  Unfortunately, by the time we discovered this, a few units had snuck out the door.  P02-08 is what we happened to be shipping at the time.  All versions subsequent to P02-08 accommodate multiple versions of silicon.  The silicon differences only affect field updates of firmware, which is why they test fine in the factory and in the observatory.

Regards,
Mike


Mike Hanson
 

Hi Konstantin,

The symptoms have nothing to do with P02-08.  They are related to differences in silicon.

We received a different version of silicon than we specified a while back.  Unfortunately, by the time we discovered this, a few units had snuck out the door.  P02-08 is what we happened to be shipping at the time.  All versions subsequent to P02-08 accommodate multiple versions of silicon.  The silicon differences only affect field updates of firmware, which is why they test fine in the factory and in the observatory.

Regards,
Mike


Konstantin v. Poschinger
 

Hi Mike,

can you please explain what is new in this Version. 

Konstantin 

Von meinem iPhone gesendet

Am 27.05.2022 um 14:53 schrieb Mike Hanson <mikeh@...>:

Hi Alex,

We'll contact you privately.

Anyone else with symptoms identical to Alex's, please contact us directly.  It requires a little TLC to get past P02-08 in a very small subset of control boxes.

Regards,
Mike Hanson


Mike Hanson
 

Hi Alex,

We'll contact you privately.

Anyone else with symptoms identical to Alex's, please contact us directly.  It requires a little TLC to get past P02-08 in a very small subset of control boxes.

Regards,
Mike Hanson


Peter Nagy
 

Try downloading .pt1 file first and then .pt2 file.

Peter


Alex
 


I have an 1100 with a GTOCP4 running the VCP4-P02-08 version of the firmware.  I just attempted to update it to the latest VCPX-P02-11.  I freshly powered cycled the CP4 after removing the USB connection to the computer.  I have no problem connecting to the embedded web page of the CP4 via the ethernet connection.  I go the the Load New Software page, select the VCPx-P02-11.pt2 file and the page indicates the file is ok.  I hit the program button, the download is ok, it prepares the file the says it's "Running New Program".  I then choose the VCPx-P02-11.pt1 file and hit the program button, and the page updates with "Resumed Operation".  When I return to main, the displayed version is still VCP4-P02-08.  I've done this several times now.  I never see an error, but the version doesn't update.  Any suggestions as to what I may try next?

Alex