Ethernet Connection to Mount in APCC


M Hambrick
 

In the troubleshooting discussions of why my mount status is not being updated in MaxIm DL after slew commands it was suggested that when connecting to the mount with an ethernet cable that it should be done through an ethernet hub (e.g. Netgear). 

Is this necessary ?

Mike


ap@CaptivePhotons.com
 

M Hambrick wrote:

 

  • In the troubleshooting discussions of why my mount status is not being updated in MaxIm DL after slew commands it was suggested that when connecting to the mount with an ethernet cable that it should be done through an ethernet hub (e.g. Netgear). 

Short answer: if it's working at all, you do not need a hub (switch).

 

Longer answer: A switch (so far as I know you can't buy a real hub any more) generally provides: (1) ability to have more than 2 devices share the same ethernet, (2) allow devices with different speeds, that cannot adjust, to communicate, (3) allow devices with different duplex that cannot adjust to communicate, (4) allow devices that cannot auto-sense transmit/receive to communicate, and (5) to provide power if a device requires Power over Ethernet.

 

Anything made in the last decade or so already handles (2) thru (4), mostly (5) is just for things like security cameras and very rarely anything you will run into with telescopes, so the only real need for a hub/switch is to allow more than 2 devices to talk to each other jointly.  And you would know if you had more than 2.

 

It's not like a powered USB hub where you might get a more solid connection, longer cable use, etc.  For the most part, for this sort of thing, ethernet either works, or doesn't, and when it does not it is almost always bad configuration.   

 

[Network engineers here can tell hours of stories of flakey wiring and incompatible standards that give lie to the above, but … this is about a simple computer to mount connection, but in those weird cases a switch didn't fix it anyway I bet!]


Peter Nagy
 

Mine works with direct connection to computer Ethernet port or through Ethernet switch. It shouldn't matter. I don't use APCC, just A-P V2 ASCOM mount driver. 

Peter