Park to home from imaging application (SGPro?)


Anis Abdul
 

Hi Brian, 
Thank you. The issue is, I dont want (can't) to park in any of the pre-defined park position because of the aforementioned roof. I could possibly make it work with Park 4 when I go back to the observatory and reduce the pier height a bit.  If I had the option of either parking to Home position (defined in APCC) or if the Alt-Az positions have same behavior between APCC and ASCOM, then this would be resolved quite nicely.
I am hoping this is user error and there is a way to park to that precise user defined position . Else I have to figure out adjusting the pier. 
Thanks
Anis


 

Hi Anis

I think there is an option you may have missed, i park in position 3 all the time via SGP

see bottom left


image.png


On Mon, Apr 12, 2021 at 10:47 AM Anis Abdul <anismo@...> wrote:

I have an AP900 setup in my observatory and the pier is tall enough that I need the scope to parked in a specific position to prevent it from interfering with the roof (and also to point to the wall). 
Using APCC standard, I have configured the correct position and it is working well and accurately.

The problem is, with SGP, I want to park to that position each time and it connects to the AP ASCOM V2 driver. The AP ASCOM V2 driver has only "Current Position" , "Park 1 to 5" and "Alt/Az" position.  

Ideally if the ASCOM driver can pass through the park command to APCC , it would do the job (since APCC is set to park to Home position). However, since I dont see that option, I set up  User defined Alt-Az position as the park position.

The issue I see is, the resolution of the Alt/Az of APCC is higher than that of ASCOM driver,
The APCC Alt-Az is set to 30:54:34.8 and 00:00:00.6
The ASCOM sees it as 30:54:34 and 00:00:01

If I do park from the ASCOM driver to the Alt/Az it does not go the require position (it is slightly off but enough to be a problem). If I park from APCC, it is perfect.

Is there any setting or option I am missing (I did look into the documentation ) but cant figure out how to get the park to go to the Home position .

Thanks in advance
Anis





--
Brian 



Brian Valente


Anis Abdul
 

I have an AP900 setup in my observatory and the pier is tall enough that I need the scope to parked in a specific position to prevent it from interfering with the roof (and also to point to the wall). 
Using APCC standard, I have configured the correct position and it is working well and accurately.

The problem is, with SGP, I want to park to that position each time and it connects to the AP ASCOM V2 driver. The AP ASCOM V2 driver has only "Current Position" , "Park 1 to 5" and "Alt/Az" position.  

Ideally if the ASCOM driver can pass through the park command to APCC , it would do the job (since APCC is set to park to Home position). However, since I dont see that option, I set up  User defined Alt-Az position as the park position.

The issue I see is, the resolution of the Alt/Az of APCC is higher than that of ASCOM driver,
The APCC Alt-Az is set to 30:54:34.8 and 00:00:00.6
The ASCOM sees it as 30:54:34 and 00:00:01

If I do park from the ASCOM driver to the Alt/Az it does not go the require position (it is slightly off but enough to be a problem). If I park from APCC, it is perfect.

Is there any setting or option I am missing (I did look into the documentation ) but cant figure out how to get the park to go to the Home position .

Thanks in advance
Anis