Topics

Preventing tracking on power up?


Ray Gralak
 

Hi Tom,

So I guess the only option is to only connect when you are ready. Which is what I am now doing.
You can connect with apcc and have it stop tracking, as I explained in my post yesterday. If you believe you have logs that show otherwise, please post a link to your logs, and we'll take a look at what happened.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Tom Blahovici
Sent: Monday, November 23, 2020 5:19 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Preventing tracking on power up?

Well that was the first thing I did. I set the hand controller to EXT.
So I guess the only option is to only connect when you are ready. Which is what I am now doing.
All solved.


Bill Long
 

If its Voyager, be sure to uncheck "unpark on connect" and "track on connect" as you see below. Ignore the simulator this is my test machine the screenshot is from.




From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Roland Christen via groups.io <chris1011@...>
Sent: Monday, November 23, 2020 5:57 PM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: Re: [ap-gto] Preventing tracking on power up?
 

So I guess the only option is to only connect when you are ready.
How are you connecting? What program?

Rolando


-----Original Message-----
From: Tom Blahovici <tom.va2fsq@...>
To: main@ap-gto.groups.io
Sent: Mon, Nov 23, 2020 7:18 pm
Subject: Re: [ap-gto] Preventing tracking on power up?

Well that was the first thing I did. I set the hand controller to EXT.
So I guess the only option is to only connect when you are ready. Which is what I am now doing.
All solved.

--
Roland Christen
Astro-Physics


Roland Christen
 


So I guess the only option is to only connect when you are ready.
How are you connecting? What program?

Rolando


-----Original Message-----
From: Tom Blahovici <tom.va2fsq@...>
To: main@ap-gto.groups.io
Sent: Mon, Nov 23, 2020 7:18 pm
Subject: Re: [ap-gto] Preventing tracking on power up?

Well that was the first thing I did. I set the hand controller to EXT.
So I guess the only option is to only connect when you are ready. Which is what I am now doing.
All solved.

--
Roland Christen
Astro-Physics


Tom Blahovici
 

Well that was the first thing I did. I set the hand controller to EXT.
So I guess the only option is to only connect when you are ready. Which is what I am now doing.
All solved.


Roland Christen
 

Autoconnect is the software that tells it to unpark. So turning Autoconnect off will cause the keypad to pause until you physically push the enter button which then initializes the mount.
You can also set the keypad to EXT, in which case it will wait for an external program to initialize.

Rolando



-----Original Message-----
From: Tom Blahovici <tom.va2fsq@...>
To: main@ap-gto.groups.io
Sent: Mon, Nov 23, 2020 5:05 pm
Subject: Re: [ap-gto] Preventing tracking on power up?

Exactly what I have now. However it still started tracking without any software telling it to unpark once.
Problem solved. Just connect when you are ready. Sorry I did this 3 times and once it started. The second time.
So it worked the first time and the third time. I can't allow it to start so autoconnect is now off.
Tom

--
Roland Christen
Astro-Physics


Tom Blahovici
 

Exactly what I have now. However it still started tracking without any software telling it to unpark once.
Problem solved. Just connect when you are ready. Sorry I did this 3 times and once it started. The second time.
So it worked the first time and the third time. I can't allow it to start so autoconnect is now off.
Tom


Roland Christen
 

I don't have Voyager, but with my SkyX it will NOT unpark unless I issue an unpark command.

I can set my mount up for the absolute simplest startup (no keypad connected or connected in EXT mode). This is what I can do:

1) Turn power on to the mount. The mount is still parked and motors are de-energized. No tracking possible.
2) Bring up SkyX. I do not connect or unpark. Mount is still parked with motors de-energized. It will NOT track.
3) I simply click on a target object in SkyX and press Slew. Sky X automatically brings up the ASCOM driver, initializes and un-parks the mount. The scope slews to the target object.
4) Done, nothing more to do.

Rolando



-----Original Message-----
From: Tom Blahovici <tom.va2fsq@...>
To: main@ap-gto.groups.io
Sent: Mon, Nov 23, 2020 3:21 pm
Subject: Re: [ap-gto] Preventing tracking on power up?

I got it to work with a combination of items.  The keypad is now external.  The initialize is set to Don't unpark.
One out of three times of power on it still started tracking.  I had to the above again.  This is with no software connected other than APCC.
Finally, I turned off the "connect to mount" when APCC starts
Now I can turn that on manually and can watch what is happening.
Seems overly complex.  The mount should not start tracking until it gets an unpark command.  All my software (TheSkyX, Voyager) issue an unpark command when started. But what do I know, there's probably good reasons for this.
Tom

--
Roland Christen
Astro-Physics


Tom Blahovici
 

I got it to work with a combination of items.  The keypad is now external.  The initialize is set to Don't unpark.
One out of three times of power on it still started tracking.  I had to the above again.  This is with no software connected other than APCC.
Finally, I turned off the "connect to mount" when APCC starts
Now I can turn that on manually and can watch what is happening.
Seems overly complex.  The mount should not start tracking until it gets an unpark command.  All my software (TheSkyX, Voyager) issue an unpark command when started. But what do I know, there's probably good reasons for this.
Tom


Roland Christen
 

1) If you don't initialize, the mount won't start tracking.
 Initialize is done with either keypad, ASCOM driver or APCC. All of them can be set to "NOT initialize on startup".
2) If you do initialize and unpark the mount with any of these three applications, you can still prevent the mount from tracking by setting each one of them from Sidereal to STOP.

Rolando



-----Original Message-----
From: Tom Blahovici <tom.va2fsq@...>
To: main@ap-gto.groups.io
Sent: Mon, Nov 23, 2020 2:14 pm
Subject: Re: [ap-gto] Preventing tracking on power up?

-What would you like to stop from happening?
 
-Rolando

I want to power up my observatory. This means,
1. Power on for the computer, camera. Mount. CP4.
2. Leave the mount parked. I don't want it to automatically start tracking.

Up to now, Everytime I finish a session I park the mount, then unplug the CP4. That prevents it from starting tracking.
I think I have all the I go I need now to resolve this in this thread. I will try a little later tonight.
Tom
















--
Roland Christen
Astro-Physics


Tom Blahovici
 

-What would you like to stop from happening?
 
-Rolando

I want to power up my observatory. This means,
1. Power on for the computer, camera. Mount. CP4.
2. Leave the mount parked. I don't want it to automatically start tracking.

Up to now, Everytime I finish a session I park the mount, then unplug the CP4. That prevents it from starting tracking.
I think I have all the I go I need now to resolve this in this thread. I will try a little later tonight.
Tom
















Roland Christen
 


When I turn the power on, apcc is not started. I need to open it and then it automatically connects. Then tracking starts.
I searched everywhere in apcc and could not find anything to stop this from happening.
What would you like to stop from happening?

Rolando


-----Original Message-----
From: Tom Blahovici <tom.va2fsq@...>
To: main@ap-gto.groups.io
Sent: Sun, Nov 22, 2020 3:45 pm
Subject: Re: [ap-gto] Preventing tracking on power up?

Hi
When I turn the power on, apcc is not started. I need to open it and then it automatically connects. Then tracking starts.
I searched everywhere in apcc and could not find anything to stop this from happening. I may have missed it though. I will check the hand controller. I guess I don't really need it anymore.
Snowing now, so the next opportunity I will check the hand controller.
Thanks, Tom

--
Roland Christen
Astro-Physics


Cheng-Yang Tan
 

Hi Tom,
  I just don't let APCC auto-connect until I'm ready:

Inline image

My mount (Mach1GTO or AP1100) doesn't start tracking until I connect. Is this what you want?

cytan




On Sunday, November 22, 2020, 04:56:28 PM CST, Ray Gralak <groups3@...> wrote:


Tom,

One more thing, APCC will not change tracking status if the mount has been initialized previously (e.g. by the hand controller or a previous run of the driver or APCC had already initialized the mount).

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Tom Blahovici
> Sent: Sunday, November 22, 2020 1:45 PM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] Preventing tracking on power up?
>
> Hi
> When I turn the power on, apcc is not started. I need to open it and then it automatically connects. Then tracking
> starts.
> I searched everywhere in apcc and could not find anything to stop this from happening. I may have missed it though. I
> will check the hand controller. I guess I don't really need it anymore.
> Snowing now, so the next opportunity I will check the hand controller.
> Thanks, Tom
>






Konstantin von Poschinger
 

Hi,

If you have the hand congtroler set to auto connect, then it will start tracking with power on. Set it to extern!

Grüsse

Konstantin v. Poschinger


Hammerichstr. 5
22605 Hamburg
040/8805747
0171/1983476

Am 22.11.2020 um 19:44 schrieb Tom Blahovici <tom.va2fsq@...>:

Hi
It seems that even though the mount is parked at the end of the evening, and then the power is turned off, when the power is turned on, the mount automatically starts tracking.  This is an issue for me since the telescope is covered and I want to power up everything before uncovering it.
I am using APCC and have a CP4.  Is this a hand control issue?
Thanks, Tom


Ray Gralak
 

Tom,

One more thing, APCC will not change tracking status if the mount has been initialized previously (e.g. by the hand controller or a previous run of the driver or APCC had already initialized the mount).

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Tom Blahovici
Sent: Sunday, November 22, 2020 1:45 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Preventing tracking on power up?

Hi
When I turn the power on, apcc is not started. I need to open it and then it automatically connects. Then tracking
starts.
I searched everywhere in apcc and could not find anything to stop this from happening. I may have missed it though. I
will check the hand controller. I guess I don't really need it anymore.
Snowing now, so the next opportunity I will check the hand controller.
Thanks, Tom


Ray Gralak
 

> When I turn the power on, apcc is not started.

> I need to open it and then it automatically connects.

> Then tracking starts.

> I searched everywhere in apcc and could not find anything to stop this from happening.

 

The reason why tracking starts is that the mount itself starts tracking when unparked.

 

So if you are initializing the mount from APCC:

 

1)    In “Settings->Edit Mount Intialization Settings”, you can set “Unpark from: “ to “Don’t Unpark”. You would then need to unpark later when ready, which will automatically start tracking unless you have the next option selected.

2)    In “Settings->Edit Mount Intialization Settings”, you can enable “Set Tracking Rate” and set it to “Zero”. This will unpark the mount, which starts the mount tracking, then APCC immediately issues a command to stop tracking.

3)    After initialization, if you later park the mount and unpark it, the mount will start tracking unless you enable “Stop Tracking after unparking” on APCC’s Park tab.

 

For reference here is a screenshot of those three options:

 

 

 

 

-Ray Gralak

Author of PEMPro

Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro

Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

 

 

> -----Original Message-----

> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Tom Blahovici

> Sent: Sunday, November 22, 2020 1:45 PM

> To: main@ap-gto.groups.io

> Subject: Re: [ap-gto] Preventing tracking on power up?

>

> Hi

> When I turn the power on, apcc is not started. I need to open it and then it automatically connects. Then tracking

> starts.

> I searched everywhere in apcc and could not find anything to stop this from happening. I may have missed it though. I

> will check the hand controller. I guess I don't really need it anymore.

> Snowing now, so the next opportunity I will check the hand controller.

> Thanks, Tom


Tom Blahovici
 

Hi
When I turn the power on, apcc is not started. I need to open it and then it automatically connects. Then tracking starts.
I searched everywhere in apcc and could not find anything to stop this from happening. I may have missed it though. I will check the hand controller. I guess I don't really need it anymore.
Snowing now, so the next opportunity I will check the hand controller.
Thanks, Tom


Roland Christen
 

How are you starting the mount? With keypad or APCC?
keypad can be set for Autoconnect = NO, which will not start the mount upon power up, assuming it has been parked the previous session.
APCC can also be set to not start tracking on power up.
The ASCOM driver can also be set to not start on power up.

Rolando



-----Original Message-----
From: Tom Blahovici <tom.va2fsq@...>
To: main@ap-gto.groups.io
Sent: Sun, Nov 22, 2020 12:44 pm
Subject: [ap-gto] Preventing tracking on power up?

Hi
It seems that even though the mount is parked at the end of the evening, and then the power is turned off, when the power is turned on, the mount automatically starts tracking.  This is an issue for me since the telescope is covered and I want to power up everything before uncovering it.
I am using APCC and have a CP4.  Is this a hand control issue?
Thanks, Tom

--
Roland Christen
Astro-Physics


Ray Gralak
 

Hi Tom,

The mount should not unpark and start tracking by itself. Is APCC running and initializing the mount when powered on?

Is this a hand control issue?
If you are using APCC, you should configure the hand controller for external initialization or disconnect the hand controller.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Tom Blahovici
Sent: Sunday, November 22, 2020 10:44 AM
To: main@ap-gto.groups.io
Subject: [ap-gto] Preventing tracking on power up?

Hi
It seems that even though the mount is parked at the end of the evening, and then the power is turned off, when the
power is turned on, the mount automatically starts tracking. This is an issue for me since the telescope is covered
and I want to power up everything before uncovering it.
I am using APCC and have a CP4. Is this a hand control issue?
Thanks, Tom


Tom Blahovici
 

Hi
It seems that even though the mount is parked at the end of the evening, and then the power is turned off, when the power is turned on, the mount automatically starts tracking.  This is an issue for me since the telescope is covered and I want to power up everything before uncovering it.
I am using APCC and have a CP4.  Is this a hand control issue?
Thanks, Tom