Mach2 model building and pointing with Sequence Generator Pro


Steve Armen
 

This is meant for Ray Gralak. With the new mach2 being controlled by SGP version 3.2.0.613 and APCC/APPM latest version I have had two opportunities to test.

It may well be I am doing something incorrectly in the process. Let me preface this with my old mach1 could use SGP plate solve and sync, then pointing with coordinates with very accurate pointing results. I have carefully checked any parameters set for the OTA and camera. Since plate solves are passing, I'm assuming the required parameters are correct.

With the new mach2, here is the process I've been following:
1) Starting up, doing what I consider a good polar alignment with Sharpcap (3.2), then connecting with SGP.
2) Do a solve and sync with ASTAP (also tried platesolve2 with no difference in results) which is successful.
3) Try to slew to a target, e.g. Vega. The slew ends up with the target somewhere off in a corner or not even in the field of view (~32' x 22').
4) OK, not totally unusual so then use the "center target" which is plate solve based which always worked in the past. This moves the target somewhere ~ 10 arc min to the left of center and happily reports centering success. 

Let me further explain, I have attempted this two ways.
1) No APCC/APPM run, just the steps above.
2) Use the APCC/APPM flow as I read it, I did setup horizon limit before starting.
  a) power up, connect to APCC, park the mount at park 3, which always works!
  b) try the homing under the AE tab
  c) Run APPM to generate a sky model. So far have tried the small and medium models. All points plate solve successfully.

After the model run, I make sure both items below are selected:
Enable Pointing Correction
Enable Tracking Correction

When I try with either method 1 or 2 with or without model, the slow to object still has a large offset. 

One thing I am wondering is, how does the mount ever get synchronized to the sky? The plate solve and sync in SGP does not appear to be working. Does the model making process automatically sync the mount to the sky? 

Can you also let me know where are the APPC logs stored?

thanks,
Steve


 

Hi Steve

I am using SGP with the 1600AE, so i have a similar setup

just a couple suggestions/comments:

1. Are your user profile coordinates set up correctly in SGP? that could cause that initial offset in the goto
2. the APCC logs are in C:\ProgramData\Astro-Physics\APCC\Logs (or at least my logs are :) )
3. re: mount syncing to sky, yes the first part of model building includes an option (enabled by default) to "recal near zenith at start". you can use the goto/recal tab in APCC to sync your mount to the sky 

On Mon, Oct 19, 2020 at 8:38 PM Steve Armen <st5.armen@...> wrote:

This is meant for Ray Gralak. With the new mach2 being controlled by SGP version 3.2.0.613 and APCC/APPM latest version I have had two opportunities to test.

It may well be I am doing something incorrectly in the process. Let me preface this with my old mach1 could use SGP plate solve and sync, then pointing with coordinates with very accurate pointing results. I have carefully checked any parameters set for the OTA and camera. Since plate solves are passing, I'm assuming the required parameters are correct.

With the new mach2, here is the process I've been following:
1) Starting up, doing what I consider a good polar alignment with Sharpcap (3.2), then connecting with SGP.
2) Do a solve and sync with ASTAP (also tried platesolve2 with no difference in results) which is successful.
3) Try to slew to a target, e.g. Vega. The slew ends up with the target somewhere off in a corner or not even in the field of view (~32' x 22').
4) OK, not totally unusual so then use the "center target" which is plate solve based which always worked in the past. This moves the target somewhere ~ 10 arc min to the left of center and happily reports centering success. 

Let me further explain, I have attempted this two ways.
1) No APCC/APPM run, just the steps above.
2) Use the APCC/APPM flow as I read it, I did setup horizon limit before starting.
  a) power up, connect to APCC, park the mount at park 3, which always works!
  b) try the homing under the AE tab
  c) Run APPM to generate a sky model. So far have tried the small and medium models. All points plate solve successfully.

After the model run, I make sure both items below are selected:
Enable Pointing Correction
Enable Tracking Correction

When I try with either method 1 or 2 with or without model, the slow to object still has a large offset. 

One thing I am wondering is, how does the mount ever get synchronized to the sky? The plate solve and sync in SGP does not appear to be working. Does the model making process automatically sync the mount to the sky? 

Can you also let me know where are the APPC logs stored?

thanks,
Steve



--
Brian 



Brian Valente


Marcelo Figueroa
 

I also upgraded from a Mach1 to Mach2 and I also use SGP. This is what I do, it works perfectly:
 
 
1) Polar alignment
2) Launch APCC (make sure the location data is correct)
3) Connect Mount -> Initialize Mount
4) Connect Driver (make sure that the option use pc time is selected).
5) Launch SGP and connect all the equipment.
6) Slew the mount to a random point in the sky.
7) Solve & Sync.
 
And that's it. You can use the Frame & Mosaic Wizard option to direct the mount where you want, also you can connect and use your favorite planetary program to make tests (I use CdC).
 
Finally, for the modeling to work it is vital to have updated weather information. If you don't have a device that does, this option works fine (requires internet connection).
 


Ray Gralak
 

Hi Steve,

This is meant for Ray Gralak. With the new mach2 being controlled by SGP version 3.2.0.613 and APCC/APPM
latest version I have had two opportunities to test.
Are you using ASCOM Platform 6.5?

There is a known breaking change (bug) in 6.5 that causes the translation of the plate-solve coordinates from J2000.0 to the local apparent (JNow).

So, if you are using 6.5, you must either go back to ASCOM 6.4, or use the beta version of ASCOM Platform 6.5 Service Pack 1. Then you must recapture pointing data with APPM.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Steve Armen
Sent: Monday, October 19, 2020 8:39 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] Mach2 model building and pointing with Sequence Generator Pro

This is meant for Ray Gralak. With the new mach2 being controlled by SGP version 3.2.0.613 and APCC/APPM
latest version I have had two opportunities to test.

It may well be I am doing something incorrectly in the process. Let me preface this with my old mach1 could use
SGP plate solve and sync, then pointing with coordinates with very accurate pointing results. I have carefully
checked any parameters set for the OTA and camera. Since plate solves are passing, I'm assuming the required
parameters are correct.

With the new mach2, here is the process I've been following:
1) Starting up, doing what I consider a good polar alignment with Sharpcap (3.2), then connecting with SGP.
2) Do a solve and sync with ASTAP (also tried platesolve2 with no difference in results) which is successful.
3) Try to slew to a target, e.g. Vega. The slew ends up with the target somewhere off in a corner or not even in the
field of view (~32' x 22').
4) OK, not totally unusual so then use the "center target" which is plate solve based which always worked in the
past. This moves the target somewhere ~ 10 arc min to the left of center and happily reports centering success.

Let me further explain, I have attempted this two ways.
1) No APCC/APPM run, just the steps above.
2) Use the APCC/APPM flow as I read it, I did setup horizon limit before starting.
a) power up, connect to APCC, park the mount at park 3, which always works!
b) try the homing under the AE tab
c) Run APPM to generate a sky model. So far have tried the small and medium models. All points plate solve
successfully.

After the model run, I make sure both items below are selected:
Enable Pointing Correction
Enable Tracking Correction

When I try with either method 1 or 2 with or without model, the slow to object still has a large offset.

One thing I am wondering is, how does the mount ever get synchronized to the sky? The plate solve and sync in
SGP does not appear to be working. Does the model making process automatically sync the mount to the sky?

Can you also let me know where are the APPC logs stored?

thanks,
Steve


Steve Armen
 

Hi Brian,

Thanks for responding the for the suggestions. I have not used user profiles in the past, so that may be the SGP issue. I will set one up. I do have the coordinates stored in the AP v2 ASCOM driver, using ASCOM platform 6.4 SP1 6.4.1.2695.

-Steve


Steve Armen
 

Thank you for responding Marcelo.

Yes, your flow sounds very similar to what I have tried with APCC with the Mach2. I have not used it in the past. In addition, I want to use CdC for planetarium ultimately to drive the mount around, that would be fantastic if I can get it to work!

I have used Frame & Mosaic Wizard in the past. It works very well as a planning tool. Let me ask, do you have a user profile setup for SGP. I never took that step or  read that was necessary for pointing to work. It just always worked for me in the past. Maybe with a more recent release of SGP, that changed? 

I will look at the weather information site to use with APPM.

-Steve


Steve Armen
 

Hi Ray,

Thanks or responding. I am using ASCOM 6.4 SP1-6.4.1.2695. There were a couple suggestions already given that may help with SGP. I don't have a local environmental monitor. How important is that for accurate modeling. In addition, sometimes I do not have a web connection where I image at. Primarily I am mobile, no observatory. 

-Steve


eckhard.voelcker@...
 

Hi Steve,

I am using a similar workflow with the Mach2:

1) Power On, Start APCC, Start Sharpcap, Start SGP. Connect equipment (Sharpcap to the main camera, SGP without the camera)
2) Polar Align with Sharpcap, close Sharpcap, connect camera in SGP
3) Start PEMPro, connect to mount and to SGP. Slew to point in sky for azimuth measurement. Measure azimuth drift, correct and repeat. Slew to point in the sky for altitude measurement. Measure altitude, correct and repeat. Quit PEMPro.
4) Slew to traget in SGP. Platesolve (Pinpoint, licensed version).
5) Start APMM. APMM shows me where the telescope is pointing at so it is easy to set points along the path of my target moving West. I use a corridor of 3 points with the targets path more or less in the middle. APMM builds this model in approximately 10 minutes.
6) Enable the model, center target in SGP.
7) Adjust focus and start imaging.

Some comments:

Platesolving close to the pole is unreliable. Better move somewhere else first and then plate solve. Afterwards entering with SGP is dead on!
Since I switched to the Mach2 I don't guide anymore.
My polar alignment improves considerably when I run PEMPro after Sharpcap!
Building a model is surprisingly easy and fun.

I have had zero problems with the Mach2 using this workflow. 

Eckhard


Steve Armen
 

Hi again Marcelo,

Let me ask you and Ray, is it required to have current weather conditions always while running APPM for tracking corrections of the AE to function well on the mach2? If so, that is a current problem for me as I do not always have web connection where I image, nor a weather monitoring device. I suppose I could pick something up for weather monitoring if anybody has a suggestion.

thanks,
-Steve


Marcelo Figueroa
 

I am far from being an expert, but I believe that since you are a mobile user, you necessarily have to build a new model every time you setup your equipment. So probably the updated weather information is not that important, unless you want to do very long exposures (10 minutes or more I think). In that case you can continue to use guiding with this technique of Roland: Nudge Guiding
 
In my case my installation is permanent in my backyard, I use the same model every night, so updated weather information is vital.
 


Ray Gralak
 

Steve,

Thanks for responding the for the suggestions. I have not used user profiles in the past, so that may be the SGP
issue. I will set one up. I do have the coordinates stored in the AP v2 ASCOM driver, using ASCOM platform 6.4
SP1 6.4.1.2695.
Okay, that's good. What kind of telescope are you using?

One thing I am wondering is, how does the mount ever get synchronized to the sky?
Using APPM is the most accurate way to synchronize the mount to the sky. As part of capturing sky data, APPM will synchronize the mount to the sky (a "RECAL").

Later, after a model is in use, the mount can be recalibrated using an ASCOM sync, but that assumes the calling program has accurately converted a plate solve's J2000 coordinates into the current epoch, and is accounting for refraction. Alternatively, using APPM's run tab is likely more accurate. APPM's "Run" tab, there are buttons that allow you to plate solve and/or RECAL the mount. The use of plate solving in APPM assumes it has been set up in APPM.

Can you also let me know where are the APPC logs stored?
You can use the APCC Log Zipper to find logs and to create a zipped file of the appropriate logs. You can run the Log Zipper utility from APCC's Tools menu.

Providing a dropbox link to the zipped set of the logs might be helpful. Please remember to indicate the calendar date and time, so we will know where to start looking in the log files.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Steve Armen
Sent: Monday, October 19, 2020 8:39 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] Mach2 model building and pointing with Sequence Generator Pro

This is meant for Ray Gralak. With the new mach2 being controlled by SGP version 3.2.0.613 and APCC/APPM
latest version I have had two opportunities to test.

It may well be I am doing something incorrectly in the process. Let me preface this with my old mach1 could use
SGP plate solve and sync, then pointing with coordinates with very accurate pointing results. I have carefully
checked any parameters set for the OTA and camera. Since plate solves are passing, I'm assuming the required
parameters are correct.

With the new mach2, here is the process I've been following:
1) Starting up, doing what I consider a good polar alignment with Sharpcap (3.2), then connecting with SGP.
2) Do a solve and sync with ASTAP (also tried platesolve2 with no difference in results) which is successful.
3) Try to slew to a target, e.g. Vega. The slew ends up with the target somewhere off in a corner or not even in the
field of view (~32' x 22').
4) OK, not totally unusual so then use the "center target" which is plate solve based which always worked in the
past. This moves the target somewhere ~ 10 arc min to the left of center and happily reports centering success.

Let me further explain, I have attempted this two ways.
1) No APCC/APPM run, just the steps above.
2) Use the APCC/APPM flow as I read it, I did setup horizon limit before starting.
a) power up, connect to APCC, park the mount at park 3, which always works!
b) try the homing under the AE tab
c) Run APPM to generate a sky model. So far have tried the small and medium models. All points plate solve
successfully.

After the model run, I make sure both items below are selected:
Enable Pointing Correction
Enable Tracking Correction

When I try with either method 1 or 2 with or without model, the slow to object still has a large offset.

One thing I am wondering is, how does the mount ever get synchronized to the sky? The plate solve and sync in
SGP does not appear to be working. Does the model making process automatically sync the mount to the sky?

Can you also let me know where are the APPC logs stored?

thanks,
Steve


Ray Gralak
 

Steve,

Let me ask you and Ray, is it required to have current weather conditions always while running APPM for tracking
corrections of the AE to function well on the mach2? If so, that is a current problem for me as I do not always
have web connection where I image, nor a weather monitoring device. I suppose I could pick something up for
weather monitoring if anybody has a suggestion.
For the most accurate tracking rate correction, precise temperature, pressure, and humidity values should be supplied to the mount.

The most important value is the temperature, followed by the pressure value. Humidity has less of an effect.

If you don't have a weather input device, such as a THUM or MGBox V2, then you can manually enter the values on APCC's Pointing model tab. If you have an internet connection and there is an OpenWeather device near to you, you can use the ASCOM OpenWeather ObservingConditions driver to get temperature, pressure, and humidity from the OpenWeather device.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Steve Armen
Sent: Monday, October 19, 2020 10:52 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Mach2 model building and pointing with Sequence Generator Pro

Hi again Marcelo,

Let me ask you and Ray, is it required to have current weather conditions always while running APPM for tracking
corrections of the AE to function well on the mach2? If so, that is a current problem for me as I do not always
have web connection where I image, nor a weather monitoring device. I suppose I could pick something up for
weather monitoring if anybody has a suggestion.

thanks,
-Steve


Steve Armen
 

Ray, 

Can APCC receive temp & humidity readings from Pegasus power/usb box? Wondering what devices can feed APCC environmental readings. Mbox, THUM, others?

thanks,
-Steve


CurtisC <calypte@...>
 

On Tue, Oct 20, 2020 at 07:42 AM, Ray Gralak wrote:
If you don't have a weather input device, such as a THUM or MGBox V2
Who sells Thum?  I can't find it on the web.  I, in fact, have a weather station that provides data (ultimately) to the NWS.  It vexes me that I can't use that data for the model.


Steve Armen
 

Sorry this thread is getting long. I use an AG optical idk10. 1.7m focal length, .25m aperture. Using ASI1600 camera at this point in time.

-Steve


Steve Armen
 


Konstantin von Poschinger
 

Hi,

if you have a Mach-2 have a look at Pegasus:


with this you have also a good part for connecting lots of stuff with only connected USB3 and Power at the mount.

Konstantin


Konstantin v. Poschinger

Hammerichstr. 5
22605 Hamburg
040/8805747
0171 1983476

Am 20.10.2020 um 21:48 schrieb CurtisC via groups.io <calypte@...>:

On Tue, Oct 20, 2020 at 07:42 AM, Ray Gralak wrote:
If you don't have a weather input device, such as a THUM or MGBox V2
Who sells Thum?  I can't find it on the web.  I, in fact, have a weather station that provides data (ultimately) to the NWS.  It vexes me that I can't use that data for the model.


Worsel
 


Ray Gralak
 

Steve,

Can APCC receive temp & humidity readings from Pegasus power/usb box? Wondering what devices can feed
APCC environmental readings. Mbox, THUM, others?
As mentioned in the APCC help file, the THUM is supported, and devices that have an ASCOM ObservingConditions driver are supported. If the Pegasus has an ObservingConditions ASCOM driver, then it is supported by APCC.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Steve Armen
Sent: Tuesday, October 20, 2020 11:59 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Mach2 model building and pointing with Sequence Generator Pro

Ray,

Can APCC receive temp & humidity readings from Pegasus power/usb box? Wondering what devices can feed
APCC environmental readings. Mbox, THUM, others?

thanks,
-Steve


Eric Claeys