PHD2 Dec tracking goes runaway after Meridian Flip with Mach1


John Davis
 

I'm sure this is a configuration problem, but I have not been able to find a clear answer searching the web, so I thought I'd post here to get input from the AP experts.

I have a new-to-me Mach1 that I have had out now for 4 sessions totalling about 20 hours of imaging.  I have been working the Bubble nebula, so I start out early in the evening when it is east of the meridian, and then later it crosses to west of the meridian.

The mount guides great from starting time until it is time for meridian flip.  After the meridian flip, it guides fine for anywhere from a few seconds to a minute - until there is the first commanded correction in Dec.  Then the Dec corrections continue and get larger - driving the scope off of the guide star until PHD2 loses it.  See attached screen shot from the PHD2 log viewer (post_meridian_flip_guiding_1.png

In PHD2 I have the box checked that says "Reverse Dec output after Meridian flip"  - because I thought I read on posts here (and in the doc maybe) that it needed to be set.  But even after un-checking that box, it continues to misbehave.

I have stopped PHD2 and re-calibrated -  using a star on the same side of the meridian and near the C-equator with mixed results.  On Saturday night, I parked the scope, turned off the mount, turned it back on, then re-calibrated PHD2  on a star west of the meridian and slewed back to the Bubble nebula west of the meridian.  Then PHD2 and the mount tracked fine.  Re-initializing the mount may not be necessary - I was not as much in troubleshooting mode as I was in "get back to imaging" mode - so I didn't do a very controlled experiment.

I don't know if it is pertinent or not, but I have the AP ASCOM driver set to allow the scope to go 60 minutes (-1 hours in the field of the driver dialog) past the meridian, and I have SGP configured to delay issuing the slew causing the flip until 60 minutes after crossing the meridian.   There is plenty of clearance with the scope and tripod/mount for that, so I was delaying the flip because I have been fighting getting it to work.

I've added the PHD2 log file as well - but I have posted the same question to the PHD2 discussion group.
I wanted to make sure there was not any AP specific configuration that I was missing.

Any help would be greatly appreciated.  Thanks!
John D.


Roland Christen
 

The PHD group would be the best at figuring out why your guide software does not reverse the guiding parameters after a meridian flip.

The mount itself cannot automatically change the way it interprets the guide command. That has to come from the guide software 9in this case PHD2).

Rolando



-----Original Message-----
From: John Davis <johncdavis200@...>
To: main@ap-gto.groups.io
Sent: Mon, Oct 19, 2020 6:12 pm
Subject: [ap-gto] PHD2 Dec tracking goes runaway after Meridian Flip with Mach1

I'm sure this is a configuration problem, but I have not been able to find a clear answer searching the web, so I thought I'd post here to get input from the AP experts.

I have a new-to-me Mach1 that I have had out now for 4 sessions totalling about 20 hours of imaging.  I have been working the Bubble nebula, so I start out early in the evening when it is east of the meridian, and then later it crosses to west of the meridian.

The mount guides great from starting time until it is time for meridian flip.  After the meridian flip, it guides fine for anywhere from a few seconds to a minute - until there is the first commanded correction in Dec.  Then the Dec corrections continue and get larger - driving the scope off of the guide star until PHD2 loses it.  See attached screen shot from the PHD2 log viewer (post_meridian_flip_guiding_1.png

In PHD2 I have the box checked that says "Reverse Dec output after Meridian flip"  - because I thought I read on posts here (and in the doc maybe) that it needed to be set.  But even after un-checking that box, it continues to misbehave.

I have stopped PHD2 and re-calibrated -  using a star on the same side of the meridian and near the C-equator with mixed results.  On Saturday night, I parked the scope, turned off the mount, turned it back on, then re-calibrated PHD2  on a star west of the meridian and slewed back to the Bubble nebula west of the meridian.  Then PHD2 and the mount tracked fine.  Re-initializing the mount may not be necessary - I was not as much in troubleshooting mode as I was in "get back to imaging" mode - so I didn't do a very controlled experiment.

I don't know if it is pertinent or not, but I have the AP ASCOM driver set to allow the scope to go 60 minutes (-1 hours in the field of the driver dialog) past the meridian, and I have SGP configured to delay issuing the slew causing the flip until 60 minutes after crossing the meridian.   There is plenty of clearance with the scope and tripod/mount for that, so I was delaying the flip because I have been fighting getting it to work.

I've added the PHD2 log file as well - but I have posted the same question to the PHD2 discussion group.
I wanted to make sure there was not any AP specific configuration that I was missing.

Any help would be greatly appreciated.  Thanks!
John D.


CurtisC <calypte@...>
 

On Mon, Oct 19, 2020 at 06:12 PM, John Davis wrote:
The mount guides great from starting time until it is time for meridian flip.  After the meridian flip, it guides fine for anywhere from a few seconds to a minute - until there is the first commanded correction in Dec.  Then the Dec corrections continue and get larger - driving the scope off of the guide star until PHD2 loses it.  See attached screen shot from the PHD2 log viewer (post_meridian_flip_guiding_1.png
What a coincidence!  I don't use PHD2.  I use MaxImDL.  But I had a recent experience of something very similar.  East of the meridian, everything was fine.  After the flip, it'd guide fabulously for several cycles, and then suddenly the guiding looked like the guider was chasing a squirrel.  I don't have an explanation.  But two nights ago it happened, and all I did was put my Mach1 into Park 3, and I remeshed the worm.  I had no reason to think the existing mesh was bad, but there wasn't much else I could think to do.  The problem disappeared, and guiding on the west side was as good as on the east side.


Roland Christen
 

That is definitely a wrong approach. If the mount runs away in Dec it's because the guide pulses are in the wrong direction and need to be reversed. It's fundamental Of course it will guide ok for a few seconds or even longer as long as no pulses are sent to Dec, but as soon as Dec receives any correction pulses, it will send the mount in the wrong direction and every pulse after that just adds to the error until it goes completely off the guide window. This is fundamental, guys!

Rolando



-----Original Message-----
From: CurtisC via groups.io <calypte@...>
To: main@ap-gto.groups.io
Sent: Mon, Oct 19, 2020 7:16 pm
Subject: Re: [ap-gto] PHD2 Dec tracking goes runaway after Meridian Flip with Mach1

On Mon, Oct 19, 2020 at 06:12 PM, John Davis wrote:
The mount guides great from starting time until it is time for meridian flip.  After the meridian flip, it guides fine for anywhere from a few seconds to a minute - until there is the first commanded correction in Dec.  Then the Dec corrections continue and get larger - driving the scope off of the guide star until PHD2 loses it.  See attached screen shot from the PHD2 log viewer (post_meridian_flip_guiding_1.png
What a coincidence!  I don't use PHD2.  I use MaxImDL.  But I had a recent experience of something very similar.  East of the meridian, everything was fine.  After the flip, it'd guide fabulously for several cycles, and then suddenly the guiding looked like the guider was chasing a squirrel.  I don't have an explanation.  But two nights ago it happened, and all I did was put my Mach1 into Park 3, and I remeshed the worm.  I had no reason to think the existing mesh was bad, but there wasn't much else I could think to do.  The problem disappeared, and guiding on the west side was as good as on the east side.


 

>>> I had no reason to think the existing mesh was bad, but there wasn't much else I could think to do.  The problem disappeared, and guiding on the west side was as good as on the east side.

this is most likely coincidence. If you do a meridian flip and the guiding "goes off" just reverse that checkbox. 

John I see you already posted to PHD forums and I responded there as well

Brian


On Mon, Oct 19, 2020 at 6:31 PM uncarollo2 <chris1011@...> via groups.io <chris1011=aol.com@groups.io> wrote:
That is definitely a wrong approach. If the mount runs away in Dec it's because the guide pulses are in the wrong direction and need to be reversed. It's fundamental Of course it will guide ok for a few seconds or even longer as long as no pulses are sent to Dec, but as soon as Dec receives any correction pulses, it will send the mount in the wrong direction and every pulse after that just adds to the error until it goes completely off the guide window. This is fundamental, guys!

Rolando



-----Original Message-----
From: CurtisC via groups.io <calypte=verizon.net@groups.io>
To: main@ap-gto.groups.io
Sent: Mon, Oct 19, 2020 7:16 pm
Subject: Re: [ap-gto] PHD2 Dec tracking goes runaway after Meridian Flip with Mach1

On Mon, Oct 19, 2020 at 06:12 PM, John Davis wrote:
The mount guides great from starting time until it is time for meridian flip.  After the meridian flip, it guides fine for anywhere from a few seconds to a minute - until there is the first commanded correction in Dec.  Then the Dec corrections continue and get larger - driving the scope off of the guide star until PHD2 loses it.  See attached screen shot from the PHD2 log viewer (post_meridian_flip_guiding_1.png
What a coincidence!  I don't use PHD2.  I use MaxImDL.  But I had a recent experience of something very similar.  East of the meridian, everything was fine.  After the flip, it'd guide fabulously for several cycles, and then suddenly the guiding looked like the guider was chasing a squirrel.  I don't have an explanation.  But two nights ago it happened, and all I did was put my Mach1 into Park 3, and I remeshed the worm.  I had no reason to think the existing mesh was bad, but there wasn't much else I could think to do.  The problem disappeared, and guiding on the west side was as good as on the east side.



--
Brian 



Brian Valente


John Davis
 

Thanks Roland - I can see what is happening - just don't understand why, since I did have the check to switch the Dec calibration after meridian flip... I guess I just wanted to make sure that is what the Mach1 is built to do.  I saw some info in PHD that said some mounts handle the reversal themselves.. 
As I said - I've posted to the PHD2 discussion board and will see what they say.

John


Renan <renanvdw@...>
 

What are you using for capturing images?

If SGP I can send you all the settings that I am using and it works.

Regards

Renan

 

From: John Davis
Sent: lunes, 19 de octubre de 2020 20:12
To: main@ap-gto.groups.io
Subject: [ap-gto] PHD2 Dec tracking goes runaway after Meridian Flip with Mach1

 

I'm sure this is a configuration problem, but I have not been able to find a clear answer searching the web, so I thought I'd post here to get input from the AP experts.

I have a new-to-me Mach1 that I have had out now for 4 sessions totalling about 20 hours of imaging.  I have been working the Bubble nebula, so I start out early in the evening when it is east of the meridian, and then later it crosses to west of the meridian.

The mount guides great from starting time until it is time for meridian flip.  After the meridian flip, it guides fine for anywhere from a few seconds to a minute - until there is the first commanded correction in Dec.  Then the Dec corrections continue and get larger - driving the scope off of the guide star until PHD2 loses it.  See attached screen shot from the PHD2 log viewer (post_meridian_flip_guiding_1.png

In PHD2 I have the box checked that says "Reverse Dec output after Meridian flip"  - because I thought I read on posts here (and in the doc maybe) that it needed to be set.  But even after un-checking that box, it continues to misbehave.

I have stopped PHD2 and re-calibrated -  using a star on the same side of the meridian and near the C-equator with mixed results.  On Saturday night, I parked the scope, turned off the mount, turned it back on, then re-calibrated PHD2  on a star west of the meridian and slewed back to the Bubble nebula west of the meridian.  Then PHD2 and the mount tracked fine.  Re-initializing the mount may not be necessary - I was not as much in troubleshooting mode as I was in "get back to imaging" mode - so I didn't do a very controlled experiment.

I don't know if it is pertinent or not, but I have the AP ASCOM driver set to allow the scope to go 60 minutes (-1 hours in the field of the driver dialog) past the meridian, and I have SGP configured to delay issuing the slew causing the flip until 60 minutes after crossing the meridian.   There is plenty of clearance with the scope and tripod/mount for that, so I was delaying the flip because I have been fighting getting it to work.

I've added the PHD2 log file as well - but I have posted the same question to the PHD2 discussion group.
I wanted to make sure there was not any AP specific configuration that I was missing.

Any help would be greatly appreciated.  Thanks!
John D.

 


John Davis
 

Hello Renan,
  Yes - I am using SGP with PHD2 - I would greatly appreciate the information.
Thanks,
John


John Davis
 

Roland - can you answer definitively:  does the "Reverse Dec output after meridian flip" need to be checked or not checked?

I ask that because over on the PHD2 board, I have a guy telling me " The ASCOM driver for A-P mounts knows the 'side of pier' for the mount; so there is no need to check the reverse Dec box n PHD2"

And I have Michael Fulbright - a good friend and long time Mach1 owner telling me "if you uncheck the reverse dec box it will certainly not work"... 

I'd put my money on Michael - but this is why I have come to the experts.

IF the box DOES need to be checked - are there any OTHER settings that I need in the AP ASCOM driver?

John


 

Hi John

i think the explanation is covered in the PHD documentation, which i've pasted below

Your mount reports side-of-pier, so PHD knows to flip the calibration when you do a meridian flip.

you would only check that box if your mount did not report side of pier. so you should leave it unchecked

here's the relevant part of the PHD documentation. if you still aren't sure there's a link to a tool in the url below to test your mount:


'Reverse Dec output after meridian flip' -  tells PHD2 how to adjust the calibration data after a meridian flip.  Some newer mounts track their 'side of pier' state and automatically reverse the direction of the declination motor.  Older mounts do not do this.  In either case, PHD2 needs to know if the mount will automatically change its behavior based on side-of-pier.  You may have difficulty finding information about how your mount behaves in this respect, so PHD2 provides the Meridian flip calibration tool to determine the correct setting


On Mon, Oct 19, 2020 at 6:36 PM John Davis <johncdavis200@...> wrote:
Thanks Roland - I can see what is happening - just don't understand why, since I did have the check to switch the Dec calibration after meridian flip... I guess I just wanted to make sure that is what the Mach1 is built to do.  I saw some info in PHD that said some mounts handle the reversal themselves.. 
As I said - I've posted to the PHD2 discussion board and will see what they say.

John



--
Brian 



Brian Valente


steve.winston@...
 

>IF the box DOES need to be checked - are there any OTHER settings that I need in the AP ASCOM driver?

I can second Brian's advice:  The "Reverse DEC output after meridian flip" option should NOT be checked.


CurtisC <calypte@...>
 

On Mon, Oct 19, 2020 at 08:31 PM, uncarollo2 <chris1011@...> wrote:
That is definitely a wrong approach. If the mount runs away in Dec it's because the guide pulses are in the wrong direction and need to be reversed. It's fundamental Of course it will guide ok for a few seconds or even longer as long as no pulses are sent to Dec, but as soon as Dec receives any correction pulses, it will send the mount in the wrong direction and every pulse after that just adds to the error until it goes completely off the guide window. This is fundamental, guys!
You are correct, of course.  What was I thinking?  


JSeay86
 

Third confirmation of Brian and Steve's advice, the "Reverse Dec output after meridian flip" should be UN-Checked. I imaged over the weekend with an automated meridian flip in SGP and had successful guiding on both sides of meridian before/after (mostly at least, darn wind). 


Roland Christen
 

I use MaximDL and I check the reverse on flip box. Maxim DL works thru the Ascom driver and thus knows when the mount is flipped to the other side. Therefore Maxim will actively change the guide commands accordingly. I don't know how PHD2 does things.

Rolando



-----Original Message-----
From: John Davis <johncdavis200@...>
To: main@ap-gto.groups.io
Sent: Mon, Oct 19, 2020 10:20 pm
Subject: Re: [ap-gto] PHD2 Dec tracking goes runaway after Meridian Flip with Mach1

Roland - can you answer definitively:  does the "Reverse Dec output after meridian flip" need to be checked or not checked?

I ask that because over on the PHD2 board, I have a guy telling me " The ASCOM driver for A-P mounts knows the 'side of pier' for the mount; so there is no need to check the reverse Dec box n PHD2"

And I have Michael Fulbright - a good friend and long time Mach1 owner telling me "if you uncheck the reverse dec box it will certainly not work"... 

I'd put my money on Michael - but this is why I have come to the experts.

IF the box DOES need to be checked - are there any OTHER settings that I need in the AP ASCOM driver?

John


John Davis
 

Guys - I'm very confused...

I have a good friend who has been a LONG time Mach1 owner - is incredibly knowldgable on all things (has written his OWN imaging software equivalent to SGP or NINA) - and according to him:

"I've always had the 'Reverse Dec output after meridian flip' enabled.  I think that is all there is to it.  You need the mount to report the pier side properly so PHD2 will know it needs to reverse DEC.  I neer had a problem with the Mach1 doing this.  I did use the meridian delay feature you are talking about some as well. 
If you uncheck the reverse dec box it will certainly not work. "

His advice to me on MANY, MANY issues has NEVER been wrong, so I am really struggling with you all saying he is wrong...

Seems like this should be a clear un-ambiguous answer... I guess from you guy's perspective it is :-)

I will experiment the next time out - try that testing software.




 

>> "I've always had the 'Reverse Dec output after meridian flip' enabled.  I think that is all there is to it. 

I don't think your friend is necessarily wrong - the first thing you need to do is uncheck it and see if that in fact does work.


There may be a number of other variables at play in a difference between yours and his - configuration settings in ASCOM, in PHD, version of PHD (1 or 2?), your firmware version, etc.



On Tue, Oct 20, 2020 at 8:25 AM John Davis <johncdavis200@...> wrote:
Guys - I'm very confused...

I have a good friend who has been a LONG time Mach1 owner - is incredibly knowldgable on all things (has written his OWN imaging software equivalent to SGP or NINA) - and according to him:

"I've always had the 'Reverse Dec output after meridian flip' enabled.  I think that is all there is to it.  You need the mount to report the pier side properly so PHD2 will know it needs to reverse DEC.  I neer had a problem with the Mach1 doing this.  I did use the meridian delay feature you are talking about some as well. 
If you uncheck the reverse dec box it will certainly not work. "

His advice to me on MANY, MANY issues has NEVER been wrong, so I am really struggling with you all saying he is wrong...

Seems like this should be a clear un-ambiguous answer... I guess from you guy's perspective it is :-)

I will experiment the next time out - try that testing software.





--
Brian 



Brian Valente


John Davis
 

Well... doing a bit more searching on the board, I have found several posts here that do indicate the "Reverse Dec" box should NOT be checked - including 

https://github.com/OpenPHDGuiding/phd2/wiki/Reverse-Dec-output-after-meridian-flip
info on the PHD2 site.

So now you have convinced me - so - can somebody tell me what the configuration settings SHOULD be for the AP ASCOM V2 driver and PHD2 in order for this to work?  
I can experiment - but I'd sure rather image than experiment :-)

My versions:
ASCOM              6.4.0.2618
AP ASCOM V2   5.30.10
PHD2                  2.6.9
SGP                    3.1.0.558

thanks for your patience!
John


 

>>> can somebody tell me what the configuration settings SHOULD be for the AP ASCOM V2 driver and PHD2 in order for this to work?  

Disable "reverse Dec output after meridian flip" in PHD. that's what it *should* be

You might be making this more difficult than it is ;)




On Tue, Oct 20, 2020 at 9:02 AM John Davis <johncdavis200@...> wrote:
Well... doing a bit more searching on the board, I have found several posts here that do indicate the "Reverse Dec" box should NOT be checked - including 

https://github.com/OpenPHDGuiding/phd2/wiki/Reverse-Dec-output-after-meridian-flip
info on the PHD2 site.

So now you have convinced me - so - can somebody tell me what the configuration settings SHOULD be for the AP ASCOM V2 driver and PHD2 in order for this to work?  
I can experiment - but I'd sure rather image than experiment :-)

My versions:
ASCOM              6.4.0.2618
AP ASCOM V2   5.30.10
PHD2                  2.6.9
SGP                    3.1.0.558

thanks for your patience!
John



--
Brian 



Brian Valente


Roland Christen
 

The ASCOM driver doesn't have a setting for reversing the Dec on pier flip. I don't think that is part of the ASCOM platform.

Rolando

-----Original Message-----
From: John Davis <johncdavis200@...>
To: main@ap-gto.groups.io
Sent: Tue, Oct 20, 2020 11:02 am
Subject: Re: [ap-gto] PHD2 Dec tracking goes runaway after Meridian Flip with Mach1

Well... doing a bit more searching on the board, I have found several posts here that do indicate the "Reverse Dec" box should NOT be checked - including 

https://github.com/OpenPHDGuiding/phd2/wiki/Reverse-Dec-output-after-meridian-flip
info on the PHD2 site.

So now you have convinced me - so - can somebody tell me what the configuration settings SHOULD be for the AP ASCOM V2 driver and PHD2 in order for this to work?  
I can experiment - but I'd sure rather image than experiment :-)

My versions:
ASCOM              6.4.0.2618
AP ASCOM V2   5.30.10
PHD2                  2.6.9
SGP                    3.1.0.558

thanks for your patience!
John


John Davis
 
Edited

That is quite possible... (making it harder than it needs to be)

After I hit the problem the first time - I went and unchecked the "Reverse Dec" box... and restarted guiding - but it ran away again.

But that was AFTER the Meridian flip, so I suppose that's closing the door after the cow has left the barn... flip had occurred, PHD2 had reveresed Dec calibration, and unchecking that box would only help the NEXT time...

I will be quite now until I can test this out next clear night (which doesn't look like this week)...

Thanks again!