Topics

A bunch of APCC woes...


Tom Blahovici
 

First: After a successful evening of imaging where I initially do a manual sync with the keypad on a star, I send the mount to Park 3. I then power everything down.
Next night, I open the sky, slew to Deneb for example and attempt to plate solve the location using Image link in TheSky.  Always fails.  The only way I can get things working is if I first manually position the scope with a finder, after telling it to go to a star and then doing a recal.  When I had the advanced option in APCC to reject recals that were off selected I would just get errors.
Second:  And this is probably where this issue come from: If I look at the site data in APCC, and select Manage sites, I set the time to Eastern time -5.  However, the program then sets it to -4 when I press save.  On that same screen "Mount Location" Ihe time offset is displayed as -3.  What???
Isn't the mount supposed to get things from the PC?  If APCC cannot do this right, the PC can.

Second: I have created two virtual ports, com5 and com6.  Using the Ascom driver in the sky for the mount, it connects correctly using com6.  I then try to connect another program, FocusMax to com6 using the AP driver and it fails.  It attempts to connect to com6 again even though it was told com5. What am I doing wrong?  Do I need to load another instance of the ASCOM driver, if that can be done?
I hope not to waste another evening of clear skys.
Tom


Tom Blahovici
 

Let's add a couple of more issues...after rebooting, the virtual ports I was using disappeared.  They were replaced with two others.  These two do not show up in the Windows device manager, nor do they show up in the ASCOM settings.

Tom


Ray Gralak
 

Tom,

 

Here's where you went wrong:

 

> First: After a successful evening of imaging where I initially

> do a manual sync with the keypad on a star

 

If APCC does not initialize the control box then the settings will not be set because they have been already set by the keypad.

 

I suggest:

 

1) You try parking the mount to park 3 with the keypad.

2) Disconnect the keypad for now.

3) In APPC enable the following checkboxes:

            Mount - Auto-Connect

            Mount – Create Virtual Ports first

            AP V2 Driver – Auto-Config

 

See screen shot:

 

 

4) Close APCC

5) Power cycle the mount. Make sure the keypad is not connected.

6) Start APCC and let it initialize the mount. Make sure it initializes the mount from Last Parked position, which it should by default.

 

> I hope not to waste another evening of clear skys.

 

Hint: It is best to try setting up new software and/or hardware well in advance in the daytime so that you will have enough time to setup and test things.

 

-Ray Gralak

Author of PEMPro

Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro

Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

 

 

> -----Original Message-----

> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Tom Blahovici

> Sent: Sunday, September 20, 2020 6:02 PM

> To: main@ap-gto.groups.io

> Subject: [ap-gto] A bunch of APCC woes...

>

> First: After a successful evening of imaging where I initially do a manual sync with the keypad on a star, I send

> the mount to Park 3. I then power everything down.

> Next night, I open the sky, slew to Deneb for example and attempt to plate solve the location using Image link in

> TheSky.  Always fails.  The only way I can get things working is if I first manually position the scope with a finder,

> after telling it to go to a star and then doing a recal.  When I had the advanced option in APCC to reject recals that

> were off selected I would just get errors.

> Second:  And this is probably where this issue come from: If I look at the site data in APCC, and select Manage

> sites, I set the time to Eastern time -5.  However, the program then sets it to -4 when I press save.  On that same

> screen "Mount Location" Ihe time offset is displayed as -3.  What???

> Isn't the mount supposed to get things from the PC?  If APCC cannot do this right, the PC can.

>

> Second: I have created two virtual ports, com5 and com6.  Using the Ascom driver in the sky for the mount, it

> connects correctly using com6.  I then try to connect another program, FocusMax to com6 using the AP driver

> and it fails.  It attempts to connect to com6 again even though it was told com5. What am I doing wrong?  Do I

> need to load another instance of the ASCOM driver, if that can be done?

> I hope not to waste another evening of clear skys.

> Tom


Ray Gralak
 

Tom,

Let's add a couple of more issues...after rebooting, the virtual ports I was using disappeared. They were replaced
with two others. These two do not show up in the Windows device manager, nor do they show up in the ASCOM
settings.
Tom, you are overthinking this. You don't have to worry about setting up the AP V2 ASCOM driver. APCC will auto-configure the AP V2 ASCOM driver if you set the options I suggested in my last post.

And BTW, the virtual ports do not stick around through a computer reboot. They are created when you run APCC.

Lastly, please take a look at the help file! Here's a link to the online version of one of the first pages you should read:

https://www.siriusimaging.com/Help/APCC/getting_started_workflow.htm

Thanks,

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Tom Blahovici
Sent: Sunday, September 20, 2020 6:11 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] A bunch of APCC woes...

Let's add a couple of more issues...after rebooting, the virtual ports I was using disappeared. They were replaced
with two others. These two do not show up in the Windows device manager, nor do they show up in the ASCOM
settings.

Tom


Tom Blahovici
 

Well, the keypad had the time set to -4.  This obviously contributed to the issues of pointing which are now resolved.  However, the issues with the virtual ports are still there.
I deleted all the ports.  Then created com16 and com17.  The original ones com5 and com6 do not show up in the device manager or in the ascom drivers.  However, I still had one device that had the driver set to com5. This one still works! Even though you cannot see it anywhere.
So my remaining question is still, can you have multiple use of the ascom driver for multiple applications each of which is configured for a different comport?  Doesn't seem to work but could be related to the still two remaining phantom ports.  And yes, I showed hidden devices and deleted them and rebooted.


Ray Gralak
 

Tom,

So my remaining question is still, can you have multiple use of the
ascom driver for multiple applications each of
Again, I think you are over complicating things. The AP V2 ASCOM driver supports multiple simultaneous applications from one instance. You do not need a separate COM port for each ASCOM client connection. One port will do.

The reason APCC tries to allocate two virtual COM ports is that a second instance of the driver will be invoked if an ASCOM client is run "as administrator". But, you don't need to worry about that.

-Ray Gralak
Author of PEMPro
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Tom Blahovici
Sent: Sunday, September 20, 2020 9:06 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] A bunch of APCC woes...

Well, the keypad had the time set to -4. This obviously contributed to the issues of pointing which are now resolved.
However, the issues with the virtual ports are still there.
I deleted all the ports. Then created com16 and com17. The original ones com5 and com6 do not show up in the
device manager or in the ascom drivers. However, I still had one device that had the driver set to com5. This one
still works! Even though you cannot see it anywhere.
So my remaining question is still, can you have multiple use of the ascom driver for multiple applications each of
which is configured for a different comport? Doesn't seem to work but could be related to the still two remaining
phantom ports. And yes, I showed hidden devices and deleted them and rebooted.


Tom Blahovici
 

Hi
I guess, I don't quite get it...when you are in an application and you choose the Ascom mount driver, there are the settings which you use to select a comport. Do you not need to attach every application to a different port?
I know that I was unable to connect both the sky and focus max at the same time unless I chose different ports. Same thing with phd2. Unless something else was wrong?.
Tom


Luca Marinelli
 

Tom,

The COM port should be completely transparent to all those applications. All you need to tell them is to talk to the  AP ASCOM driver. APCC has created a virtual COM port for the driver and manages the communications with the mount. 

--Luca


David Fabrizio
 

Configure your virtual ports starting at a higher com port like 20, 21, etc. That way you won’t have a com port conflict with the mouse, etc.


On Sep 21, 2020, at 3:20 PM, Luca Marinelli <photo@...> wrote:

Tom,

The COM port should be completely transparent to all those applications. All you need to tell them is to talk to the  AP ASCOM driver. APCC has created a virtual COM port for the driver and manages the communications with the mount. 

--Luca