Issue with starting ASCOM driver from SGP #ASCOM_V2_Driver


DiscoDuck
 

This may well be an SGP issue, but let me ask here just in case anyone has seen this ... or hopefully Ray might have some insight.

I have an issue where
- I start APCC and connect it to the mount and initialise the mount
- I start SGP
- I click on connect to mount in SGP

Normally, this fires up the AP ASCOM driver, which connects to APCC (virtual com port) and all is good. However, it now brings up the ASCOM driver with "default values" and you can see it flashing while trying to connect to APCC and then eventually fails and the ASCOM driver disappears and I get an error message from SGP that the mount failed to connect. It has previously worked fine [though I have had this issue before and it went away when I reinstalled the ASCOM driver. Could do that again now, but thought since it has resurfaced it is worth asking]

The issue is repeatable i.e. it happens every time I try to connect from SGP.

Current workaround is to connect to the ASCOM driver from APCC. Then when I click connect from SGP it simply connects to the (already running and initialised) ASCOM driver and all is good.

Ideas/comments appreciated.
Thanks,
Paul


Worsel
 

Paul

When I start up APCC the driver ALWAYS starts automatically...I think the driver MUST start to connect to the mount.  I never have to start the driver on its own. I am unsure why this does not seem to happen for your config.  Ray Gralak likely has more insight.

Bryan


DiscoDuck
 

Thanks. My understanding is that APCC talks directly to the mount, and the ASCOM driver sits above APCC and the apps (SGP) talk to that. I haven't got APCC configured to auto-start the driver (I think you can). But it is odd that starting it from SGP used to work and now doesn't. Thanks for your comments though.


Ray Gralak
 

Hi Paul,

The issue is repeatable i.e. it happens every time I try to connect from SGP.
1. Make sure that you are not starting APCC "as Administrator". You do not need to run APCC with admin privileges.
2. Make sure that you are not starting SGP "as administrator". That will start a second instance of the driver when SGP connects to the AP V2 driver.
3. Enable the "Auto-Config" option in the "AP V2 Driver" group box in APCC. This will always reconfigure the AP V2 driver even if APCC's virtual com ports change.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of DiscoDuck
Sent: Thursday, July 16, 2020 9:10 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] Issue with starting ASCOM driver from SGP #ASCOM_V2_Driver

This may well be an SGP issue, but let me ask here just in case anyone has seen this ... or hopefully Ray might
have some insight.

I have an issue where
- I start APCC and connect it to the mount and initialise the mount
- I start SGP
- I click on connect to mount in SGP

Normally, this fires up the AP ASCOM driver, which connects to APCC (virtual com port) and all is good. However,
it now brings up the ASCOM driver with "default values" and you can see it flashing while trying to connect to
APCC and then eventually fails and the ASCOM driver disappears and I get an error message from SGP that the
mount failed to connect. It has previously worked fine [though I have had this issue before and it went away when
I reinstalled the ASCOM driver. Could do that again now, but thought since it has resurfaced it is worth asking]

The issue is repeatable i.e. it happens every time I try to connect from SGP.

Current workaround is to connect to the ASCOM driver from APCC. Then when I click connect from SGP it simply
connects to the (already running and initialised) ASCOM driver and all is good.

Ideas/comments appreciated.
Thanks,
Paul


DiscoDuck
 

Sorry not to reply early. Been cloudy and not used the mount!

Neither APCC nor SGP were run as admin, and Auto-Config was already checked.

Same behaviour. It will not start the driver when connecting from SGP nor from any other client (e.g. StellariumScope).

But the driver starts fine if connected first from APCC.

Note: clicking on Now for Auto-Config in APCC claims to successfully update the driver config, and yet the problem persists after that


Worsel
 

Paul

How do you connect to the mount...wireless, wired, RS232?   I wonder if the IP address has inadvertently changed?

Bryan


DiscoDuck
 

Ethernet cable. There is no problem connecting APCC to the mount. It's when the ASCOM driver is started by a client it seems unable to connect to APCC's virtual COM port.
(however if APCC itself starts the driver all is good).


 

>>> (however if APCC itself starts the driver all is good).

I always start ASCOM driver from APCC fwiw

On Sat, Jul 25, 2020 at 9:52 PM DiscoDuck <montagoo@...> wrote:
Ethernet cable. There is no problem connecting APCC to the mount. It's when the ASCOM driver is started by a client it seems unable to connect to APCC's virtual COM port.
(however if APCC itself starts the driver all is good).



--
Brian 



Brian Valente


DiscoDuck
 
Edited

Thanks Brian. I am concerned though that it used to work and now does not.

The error log starts
000001 # AP ASCOM Driver - 5.20.09
000002 # Controller: GTOCP4
000003 # Mount Type: 
000004 # O/S: Windows 7
000005 # Admin: False
000006 2020-07-25 18:03:57.257:             Load: Info      : OnTop=-1,RestorePosition=0,Left = 0, Top = 0
000007 2020-07-25 18:03:57.278:       Initialize: Info      : SafeSlewRaDec = 1
000008 2020-07-25 18:03:57.288:            ASCOM: Info      : GET InterfaceVersion = 2
000009 2020-07-25 18:03:57.298:            ASCOM: Info      : SET Connected = True
000010 2020-07-25 18:03:57.362:           Serial: Info      : Setting serial receive timeout (mSecs): 1000
000011 2020-07-25 18:03:57.362:           Serial: Info      : AP Serial - Port = 21, Speed = 9600, Timeout = 1000ms
000012 2020-07-25 18:03:57.364:           Serial: Error     : Failed to connect: Error = -3
000013 2020-07-25 18:03:57.364:     ClearBuffers: Info      : Removed 0 bytes in 0 Ticks
000014 2020-07-25 18:03:57.364:        Telescope: Info      : CommandString TX=':V#'
000015 2020-07-25 18:03:57.364:        Telescope: Warning   : Retransmits: 1
000016 2020-07-25 18:03:57.364:        Telescope: Error     : CommandString: NO Response or bad response: ':V#', Response='' -> Giving up!
000017 2020-07-25 18:03:57.364:        Telescope: Error     : RECEIVE TERMINATED ERRORS: 1
000018 2020-07-25 18:03:57.364:           Driver: Info      : CommandClear()
000019 2020-07-25 18:03:57.385:     ClearBuffers: Info      : Removed 0 bytes in 0 Ticks

And then it continues to try the same port until it gives up.
It doesn't seem to get any response. But if the timestamps are to be believed it doesn't seem to wait long enough for it to be a timeout.


DiscoDuck
 

Nudge


Ray Gralak
 

It might help if you posted a screen shot of APCC showing your connect settings.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of DiscoDuck
Sent: Monday, July 27, 2020 4:41 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Issue with starting ASCOM driver from SGP #ASCOM_V2_Driver

Nudge


DiscoDuck
 

Hi Ray, 
Here's the settings (attached).
Thanks,
Paul


DiscoDuck
 

If any use, here's the virtual com ports too ...


Ray Gralak
 

Try enabling "Create Virtual Ports First".

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of DiscoDuck
Sent: Tuesday, July 28, 2020 3:11 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Issue with starting ASCOM driver from SGP #ASCOM_V2_Driver

Hi Ray,
Here's the settings (attached).
Thanks,
Paul


DiscoDuck
 

Sorry not to reply earlier but it was a while between setups (winter here in Australia!). That works fine now. Thanks for the advice.