GTO CP3 connection problem via COM port in Windows 10


Henry Kwok
 

Hi Ray (or anyone else who can help):

Since I have upgraded to Windows 10 (from Windows 7) I have a problem connecting to the mount via COM port using ASCOM.
Basically the first attempt at connecting to the mount after a fresh boot up of the machine will always fail.
However, if I try again the second time it will work.

For example, I normally start APJog, then click connect. It will launch the mount ASCOM driver window, but it will fail to detect the mount.
To solve the problem I will have to click connect again (which does nothing), then click disconnect (so to close the mount driver window), then click connect again and then everything will work fine from there.

I have also tried to connect to the mount from Voyager - and I see the same problem (i.e. first attempt at connecting to the mount after a fresh boot will fail).

This is a fatal issue, but more a nuisance.

I have noticed this problem since upgrading to Windows 10. Windows device manager does not report any error.

BTW, Voyager always run in administrator mode. I have set APJog to run as administrator as well, because if I don't and try to run Voyager after APJog the mount will not connect.

Is there some setting I am missing?

Thanks


Ray Gralak
 

Hi Henry,

Before connecting the driver open Windows Device Manager and find the COM port(s) that are present on your system. Then open the AP V2 Driver ASCOM Setup. The driver does not automatically discover which port the mount is using so you must select the proper COM port. Select each port and click "Check Port" until you locate the port. Then close the window. The driver should now connect

Also, do not run Voyager or any other ASCOM client as administrator. It should not be required to run any ASCOM client applications as administrator as that may cause a second instance of the driver to start if you also have another application connected.

If you still have problems with take notice of the COM port the driver is trying to connect with to make sure it matches the COM port the mount is connected to. If you are using a USB/serial converter sometimes they try to allocate a new COM port every time they run or after booting. If you have one that does that then try updating its device driver. If that doesn't help try a different USB/serial converter, or if you have a desktop get a serial port add in card.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Henry Kwok
Sent: Saturday, March 14, 2020 12:51 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

Hi Ray (or anyone else who can help):

Since I have upgraded to Windows 10 (from Windows 7) I have a problem connecting to the mount via COM port
using ASCOM.
Basically the first attempt at connecting to the mount after a fresh boot up of the machine will always fail.
However, if I try again the second time it will work.

For example, I normally start APJog, then click connect. It will launch the mount ASCOM driver window, but it will
fail to detect the mount.
To solve the problem I will have to click connect again (which does nothing), then click disconnect (so to close the
mount driver window), then click connect again and then everything will work fine from there.

I have also tried to connect to the mount from Voyager - and I see the same problem (i.e. first attempt at connecting
to the mount after a fresh boot will fail).

This is a fatal issue, but more a nuisance.

I have noticed this problem since upgrading to Windows 10. Windows device manager does not report any error.

BTW, Voyager always run in administrator mode. I have set APJog to run as administrator as well, because if I
don't and try to run Voyager after APJog the mount will not connect.

Is there some setting I am missing?

Thanks


Peter Nagy
 

There are good number of people I know of uses Voyager running as admin with A-P mounts and A-P V2 ASCOM driver without issues like myself. Developer of Voyager said that Voyager must run as admin.

I suggest Henry create a new thread at Voyager forum. There was a similar issue reported at Voyager forum and this is one example and hopefully this will fix it for you:

https://forum.starkeeper.it/t/new-problem-connecting-to-mach1gto-since-upgrading-windows-7-to-windows-10/1162/8

Scroll down to about 9/13 as shown at right side. Here is one of the snippet:

"A Teamviewer session with Leo has fixed all the problems! I am very grateful. For posterity, the problem with the web server is to do with the port. For some reason on my PC the port I need to use is 8081, not the default 80. Leo figured out the problem so its all working fine now!"

Read the whole thread.

Peter


Henry Kwok
 

Hi Ray and Peter,

Voyager must run in administrator mode.

The person on the Voyager forum is me. Leo has fixed most of the problem for me. As it turns out, most of the problem was due to the upgrade process from Windows 7 to Windows 10. I have since done a clean install of Windows 10, and after Leo tweaked the settings everything is working 99% of the time now.

The only exception is the problem I described above i.e. the driver will not connect to the mount on the first attempt after a reboot, but will connect subsequently without changing any settings between the 1st and 2nd attempts. Therefore I know it has nothin to do with COM port selection. It is almost as if it needs one attempt to wake up something (hardware or software I am not sure).

The problem does not appear limited to Voyager as it will also happen with APJog (which I set to administrator mode) as well, therefore I think it is a problem with hardware-driver interaction and I have elected to post here rather than on the Voyager forum. 

Cheers

Henry


Bill Long
 

I recently bought a used Mach 1 with CP3 V2, and I cannot reproduce this issue on Windows 10. 


From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Henry Kwok <henry.ck.kwok@...>
Sent: Saturday, March 14, 2020 6:48 PM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10
 
Hi Ray and Peter,

Voyager must run in administrator mode.

The person on the Voyager forum is me. Leo has fixed most of the problem for me. As it turns out, most of the problem was due to the upgrade process from Windows 7 to Windows 10. I have since done a clean install of Windows 10, and after Leo tweaked the settings everything is working 99% of the time now.

The only exception is the problem I described above i.e. the driver will not connect to the mount on the first attempt after a reboot, but will connect subsequently without changing any settings between the 1st and 2nd attempts. Therefore I know it has nothin to do with COM port selection. It is almost as if it needs one attempt to wake up something (hardware or software I am not sure).

The problem does not appear limited to Voyager as it will also happen with APJog (which I set to administrator mode) as well, therefore I think it is a problem with hardware-driver interaction and I have elected to post here rather than on the Voyager forum. 

Cheers

Henry


Ray Gralak
 

There are good number of people I know of uses Voyager running as admin with A-P mounts and A-P V2
ASCOM driver without issues like myself. Developer of Voyager said that Voyager must run as admin.
Other ASCOM applications don't need to be run as administrator, and in fact should not need to be run as administrator. The only exception is that sometimes an application needs to run *once* as administrator to complete registration.

So what requires Voyager have to run as administrator? Certainly if it is just talking to an AP mount it does not need to run as administrator. Cameras neither, because other applications (e.g. SGPro and SkyX) do not need to run as administrator that access cameras, filter wheels, domes, weather stations, plate solvers, etc.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Peter Nagy
Sent: Saturday, March 14, 2020 6:00 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

There are good number of people I know of uses Voyager running as admin with A-P mounts and A-P V2
ASCOM driver without issues like myself. Developer of Voyager said that Voyager must run as admin.

I suggest Henry create a new thread at Voyager forum. There was a similar issue reported at Voyager forum and
this is one example and hopefully this will fix it for you:

https://forum.starkeeper.it/t/new-problem-connecting-to-mach1gto-since-upgrading-windows-7-to-windows-
10/1162/8

Scroll down to about 9/13 as shown at right side. Here is one of the snippet:

"A Teamviewer session with Leo has fixed all the problems! I am very grateful. For posterity, the problem with the
web server is to do with the port. For some reason on my PC the port I need to use is 8081, not the default 80. Leo
figured out the problem so its all working fine now!"

Read the whole thread.

Peter


Ray Gralak
 

Henry,

Did you try my instructions?

This is a not a problem with the mount or AP software. This has to do with the COM port connection to the mount. Are you using a USB/serial converter?

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Henry Kwok
Sent: Saturday, March 14, 2020 6:48 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

Hi Ray and Peter,

Voyager must run in administrator mode.

The person on the Voyager forum is me. Leo has fixed most of the problem for me. As it turns out, most of the
problem was due to the upgrade process from Windows 7 to Windows 10. I have since done a clean install of
Windows 10, and after Leo tweaked the settings everything is working 99% of the time now.

The only exception is the problem I described above i.e. the driver will not connect to the mount on the first attempt
after a reboot, but will connect subsequently without changing any settings between the 1st and 2nd attempts.
Therefore I know it has nothin to do with COM port selection. It is almost as if it needs one attempt to wake up
something (hardware or software I am not sure).

The problem does not appear limited to Voyager as it will also happen with APJog (which I set to administrator
mode) as well, therefore I think it is a problem with hardware-driver interaction and I have elected to post here
rather than on the Voyager forum.

Cheers

Henry


Bill Long
 

Besides the philosophical discussion here -- which I agree with, these folks are right that Voyager needs to run as admin per the developer. The licensing portion of the software and the integrated Web Dashboard UI have requirements on that, and a few others. 

Lets not derail the discussion though. It needs to run this way, and if everything else one needs runs as Admin it will work just fine. I have imaged for hundreds of hours with AP mounts, APCC, PHD2, SkyX, and Voyager all running as admin. 


From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Ray Gralak <groups3@...>
Sent: Saturday, March 14, 2020 7:13 PM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10
 
> There are good number of people I know of uses Voyager running as admin with A-P mounts and A-P V2
> ASCOM driver without issues like myself. Developer of Voyager said that Voyager must run as admin.

Other ASCOM applications don't need to be run as administrator, and in fact should not need to be run as administrator. The only exception is that sometimes an application needs to run *once* as administrator to complete registration.

So what requires Voyager have to run as administrator? Certainly if it is just talking to an AP mount it does not need to run as administrator. Cameras neither, because other applications (e.g. SGPro and SkyX) do not need to run as administrator that access cameras, filter wheels, domes, weather stations, plate solvers, etc.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.astro-physics.com%2Fapcc-pro&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198351972854681&amp;sdata=LJ%2FPZ1VVuCJVXgGUumw2B3PxVRvP47TwEzHEMCIl7HM%3D&amp;reserved=0
Author of PEMPro V3:  https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ccdware.com&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198351972854681&amp;sdata=eEW7dcRsi8kNcrtHscBpIqPekW1%2FdsA3RpG1rmuri10%3D&amp;reserved=0
Author of Astro-Physics V2 ASCOM Driver: https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.siriusimaging.com%2Fapdriver&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198351972854681&amp;sdata=T7o1GhnqdxuDxtrWKhFp%2F4Tl6gC6%2BGtoep%2FOI3HzTx0%3D&amp;reserved=0


> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Peter Nagy
> Sent: Saturday, March 14, 2020 6:00 PM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10
>
> There are good number of people I know of uses Voyager running as admin with A-P mounts and A-P V2
> ASCOM driver without issues like myself. Developer of Voyager said that Voyager must run as admin.
>
> I suggest Henry create a new thread at Voyager forum. There was a similar issue reported at Voyager forum and
> this is one example and hopefully this will fix it for you:
>
> https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fforum.starkeeper.it%2Ft%2Fnew-problem-connecting-to-mach1gto-since-upgrading-windows-7-to-windows-&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198351972854681&amp;sdata=23mG1p9rVQFG72aCFvHrPA2FHCrrfjThsc5k8SvppdQ%3D&amp;reserved=0
> 10/1162/8
>
> Scroll down to about 9/13 as shown at right side. Here is one of the snippet:
>
> "A Teamviewer session with Leo has fixed all the problems! I am very grateful. For posterity, the problem with the
> web server is to do with the port. For some reason on my PC the port I need to use is 8081, not the default 80. Leo
> figured out the problem so its all working fine now!"
>
> Read the whole thread.
>
> Peter
>





Ray Gralak
 

Besides the philosophical discussion here -- which I agree with, these folks are right that Voyager needs to run as
admin per the developer. The licensing portion of the software and the integrated Web Dashboard UI have
requirements on that, and a few others.
I suspected that. The developer has chosen a licensing scheme that requires administrative access. It is nothing to do with
communication to astronomy equipment. Running a web UI/API does not require administrative rights either. This sounds like
some poor design decisions.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Bill Long
Sent: Saturday, March 14, 2020 7:19 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

Besides the philosophical discussion here -- which I agree with, these folks are right that Voyager needs to run as
admin per the developer. The licensing portion of the software and the integrated Web Dashboard UI have
requirements on that, and a few others.

Lets not derail the discussion though. It needs to run this way, and if everything else one needs runs as Admin it
will work just fine. I have imaged for hundreds of hours with AP mounts, APCC, PHD2, SkyX, and Voyager all
running as admin.

________________________________

From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Ray Gralak <groups3@gralak.com>
Sent: Saturday, March 14, 2020 7:13 PM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

There are good number of people I know of uses Voyager running as admin with A-P mounts and A-P V2
ASCOM driver without issues like myself. Developer of Voyager said that Voyager must run as admin.
Other ASCOM applications don't need to be run as administrator, and in fact should not need to be run as
administrator. The only exception is that sometimes an application needs to run *once* as administrator to
complete registration.

So what requires Voyager have to run as administrator? Certainly if it is just talking to an AP mount it does not
need to run as administrator. Cameras neither, because other applications (e.g. SGPro and SkyX) do not need to
run as administrator that access cameras, filter wheels, domes, weather stations, plate solvers, etc.

-Ray Gralak
Author of APCC (Astro-Physics Command Center):
https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.astro-physics.com%2Fapcc-
pro&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaa
aa%7C1%7C0%7C637198351972854681&amp;sdata=LJ%2FPZ1VVuCJVXgGUumw2B3PxVRvP47TwEzHEMC
Il7HM%3D&amp;reserved=0 <https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.astro-
physics.com%2Fapcc-
pro&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaa
aa%7C1%7C0%7C637198351972854681&amp;sdata=LJ%2FPZ1VVuCJVXgGUumw2B3PxVRvP47TwEzHEMC
Il7HM%3D&amp;reserved=0>
Author of PEMPro V3:
https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ccdware.com&;data=02%7C01%7
C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C6371983
51972854681&amp;sdata=eEW7dcRsi8kNcrtHscBpIqPekW1%2FdsA3RpG1rmuri10%3D&amp;reserved=0
<https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ccdware.com&;data=02%7C01%
7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198
351972854681&amp;sdata=eEW7dcRsi8kNcrtHscBpIqPekW1%2FdsA3RpG1rmuri10%3D&amp;reserved=0>
Author of Astro-Physics V2 ASCOM Driver:
https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.siriusimaging.com%2Fapdriver&;
data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1
%7C0%7C637198351972854681&amp;sdata=T7o1GhnqdxuDxtrWKhFp%2F4Tl6gC6%2BGtoep%2FOI3HzTx0%
3D&amp;reserved=0
<https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.siriusimaging.com%2Fapdriver&
;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1
%7C0%7C637198351972854681&amp;sdata=T7o1GhnqdxuDxtrWKhFp%2F4Tl6gC6%2BGtoep%2FOI3HzTx0%
3D&amp;reserved=0>


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Peter Nagy
Sent: Saturday, March 14, 2020 6:00 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

There are good number of people I know of uses Voyager running as admin with A-P mounts and A-P V2
ASCOM driver without issues like myself. Developer of Voyager said that Voyager must run as admin.

I suggest Henry create a new thread at Voyager forum. There was a similar issue reported at Voyager forum and
this is one example and hopefully this will fix it for you:

https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fforum.starkeeper.it%2Ft%2Fnew-problem-
connecting-to-mach1gto-since-upgrading-windows-7-to-windows-
&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa
%7C1%7C0%7C637198351972854681&amp;sdata=23mG1p9rVQFG72aCFvHrPA2FHCrrfjThsc5k8SvppdQ%3D
&amp;reserved=0
<https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fforum.starkeeper.it%2Ft%2Fnew-problem-
connecting-to-mach1gto-since-upgrading-windows-7-to-windows-
&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa
%7C1%7C0%7C637198351972854681&amp;sdata=23mG1p9rVQFG72aCFvHrPA2FHCrrfjThsc5k8SvppdQ%3D
&amp;reserved=0>
10/1162/8

Scroll down to about 9/13 as shown at right side. Here is one of the snippet:

"A Teamviewer session with Leo has fixed all the problems! I am very grateful. For posterity, the problem with the
web server is to do with the port. For some reason on my PC the port I need to use is 8081, not the default 80.
Leo
figured out the problem so its all working fine now!"

Read the whole thread.

Peter





Bill Long
 

I agree that software should not have to run as admin. In the case of Voyager, that is where things are at. 


From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Ray Gralak <groups3@...>
Sent: Saturday, March 14, 2020 7:23 PM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10
 
> Besides the philosophical discussion here -- which I agree with, these folks are right that Voyager needs to run as
> admin per the developer. The licensing portion of the software and the integrated Web Dashboard UI have
> requirements on that, and a few others.

I suspected that. The developer has chosen a licensing scheme that requires administrative access. It is nothing to do with
communication to astronomy equipment. Running a web UI/API does not require administrative rights either. This sounds like
some poor design decisions.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.astro-physics.com%2Fapcc-pro&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198358442041913&amp;sdata=8vqWOMLqTW0cKxzD8xTQYsJJhw0qRzFS0tbe4sJw7sA%3D&amp;reserved=0
Author of PEMPro V3:  https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ccdware.com&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198358442051917&amp;sdata=CPBu3pUh9H22GyArs9ys3Xx6Le5KsLujRZi8ZOM1ekg%3D&amp;reserved=0
Author of Astro-Physics V2 ASCOM Driver: https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.siriusimaging.com%2Fapdriver&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198358442051917&amp;sdata=gUtcJ2g%2B%2FRg6OvMtehafQbd%2Bn4vxIGVwLGp7OMPrqOg%3D&amp;reserved=0


> -----Original Message-----
> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Bill Long
> Sent: Saturday, March 14, 2020 7:19 PM
> To: main@ap-gto.groups.io
> Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10
>
> Besides the philosophical discussion here -- which I agree with, these folks are right that Voyager needs to run as
> admin per the developer. The licensing portion of the software and the integrated Web Dashboard UI have
> requirements on that, and a few others.
>
> Lets not derail the discussion though. It needs to run this way, and if everything else one needs runs as Admin it
> will work just fine. I have imaged for hundreds of hours with AP mounts, APCC, PHD2, SkyX, and Voyager all
> running as admin.
>
> ________________________________
>
> From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Ray Gralak <groups3@...>
> Sent: Saturday, March 14, 2020 7:13 PM
> To: main@ap-gto.groups.io <main@ap-gto.groups.io>
> Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10
>
> > There are good number of people I know of uses Voyager running as admin with A-P mounts and A-P V2
> > ASCOM driver without issues like myself. Developer of Voyager said that Voyager must run as admin.
>
> Other ASCOM applications don't need to be run as administrator, and in fact should not need to be run as
> administrator. The only exception is that sometimes an application needs to run *once* as administrator to
> complete registration.
>
> So what requires Voyager have to run as administrator? Certainly if it is just talking to an AP mount it does not
> need to run as administrator. Cameras neither, because other applications (e.g. SGPro and SkyX) do not need to
> run as administrator that access cameras, filter wheels, domes, weather stations, plate solvers, etc.
>
> -Ray Gralak
> Author of APCC (Astro-Physics Command Center):
> https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%253A%252F%252Fwww.astro-physics.com%252Fapcc-&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198358442051917&amp;sdata=W693ubnweW9ZrHgKCIWaplQvn8loBZSoh5DyjtAegkk%3D&amp;reserved=0
> pro&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaa
> aa%7C1%7C0%7C637198351972854681&amp;sdata=LJ%2FPZ1VVuCJVXgGUumw2B3PxVRvP47TwEzHEMC
> Il7HM%3D&amp;reserved=0 <https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%253A%252F%252Fwww.astro-&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198358442051917&amp;sdata=bLcbV8VTObboL1MMeRGSmi6wkHw1I9uXQ%2BXRJJyZ2DQ%3D&amp;reserved=0
> physics.com%2Fapcc-
> pro&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaa
> aa%7C1%7C0%7C637198351972854681&amp;sdata=LJ%2FPZ1VVuCJVXgGUumw2B3PxVRvP47TwEzHEMC
> Il7HM%3D&amp;reserved=0>
> Author of PEMPro V3:
> https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%253A%252F%252Fwww.ccdware.com%26amp%3Bdata%3D02%257C01%257&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198358442051917&amp;sdata=YVjNNQxHkmsZTPKGtNTP0IP1zqL1yD%2BU9PNBksy%2Fh74%3D&amp;reserved=0
> C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C6371983
> 51972854681&amp;sdata=eEW7dcRsi8kNcrtHscBpIqPekW1%2FdsA3RpG1rmuri10%3D&amp;reserved=0
> <https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%253A%252F%252Fwww.ccdware.com%26amp%3Bdata%3D02%257C01%25&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198358442051917&amp;sdata=yoF4Vk9yksJuyUIeei8CMjmy%2F1CwPGa1NCfg0tvU1kM%3D&amp;reserved=0
> 7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198
> 351972854681&amp;sdata=eEW7dcRsi8kNcrtHscBpIqPekW1%2FdsA3RpG1rmuri10%3D&amp;reserved=0>
> Author of Astro-Physics V2 ASCOM Driver:
> https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%253A%252F%252Fwww.siriusimaging.com%252Fapdriver%26amp&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198358442051917&amp;sdata=IfwCaDswchXjYrGFxg14lTq4jjHh7yFEb93QAAJaDRI%3D&amp;reserved=0;
> data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1
> %7C0%7C637198351972854681&amp;sdata=T7o1GhnqdxuDxtrWKhFp%2F4Tl6gC6%2BGtoep%2FOI3HzTx0%
> 3D&amp;reserved=0
> <https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%253A%252F%252Fwww.siriusimaging.com%252Fapdriver%26amp&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198358442051917&amp;sdata=IfwCaDswchXjYrGFxg14lTq4jjHh7yFEb93QAAJaDRI%3D&amp;reserved=0
> ;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1
> %7C0%7C637198351972854681&amp;sdata=T7o1GhnqdxuDxtrWKhFp%2F4Tl6gC6%2BGtoep%2FOI3HzTx0%
> 3D&amp;reserved=0>
>
>
> > -----Original Message-----
> > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Peter Nagy
> > Sent: Saturday, March 14, 2020 6:00 PM
> > To: main@ap-gto.groups.io
> > Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10
> >
> > There are good number of people I know of uses Voyager running as admin with A-P mounts and A-P V2
> > ASCOM driver without issues like myself. Developer of Voyager said that Voyager must run as admin.
> >
> > I suggest Henry create a new thread at Voyager forum. There was a similar issue reported at Voyager forum and
> > this is one example and hopefully this will fix it for you:
> >
> > https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%253A%252F%252Fforum.starkeeper.it%252Ft%252Fnew-problem-&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198358442051917&amp;sdata=dn5TcWBMjp03C5Xt198y0pZ50MjEI9kq8G%2FWIcReA4E%3D&amp;reserved=0
> connecting-to-mach1gto-since-upgrading-windows-7-to-windows-
> &amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa
> %7C1%7C0%7C637198351972854681&amp;sdata=23mG1p9rVQFG72aCFvHrPA2FHCrrfjThsc5k8SvppdQ%3D
> &amp;reserved=0
> <https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%253A%252F%252Fforum.starkeeper.it%252Ft%252Fnew-problem-&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198358442051917&amp;sdata=dn5TcWBMjp03C5Xt198y0pZ50MjEI9kq8G%2FWIcReA4E%3D&amp;reserved=0
> connecting-to-mach1gto-since-upgrading-windows-7-to-windows-
> &amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa
> %7C1%7C0%7C637198351972854681&amp;sdata=23mG1p9rVQFG72aCFvHrPA2FHCrrfjThsc5k8SvppdQ%3D
> &amp;reserved=0>
> > 10/1162/8
> >
> > Scroll down to about 9/13 as shown at right side. Here is one of the snippet:
> >
> > "A Teamviewer session with Leo has fixed all the problems! I am very grateful. For posterity, the problem with the
> > web server is to do with the port. For some reason on my PC the port I need to use is 8081, not the default 80.
> Leo
> > figured out the problem so its all working fine now!"
> >
> > Read the whole thread.
> >
> > Peter
> >
>
>
>
>
>
>





Ray Gralak
 

I agree that software should not have to run as admin. In the case of Voyager, that is where things are at.
Okay then... so every application used will likely need to be started as administrator. If not, there could be a conflict on the
driver's COM port if both an admin and non-admin AP V2 driver instances are invoked. APCC gets around the problem by creating
separate virtual ports for regular and admin driver instances so two AP V2 drivers can be run simultaneously.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Bill Long
Sent: Saturday, March 14, 2020 7:26 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

I agree that software should not have to run as admin. In the case of Voyager, that is where things are at.

________________________________

From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Ray Gralak <groups3@gralak.com>
Sent: Saturday, March 14, 2020 7:23 PM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

Besides the philosophical discussion here -- which I agree with, these folks are right that Voyager needs to run
as
admin per the developer. The licensing portion of the software and the integrated Web Dashboard UI have
requirements on that, and a few others.
I suspected that. The developer has chosen a licensing scheme that requires administrative access. It is nothing
to do with
communication to astronomy equipment. Running a web UI/API does not require administrative rights either. This
sounds like
some poor design decisions.

-Ray Gralak
Author of APCC (Astro-Physics Command Center):
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.astro-physics.com%2Fapcc-
pro&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaa
aaa%7C1%7C0%7C637198358442041913&amp;sdata=8vqWOMLqTW0cKxzD8xTQYsJJhw0qRzFS0tbe4sJw7s
A%3D&amp;reserved=0 <https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.astro-
physics.com%2Fapcc-
pro&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaa
aaa%7C1%7C0%7C637198358442041913&amp;sdata=8vqWOMLqTW0cKxzD8xTQYsJJhw0qRzFS0tbe4sJw7s
A%3D&amp;reserved=0>
Author of PEMPro V3:
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ccdware.com&;data=02%7C01%
7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C63719
8358442051917&amp;sdata=CPBu3pUh9H22GyArs9ys3Xx6Le5KsLujRZi8ZOM1ekg%3D&amp;reserved=0
<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ccdware.com&;data=02%7C01
%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637
198358442051917&amp;sdata=CPBu3pUh9H22GyArs9ys3Xx6Le5KsLujRZi8ZOM1ekg%3D&amp;reserved=0>
Author of Astro-Physics V2 ASCOM Driver:
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.siriusimaging.com%2Fapdriver&;
data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1
%7C0%7C637198358442051917&amp;sdata=gUtcJ2g%2B%2FRg6OvMtehafQbd%2Bn4vxIGVwLGp7OMPrqOg
%3D&amp;reserved=0
<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.siriusimaging.com%2Fapdriver&am
p;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7
C1%7C0%7C637198358442051917&amp;sdata=gUtcJ2g%2B%2FRg6OvMtehafQbd%2Bn4vxIGVwLGp7OMPrq
Og%3D&amp;reserved=0>


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Bill Long
Sent: Saturday, March 14, 2020 7:19 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

Besides the philosophical discussion here -- which I agree with, these folks are right that Voyager needs to run
as
admin per the developer. The licensing portion of the software and the integrated Web Dashboard UI have
requirements on that, and a few others.

Lets not derail the discussion though. It needs to run this way, and if everything else one needs runs as Admin
it
will work just fine. I have imaged for hundreds of hours with AP mounts, APCC, PHD2, SkyX, and Voyager all
running as admin.

________________________________

From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Ray Gralak <groups3@gralak.com>
Sent: Saturday, March 14, 2020 7:13 PM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

There are good number of people I know of uses Voyager running as admin with A-P mounts and A-P V2
ASCOM driver without issues like myself. Developer of Voyager said that Voyager must run as admin.
Other ASCOM applications don't need to be run as administrator, and in fact should not need to be run as
administrator. The only exception is that sometimes an application needs to run *once* as administrator to
complete registration.

So what requires Voyager have to run as administrator? Certainly if it is just talking to an AP mount it does not
need to run as administrator. Cameras neither, because other applications (e.g. SGPro and SkyX) do not need
to
run as administrator that access cameras, filter wheels, domes, weather stations, plate solvers, etc.

-Ray Gralak
Author of APCC (Astro-Physics Command Center):
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2
F%3Furl%3Dhttps%253A%252F%252Fwww.astro-physics.com%252Fapcc-
&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa
%7C1%7C0%7C637198358442051917&amp;sdata=W693ubnweW9ZrHgKCIWaplQvn8loBZSoh5DyjtAegkk%3D
&amp;reserved=0
<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%
2F%3Furl%3Dhttps%253A%252F%252Fwww.astro-physics.com%252Fapcc-
&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa
%7C1%7C0%7C637198358442051917&amp;sdata=W693ubnweW9ZrHgKCIWaplQvn8loBZSoh5DyjtAegkk%3D
&amp;reserved=0>
pro&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaa
aa%7C1%7C0%7C637198351972854681&amp;sdata=LJ%2FPZ1VVuCJVXgGUumw2B3PxVRvP47TwEzHEMC
Il7HM%3D&amp;reserved=0
<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%
2F%3Furl%3Dhttps%253A%252F%252Fwww.astro-
&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa
%7C1%7C0%7C637198358442051917&amp;sdata=bLcbV8VTObboL1MMeRGSmi6wkHw1I9uXQ%2BXRJJyZ2
DQ%3D&amp;reserved=0
physics.com%2Fapcc-
pro&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaa
aa%7C1%7C0%7C637198351972854681&amp;sdata=LJ%2FPZ1VVuCJVXgGUumw2B3PxVRvP47TwEzHEMC
Il7HM%3D&amp;reserved=0>
Author of PEMPro V3:
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2
F%3Furl%3Dhttps%253A%252F%252Fwww.ccdware.com%26amp%3Bdata%3D02%257C01%257&amp;data=0
2%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0
%7C637198358442051917&amp;sdata=YVjNNQxHkmsZTPKGtNTP0IP1zqL1yD%2BU9PNBksy%2Fh74%3D&a
mp;reserved=0
<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%
2F%3Furl%3Dhttps%253A%252F%252Fwww.ccdware.com%26amp%3Bdata%3D02%257C01%257&amp;data=
02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C
0%7C637198358442051917&amp;sdata=YVjNNQxHkmsZTPKGtNTP0IP1zqL1yD%2BU9PNBksy%2Fh74%3D&a
mp;reserved=0>
C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C6371983
51972854681&amp;sdata=eEW7dcRsi8kNcrtHscBpIqPekW1%2FdsA3RpG1rmuri10%3D&amp;reserved=0
<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%
2F%3Furl%3Dhttps%253A%252F%252Fwww.ccdware.com%26amp%3Bdata%3D02%257C01%25&amp;data=0
2%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0
%7C637198358442051917&amp;sdata=yoF4Vk9yksJuyUIeei8CMjmy%2F1CwPGa1NCfg0tvU1kM%3D&amp;res
erved=0
7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198
351972854681&amp;sdata=eEW7dcRsi8kNcrtHscBpIqPekW1%2FdsA3RpG1rmuri10%3D&amp;reserved=0>
Author of Astro-Physics V2 ASCOM Driver:
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2
F%3Furl%3Dhttps%253A%252F%252Fwww.siriusimaging.com%252Fapdriver%26amp&amp;data=02%7C01%7
C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637198
358442051917&amp;sdata=IfwCaDswchXjYrGFxg14lTq4jjHh7yFEb93QAAJaDRI%3D&amp;reserved=0
<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%
2F%3Furl%3Dhttps%253A%252F%252Fwww.siriusimaging.com%252Fapdriver%26amp&amp;data=02%7C01%
7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C63719
8358442051917&amp;sdata=IfwCaDswchXjYrGFxg14lTq4jjHh7yFEb93QAAJaDRI%3D&amp;reserved=0> ;
data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1
%7C0%7C637198351972854681&amp;sdata=T7o1GhnqdxuDxtrWKhFp%2F4Tl6gC6%2BGtoep%2FOI3HzTx0%
3D&amp;reserved=0
<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%
2F%3Furl%3Dhttps%253A%252F%252Fwww.siriusimaging.com%252Fapdriver%26amp&amp;data=02%7C01%
7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C63719
8358442051917&amp;sdata=IfwCaDswchXjYrGFxg14lTq4jjHh7yFEb93QAAJaDRI%3D&amp;reserved=0
;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1
%7C0%7C637198351972854681&amp;sdata=T7o1GhnqdxuDxtrWKhFp%2F4Tl6gC6%2BGtoep%2FOI3HzTx0%
3D&amp;reserved=0>


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Peter Nagy
Sent: Saturday, March 14, 2020 6:00 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

There are good number of people I know of uses Voyager running as admin with A-P mounts and A-P V2
ASCOM driver without issues like myself. Developer of Voyager said that Voyager must run as admin.

I suggest Henry create a new thread at Voyager forum. There was a similar issue reported at Voyager forum
and
this is one example and hopefully this will fix it for you:

https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2
F%3Furl%3Dhttps%253A%252F%252Fforum.starkeeper.it%252Ft%252Fnew-problem-
&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa
%7C1%7C0%7C637198358442051917&amp;sdata=dn5TcWBMjp03C5Xt198y0pZ50MjEI9kq8G%2FWIcReA4E%
3D&amp;reserved=0
<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%
2F%3Furl%3Dhttps%253A%252F%252Fforum.starkeeper.it%252Ft%252Fnew-problem-
&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa
%7C1%7C0%7C637198358442051917&amp;sdata=dn5TcWBMjp03C5Xt198y0pZ50MjEI9kq8G%2FWIcReA4E%
3D&amp;reserved=0>
connecting-to-mach1gto-since-upgrading-windows-7-to-windows-
&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa
%7C1%7C0%7C637198351972854681&amp;sdata=23mG1p9rVQFG72aCFvHrPA2FHCrrfjThsc5k8SvppdQ%3D
&amp;reserved=0
<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%
2F%3Furl%3Dhttps%253A%252F%252Fforum.starkeeper.it%252Ft%252Fnew-problem-
&amp;data=02%7C01%7C%7Ca4bd9792e1b74c61c18d08d7c887ee2f%7C84df9e7fe9f640afb435aaaaaaaaaaaa
%7C1%7C0%7C637198358442051917&amp;sdata=dn5TcWBMjp03C5Xt198y0pZ50MjEI9kq8G%2FWIcReA4E%
3D&amp;reserved=0
connecting-to-mach1gto-since-upgrading-windows-7-to-windows-
&amp;data=02%7C01%7C%7C4754c20f8ce84ef9e50c08d7c8866c5a%7C84df9e7fe9f640afb435aaaaaaaaaaaa
%7C1%7C0%7C637198351972854681&amp;sdata=23mG1p9rVQFG72aCFvHrPA2FHCrrfjThsc5k8SvppdQ%3D
&amp;reserved=0>
10/1162/8

Scroll down to about 9/13 as shown at right side. Here is one of the snippet:

"A Teamviewer session with Leo has fixed all the problems! I am very grateful. For posterity, the problem with
the
web server is to do with the port. For some reason on my PC the port I need to use is 8081, not the default 80.
Leo
figured out the problem so its all working fine now!"

Read the whole thread.

Peter









Henry Kwok
 

Hi Ray

I do not use USB-serial converter. The PC has a physical serial port which is COM1
I have run device manager after boot. It reports COM1 as the only COM port and it is running properly.
I have run AP Telescope Setup as normal or as administrator immediate after reboot - in both cases it detects the mount normally.
I have run APJog as normal or as administrator immediate after reboot - the driver fails to detect the mount on the first attempt.
Is there a log file somewhere that may be of use?
Perhaps it is a problem specific to my hardware?

Thanks

Henry


Ray Gralak
 

Henry,

I have run APJog as normal or as administrator immediate after reboot - the driver fails to detect the mount on the
first attempt.
When the mount does not connect does the port number on the driver say COM1? Or another port?

Is it possible that something else may be trying to connect to COM1 at the same time?

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Henry Kwok
Sent: Saturday, March 14, 2020 7:59 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

Hi Ray

I do not use USB-serial converter. The PC has a physical serial port which is COM1
I have run device manager after boot. It reports COM1 as the only COM port and it is running properly.
I have run AP Telescope Setup as normal or as administrator immediate after reboot - in both cases it detects the
mount normally.
I have run APJog as normal or as administrator immediate after reboot - the driver fails to detect the mount on the
first attempt.
Is there a log file somewhere that may be of use?
Perhaps it is a problem specific to my hardware?

Thanks

Henry


Henry Kwok
 

Hi Ray

It says COM1 - see screenshots attached.

Thanks

Henry


Ray Gralak
 

Hi Henry,

It says COM1 - see screenshots attached.
1. AP Jog does not run as administrator. Did you run it that way on purpose?

2. Is it possible another application was connected to the COM port at the same time?

3. If after the connect fails if you click connect again in APJog without exiting does the connect work?

I have just tried to reproduce the problem you are seeing and I cannot so it is likely something specific on your computer.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Henry Kwok
Sent: Saturday, March 14, 2020 8:32 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

Hi Ray

It says COM1 - see screenshots attached.

Thanks

Henry



Henry Kwok
 

AP Jog fails to connect even in normal mode, if launched after a fresh reboot. And as it is a fresh reboot, there is nothing trying to access COM1.

The reason why I run APJog in administrator mode, is so that later on when I run Voyager, which must be in admin mode, the same driver instance will be used. Otherwise, there will be two instances of drivers and they don't play nicely together -- been there, done that.

Oh well, I guess it shall remain a mystery then.... Like I say it is just a nuisance, as a second attempt at connecting will work. I was just hoping that it is some software setting that is causing this problem.


Ray Gralak
 

Oh well, I guess it shall remain a mystery then.... Like I say it is just a nuisance, as a second attempt at connecting
will work. I was just hoping that it is some software setting that is causing this problem.
One possibility is that it could be the COM port on your computer has garbage in the send or receive buffers.

You could try seeing if there is a specific COM port driver for your computer. Also you could try replacing or adding another COM port adapter to see if the problem goes away.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Henry Kwok
Sent: Saturday, March 14, 2020 9:09 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] GTO CP3 connection problem via COM port in Windows 10

AP Jog fails to connect even in normal mode, if launched after a fresh reboot. And as it is a fresh reboot, there is
nothing trying to access COM1.

The reason why I run APJog in administrator mode, is so that later on when I run Voyager, which must be in
admin mode, the same driver instance will be used. Otherwise, there will be two instances of drivers and they
don't play nicely together -- been there, done that.

Oh well, I guess it shall remain a mystery then.... Like I say it is just a nuisance, as a second attempt at connecting
will work. I was just hoping that it is some software setting that is causing this problem.



Henry Kwok
 

3. If after the connect fails if you click connect again in APJog without exiting does the connect work?
After it fails to connect, I need to click connect again, then disconnect, then close the application to unload the driver instance.

Then I can launch APJog again, click connect and then it will work normally.


Peter Nagy
 

Can you try with a different Windows 10 computer and see if it behaves differently? 

Peter