AP V2 ASCOM driver v5.30.07 available for download


Ray Gralak
 

Hello all,

The Astro-Physics V2 ASCOM driver v5.30.07 and documentation is available for download at this link:

https://www.gralak.com/apdriver

This version is *required* for Mach 2 mounts and highly recommended for all other Astro-Physics mounts with GTOCP1 through GTOCP5
control boxes.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


Worsel
 

Ray

New driver andnew  APCC Pro both installed and functional without issue.

Thanks!

Bryan


Bruce Donzanti
 

Hi Ray

I tried to download the new version several times (I have a GTOCP4) but keep getting the same message:

The following applications are using files that need to be updated by Setup.  It is recommended that you allow Setup to automatically close these applications.  After the installation has completed, Setup will attempt to restart the applications.

AstroPhysics V2 ASCOM Mount Drive
APSetup

I clicked NEXT as the Automatically close the applications radio button was filled in.  However, when I did that, a second message popped up: 
Setup was unable to automatically close all applications.  It is recommended that you close all applications using files that need to be updated by Setup before continuing.

So, not sure how to proceed as I am not usually a windows user and don't want to mess things up.  I just hit abort.  How should I proceed?

Bruce 




On Sat, Feb 29, 2020 at 7:18 PM Ray Gralak <groups3@...> wrote:
Hello all,

The Astro-Physics V2 ASCOM driver v5.30.07 and documentation is available for download at this link:

https://www.gralak.com/apdriver

This version is *required* for Mach 2 mounts and highly recommended for all other Astro-Physics mounts with GTOCP1 through GTOCP5
control boxes.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3:  https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver





Dale Ghent
 

There's an instance of the A-P ASCOM driver still running for some reason, and the installer was unable to get it to quit. This is not an uncommon occurrence with ASCOM drivers in general and is rather annoying when it does happen - the driver is still running because it believes that something is using it, when in reality there isn't. If you are certain that this is the case, you can open up Windows Task Manager (right click the task bar, select Task Manager) and in the resulting list of programs that are running, you can right click on it and "End Process". That should kill it and you can retry the installation.

Failing that, a reboot will always clear the zombie process.

/dale

On Mar 2, 2020, at 12:47 PM, Bruce Donzanti <donza2735@gmail.com> wrote:

Hi Ray

I tried to download the new version several times (I have a GTOCP4) but keep getting the same message:

The following applications are using files that need to be updated by Setup. It is recommended that you allow Setup to automatically close these applications. After the installation has completed, Setup will attempt to restart the applications.

AstroPhysics V2 ASCOM Mount Drive
APSetup

I clicked NEXT as the Automatically close the applications radio button was filled in. However, when I did that, a second message popped up:
Setup was unable to automatically close all applications. It is recommended that you close all applications using files that need to be updated by Setup before continuing.

So, not sure how to proceed as I am not usually a windows user and don't want to mess things up. I just hit abort. How should I proceed?

Bruce




On Sat, Feb 29, 2020 at 7:18 PM Ray Gralak <groups3@gralak.com> wrote:
Hello all,

The Astro-Physics V2 ASCOM driver v5.30.07 and documentation is available for download at this link:

https://www.gralak.com/apdriver

This version is *required* for Mach 2 mounts and highly recommended for all other Astro-Physics mounts with GTOCP1 through GTOCP5
control boxes.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver





Mike Dodd
 

On 3/2/2020 12:47 PM, Bruce Donzanti wrote:
So, not sure how to proceed as I am not usually a windows user and don't
want to mess things up. I just hit abort. How should I proceed?
Last night I successfully installed the driver on my obs PC. I started the PC, then immediately ran the driver installation program. The AP1200 was not even powered-up. The installation ran perfectly. When done, I powered-up the mount, launched the AP Jog program, and connected to the mount to verify that the driver still works. It does.

HTH.

--
Mike

Mike Dodd
Louisa County, Virginia USA
http://astronomy.mdodd.com


 

I did that too - booted up the PC and then ran the installer immediately before anything else started up


On Mon, Mar 2, 2020 at 10:06 AM Mike Dodd <mike@...> wrote:
On 3/2/2020 12:47 PM, Bruce Donzanti wrote:
> So, not sure how to proceed as I am not usually a windows user and don't
> want to mess things up.  I just hit abort.  How should I proceed?

Last night I successfully installed the driver on my obs PC. I started
the PC, then immediately ran the driver installation program. The AP1200
was not even powered-up. The installation ran perfectly. When done, I
powered-up the mount, launched the AP Jog program, and connected to the
mount to verify that the driver still works. It does.

HTH.

--
Mike

Mike Dodd
Louisa County, Virginia USA
http://astronomy.mdodd.com





--
Brian 



Brian Valente


Bruce Donzanti
 

Dale/Mike/Brian

That worked!  Thanks much guys.




On Mon, Mar 2, 2020 at 1:04 PM Dale Ghent <daleg@...> wrote:

There's an instance of the A-P ASCOM driver still running for some reason, and the installer was unable to get it to quit. This is not an uncommon occurrence with ASCOM drivers in general and is rather annoying when it does happen - the driver is still running because it believes that something is using it, when in reality there isn't.  If you are certain that this is the case, you can open up Windows Task Manager (right click the task bar, select Task Manager) and in the resulting list of programs that are running, you can right click on it and "End Process". That should kill it and you can retry the installation.

Failing that, a reboot will always clear the zombie process.

/dale

> On Mar 2, 2020, at 12:47 PM, Bruce Donzanti <donza2735@...> wrote:
>
> Hi Ray
>
> I tried to download the new version several times (I have a GTOCP4) but keep getting the same message:
>
> The following applications are using files that need to be updated by Setup.  It is recommended that you allow Setup to automatically close these applications.  After the installation has completed, Setup will attempt to restart the applications.
>
> AstroPhysics V2 ASCOM Mount Drive
> APSetup
>
> I clicked NEXT as the Automatically close the applications radio button was filled in.  However, when I did that, a second message popped up:
> Setup was unable to automatically close all applications.  It is recommended that you close all applications using files that need to be updated by Setup before continuing.
>
> So, not sure how to proceed as I am not usually a windows user and don't want to mess things up.  I just hit abort.  How should I proceed?
>
> Bruce
>
>
>
>
> On Sat, Feb 29, 2020 at 7:18 PM Ray Gralak <groups3@...> wrote:
> Hello all,
>
> The Astro-Physics V2 ASCOM driver v5.30.07 and documentation is available for download at this link:
>
> https://www.gralak.com/apdriver
>
> This version is *required* for Mach 2 mounts and highly recommended for all other Astro-Physics mounts with GTOCP1 through GTOCP5
> control boxes.
>
> -Ray Gralak
> Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
> Author of PEMPro V3:  https://www.ccdware.com
> Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver
>
>
>
>
>





Mark
 

Since installing the new ascom driver on my mach1gto the mount seems to operate normally, however the custom slew rate does not operate as expected.

Steps to reproduce:
1.  Open the telescope setup application
2.  Click advanced >>>>
3.  click the dropdown box next to "set slew rate" and you only have the options of:  600x 900x and 1200x.

Previously I could set this to 200x so I wouldn't piss off my neighbours.  Slewing took longer but it was better than them complaining to my landlord.


Larry Phillips
 
Edited

I had the same behavior but since I am eventually going to get a Mach2, I click on the Mach2 mount type and the custom slew rate was available.  I then went back to Mach1 and the custom slew rate was now available.

Larry


Mark
 

Larry-  I'll check this out, thanks for the pointer!


Mark
 

Unfortunately that didn't work.  The "custom" setting shows up in the settings application if you switch between mach1 and mach2 and then back to mach1, then you can set the custom slew rate, but when you start the scope itself the custom slew rate is no longer available.  Looks like it's a genuine bug.


Ray Gralak
 

Mark,

Thanks for pointing that out. That will be fixed in the next build. There were a lot of changes to the rate command logic with emphasis on the Mach 2 and that must have slipped through.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Mark
Sent: Tuesday, March 3, 2020 8:09 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] AP V2 ASCOM driver v5.30.07 available for download

Unfortunately that didn't work. The "custom" setting shows up in the settings application if you switch between
mach1 and mach2 and then back to mach1, then you can set the custom slew rate, but when you start the scope
itself the custom slew rate is no longer available. Looks like it's a genuine bug.