Cannot Seem to Keep the Same Virtual Ports


Jerome A Yesavage
 

Hi,

I have a Mach1 with the latest APCC.  The mount is on Comm 5 via USB and George had me set up two virtual Ports at 21 and 22.  I am using ACP and the virtual ports do not connect automatically.  It appears I have lost them and I now have Comm 6 and 7.  The Mount connects to the USB Port, but the AP Virtual drivers do not, automatically or manually.  I tried to delete the virtual ports and that does not work either. 

Any suggestions on this as nobody is in the office for a couple days, just had to rebuild the system....

Happy New Year,

JY


Ray Gralak
 

The mount is on Comm 5 via USB and George had me set up two virtual
Ports at 21 and 22. I am using ACP and the virtual ports do not connect automatically. It appears I have lost them
and I now have Comm 6 and 7. The Mount connects to the USB Port, but the AP Virtual drivers do not,
automatically or manually. I tried to delete the virtual ports and that does not work either.
It doesn't matter which COM ports are used for the virtual ports if you set the APCC connect configuration as in the attached screenshot.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Jerome A Yesavage
Sent: Friday, December 27, 2019 9:03 AM
To: main@ap-gto.groups.io
Subject: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

Hi,

I have a Mach1 with the latest APCC. The mount is on Comm 5 via USB and George had me set up two virtual
Ports at 21 and 22. I am using ACP and the virtual ports do not connect automatically. It appears I have lost them
and I now have Comm 6 and 7. The Mount connects to the USB Port, but the AP Virtual drivers do not,
automatically or manually. I tried to delete the virtual ports and that does not work either.

Any suggestions on this as nobody is in the office for a couple days, just had to rebuild the system....

Happy New Year,

JY


Joe Zeglinski
 

Jerome,
 
    Visit the FTDI website, the company who makes the serial/USB adapter chips for various adapter brands. There is a Windows utility that you can use to re-assign FTDI serial ports addresses to whatever number you need. Very handy.
FTDI Com Port Assignment:
 
    Easiest way to assign – or reassign - an FTDI serial COM port address  to whatever port number you need it to be, or see what ports are already assigned, without messing with Device Manager, etc.
 
    Also, handy – a Win-XP & Win-8/10  Com Port Monitor  desktop “ GADGET” utility.
 
    I use both, very handy. Even though GADGETS are no longer (officially) supported in Win-10, this one works, if you install Microsoft’s GADGET conversion fix, which you might be offered as a warning/pop-up. No problem.
 
    However, if your adapter uses a PROLIFIC chip instead, sorry, my sympathies with that choice.
 
Joe Z.
 
 

From: Jerome A Yesavage
Sent: Friday, December 27, 2019 12:03 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] Cannot Seem to Keep the Same Virtual Ports
 
Hi,

I have a Mach1 with the latest APCC.  The mount is on Comm 5 via USB and George had me set up two virtual Ports at 21 and 22.  I am using ACP and the virtual ports do not connect automatically.  It appears I have lost them and I now have Comm 6 and 7.  The Mount connects to the USB Port, but the AP Virtual drivers do not, automatically or manually.  I tried to delete the virtual ports and that does not work either. 

Any suggestions on this as nobody is in the office for a couple days, just had to rebuild the system....

Happy New Year,

JY


Jerome A Yesavage
 

Thanks Ray,

George had me uncheck the Auto-Conf and check the Auto-Connect.  Seems to work better with both checked.  Any reason why not? 

Seems you need this to automatically connect with various components that start in APC

Comms 21 and 22 came back after I rebooted the machine. 

JY


Ray Gralak
 

George had me uncheck the Auto-Conf and check the Auto-Connect. Seems to work better with both checked.
What works better? Connecting APCC to the driver does nothing but keep the driver running even if there are no clients using the driver.

Any reason why not?
When APCC is connected to the driver when no ASCOM clients are using the driver it just wastes disk space for both (APCC and the driver) logs.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Jerome A Yesavage
Sent: Friday, December 27, 2019 12:58 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

Thanks Ray,

George had me uncheck the Auto-Conf and check the Auto-Connect. Seems to work better with both checked.
Any reason why not?

Seems you need this to automatically connect with various components that start in APC

Comms 21 and 22 came back after I rebooted the machine.

JY


Jerome A Yesavage
 

I am still having problems with this.  If for some reason virtual Port 21 goes away (I am not sure why... maybe not shut down perfectly by ACP), APCC seems to decide to rereate a new Port 6.  Problem is there is already another USB Port 6 to which my NightCrawler focuser is attached.  I guess Port 6 may be seen as the lowest number free and selected, if the focuser is not turned on, which it is not since I have to start up APCC and the mount first, before the Nightcrawler, or FocusMax will not see a mount. 

At this point neither APCC not FocusMax are working right and I guess I have to reboot the computer to start from scratch or try to renumber the serial ports as suggested.  But then it seem that Port 6 will just get recreated at some point. 

I hate rebooting the computer remotely and renumbering is not a practical solution. 

Can you somehow exclude a port number from use by APCC?   


Ray Gralak
 

Hi Jerome,

Can you somehow exclude a port number from use by APCC?
No, but the ports should stay configured on the Virtual Ports tab if you:

1. Manually delete the first two virtual ports (if they are created, click "Delete" for each),
2. Set the virtual port numbers to the ports you want (e.g. COM21 and COM22).
3. Click "Create" for each port.

Then every time APCC starts those ports will be configured *if* they are available. However, if something else is using one of those ports APCC will choose the lowest available COM port number.

And again, I suggest you follow the settings in the screen shot I sent before and that I am attaching again.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Jerome A Yesavage
Sent: Tuesday, December 31, 2019 8:20 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

I am still having problems with this. If for some reason virtual Port 21 goes away (I am not sure why... maybe not
shut down perfectly by ACP), APCC seems to decide to rereate a new Port 6. Problem is there is already another
USB Port 6 to which my NightCrawler focuser is attached. I guess Port 6 may be seen as the lowest number free
and selected, if the focuser is not turned on, which it is not since I have to start up APCC and the mount first,
before the Nightcrawler, or FocusMax will not see a mount.

At this point neither APCC not FocusMax are working right and I guess I have to reboot the computer to start from
scratch or try to renumber the serial ports as suggested. But then it seem that Port 6 will just get recreated at
some point.

I hate rebooting the computer remotely and renumbering is not a practical solution.

Can you somehow exclude a port number from use by APCC?


 

Ray is that the recommended settings in APCC for the ASCOM driver as well?

For some reason I thought the ascom check box settings should be reversed from what you show on that graphic


Thanks

Brian

portfolio https://www.brianvalentephotography.com/

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Ray Gralak
Sent: Tuesday, December 31, 2019 8:42 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

Hi Jerome,

Can you somehow exclude a port number from use by APCC?
No, but the ports should stay configured on the Virtual Ports tab if you:

1. Manually delete the first two virtual ports (if they are created, click "Delete" for each), 2. Set the virtual port numbers to the ports you want (e.g. COM21 and COM22).
3. Click "Create" for each port.

Then every time APCC starts those ports will be configured *if* they are available. However, if something else is using one of those ports APCC will choose the lowest available COM port number.

And again, I suggest you follow the settings in the screen shot I sent before and that I am attaching again.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Jerome A Yesavage
Sent: Tuesday, December 31, 2019 8:20 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

I am still having problems with this. If for some reason virtual Port 21 goes away (I am not sure why... maybe not
shut down perfectly by ACP), APCC seems to decide to rereate a new Port 6. Problem is there is already another
USB Port 6 to which my NightCrawler focuser is attached. I guess Port 6 may be seen as the lowest number free
and selected, if the focuser is not turned on, which it is not since I have to start up APCC and the mount first,
before the Nightcrawler, or FocusMax will not see a mount.

At this point neither APCC not FocusMax are working right and I guess I have to reboot the computer to start from
scratch or try to renumber the serial ports as suggested. But then it seem that Port 6 will just get recreated at
some point.

I hate rebooting the computer remotely and renumbering is not a practical solution.

Can you somehow exclude a port number from use by APCC?


Ray Gralak
 

Hi Brian,

Ray is that the recommended settings in APCC for the ASCOM driver as well?
Yes!

Just to be clear, APCC does not actually use the driver for anything. It's the driver that uses APCC.

Although you can connect APCC to the driver all that does is potentially save a little time if all ASCOM client connections to the driver disconnect and reconnect frequently. That's because if APCC is connected to the driver then the driver won't close down if all the ASCOM clients disconnect.

The drawback however is that even when nothing else is connected to the driver is just wasting disk space logging the details because its background polling the mount (which APCC is also doing). So, I prefer to tell people to not enable the option for APCC to connect to the driver.

The other driver option, "Auto-configure", will set the AP V2 driver's COM port to whatever virtual COM port APCC has configured, even if that virtual port just changed. This assures that the driver will always start and connect to the correct virtual port.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Brian Valente
Sent: Tuesday, December 31, 2019 9:12 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

Ray is that the recommended settings in APCC for the ASCOM driver as well?

For some reason I thought the ascom check box settings should be reversed from what you show on that graphic


Thanks

Brian

portfolio https://www.brianvalentephotography.com/

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Ray Gralak
Sent: Tuesday, December 31, 2019 8:42 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

Hi Jerome,

Can you somehow exclude a port number from use by APCC?
No, but the ports should stay configured on the Virtual Ports tab if you:

1. Manually delete the first two virtual ports (if they are created, click "Delete" for each), 2. Set the virtual port
numbers to the ports you want (e.g. COM21 and COM22).
3. Click "Create" for each port.

Then every time APCC starts those ports will be configured *if* they are available. However, if something else is
using one of those ports APCC will choose the lowest available COM port number.

And again, I suggest you follow the settings in the screen shot I sent before and that I am attaching again.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-
physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com Author of Astro-Physics V2 ASCOM Driver:
https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Jerome A Yesavage
Sent: Tuesday, December 31, 2019 8:20 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

I am still having problems with this. If for some reason virtual Port 21 goes away (I am not sure why... maybe not
shut down perfectly by ACP), APCC seems to decide to rereate a new Port 6. Problem is there is already
another
USB Port 6 to which my NightCrawler focuser is attached. I guess Port 6 may be seen as the lowest number
free
and selected, if the focuser is not turned on, which it is not since I have to start up APCC and the mount first,
before the Nightcrawler, or FocusMax will not see a mount.

At this point neither APCC not FocusMax are working right and I guess I have to reboot the computer to start
from
scratch or try to renumber the serial ports as suggested. But then it seem that Port 6 will just get recreated at
some point.

I hate rebooting the computer remotely and renumbering is not a practical solution.

Can you somehow exclude a port number from use by APCC?





Jerome A Yesavage
 
Edited

Hi,

Thanks for all the comments.

I just went and tested this a little and I can delete and create the ports as you suggested and am now back to 20 and 21.  I am not clear why these virtual port "disappear" at some point.

I will have to keep an eye on this and see what happens.  At least I seem to have the area in which the problem arises circumscribed.

To reiterate, when a new port is created from the bottom of the list (Port 6),it is that specific Port which cause me my problem since it is the one the focuser uses when it is turned on... it is not there when it is off since the USB is off too.  This focuser is turned on in the ACP Startup sequence AFTER APCC, since it needs the virtual port to work too. 

I can also use that software to see if I can rename the focuser Port to something safer, like 10. 

I would have tried that but the software gave me a positive in VirusTotal so I had a slight pause there.

I just checked and you can change the port number in device manager advanced settings for that COMM Device.  I rebooted the focuser and it stays at COMM 10.  I reset this to the right number in FocusMax and also ACP and it all seems to work.  Maybe this gives me some insurance.


 

>>> I can also use that software to see if I can rename the focuser Port to something safer, like 10. 

this seems like a good short term strategy, good luck

Brian

On Wed, Jan 1, 2020 at 8:37 AM Jerome A Yesavage <yesavage@...> wrote:
Hi,

Thanks for all the comments.

I just went and tested this a little and I can delete and create the ports as you suggested and am now back to 20 and 21.  I am not clear why these virtual port "disappear" at some point.

I will have to keep an eye on this and see what happens.  At least I seem to have the area in which the problem arises circumscribed.

To reiterate, when a new port is created from the bottom of the list (Port 6),it is that specific Port which cause me my problem since it is the one the focuser uses when it is turned on... it is not there when it is off since the USB is off too.  This focuser is turned on in the ACP Startup sequence AFTER APCC, since it needs the virtual port to work too. 

I can also use that software to see if I can rename the focuser Port to something safer, like 10. 

I would have tried that but the software gave me a positive in VirusTotal so I had a slight pause there.



--
Brian 



Brian Valente


Ray Gralak
 

Hi Jerome,

I just went and tested this a little and I can delete and create the ports as you suggested and am now back to 20
and 21. I am not clear why these virtual port "disappear" at some point.

I will have to keep an eye on this and see what happens. At least I seem to have the area in which the problem
arises circumscribed.
I think I already explained why this could happen. That is, if the port is in use by something else already. Another cause would be that APCC's settings file was deleted/renamed/corrupted. APCC keeps backup settings files that you can use to restore the last good settings if that happens. You can find the backup files in this folder:

C:\ProgramData\Astro-Physics\APCC\Backups

To reiterate, when a new port is created from the bottom of the list (Port 6),it is that specific Port which cause me
my problem since it is the one the focuser uses when it is turned on...
Usually you can change the virtual port number of a device in Windows Device Manager.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Jerome A Yesavage
Sent: Wednesday, January 1, 2020 8:37 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

Hi,

Thanks for all the comments.

I just went and tested this a little and I can delete and create the ports as you suggested and am now back to 20
and 21. I am not clear why these virtual port "disappear" at some point.

I will have to keep an eye on this and see what happens. At least I seem to have the area in which the problem
arises circumscribed.

To reiterate, when a new port is created from the bottom of the list (Port 6),it is that specific Port which cause me
my problem since it is the one the focuser uses when it is turned on... it is not there when it is off since the USB is
off too. This focuser is turned on in the ACP Startup sequence AFTER APCC, since it needs the virtual port to
work too.

I can also use that software to see if I can rename the focuser Port to something safer, like 10.

I would have tried that but the software gave me a positive in VirusTotal so I had a slight pause there.


Jerome A Yesavage
 

So, when I started up last night again the established Virtual Ports vanished and I am back to 6.  The good news is because I put the focuser on 10, the focuser started up alright, but I am curious about what is going on.  I took a screen shot.  Maybe APCC is just recreating the ports anew when it starts up whether or not they are there.  Maybe it is those check boxes in the lower left corner...  I think I have tried all the relevant permutations. 

BTW  There are often timing issues with ACP and APCC.  George and Bob have me wait 30s after powering on the mount before starting APCC.  I also waited 10s before starting Maxim after the CCD is powered on.  I increased that to 20s for good measure since it tries to attach to the mount for guiding. 


Steve Reilly
 

Won’t swear to it but I think AutoConfig should be unchecked. It is on mine and has worked fine forever.

 

-Steve

 

 

From: main@ap-gto.groups.io <main@ap-gto.groups.io> On Behalf Of Jerome A Yesavage
Sent: Thursday, January 2, 2020 10:32 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

 

So, when I started up last night again the established Virtual Ports vanished and I am back to 6.  The good news is because I put the focuser on 10, the focuser started up alright, but I am curious about what is going on.  I took a screen shot.  Maybe APCC is just recreating the ports anew when it starts up whether or not they are there.  Maybe it is those check boxes in the lower left corner...  I think I have tried all the relevant permutations. 

BTW  There are often timing issues with ACP and APCC.  George and Bob have me wait 30s after powering on the mount before starting APCC.  I also waited 10s before starting Maxim after the CCD is powered on.  I increased that to 20s for good measure since it tries to attach to the mount for guiding. 


Ray Gralak
 

Hi Jerome,

So, when I started up last night again the established Virtual Ports vanished and I am back to 6
I cannot reproduce the behavior you are seeing so it might be isolated to your particular computer or Windows system configuration. Your computer must not be saving the configuration or the configuration is getting corrupted or APCC is being "killed" before it can save the configuration. I've seen some people unnecessarily do this to tasks using ACP. If you are doing that... change that now!

BTW There are often timing issues with ACP and APCC.
APCC is written in .Net which requires "just in time" compiling at run-time so it can take a few seconds to build before starting. Then it takes a bit more time to create the virtual ports, connect to the mount, backup the previous settings, query the mount parameters, initialize the user interface, etc.

So, if you have a slow computer it might take some time, but once it is running APCC should run well even on computationally challenged computers. I don't think this should be a problem if your computer takes 15-30 seconds to start APCC and the driver, especially if you start your session before it gets dark... right?

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Jerome A Yesavage
Sent: Thursday, January 2, 2020 7:32 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

So, when I started up last night again the established Virtual Ports vanished and I am back to 6. The good news is
because I put the focuser on 10, the focuser started up alright, but I am curious about what is going on. I took a
screen shot. Maybe APCC is just recreating the ports anew when it starts up whether or not they are there.
Maybe it is those check boxes in the lower left corner... I think I have tried all the relevant permutations.

BTW There are often timing issues with ACP and APCC. George and Bob have me wait 30s after powering on
the mount before starting APCC. I also waited 10s before starting Maxim after the CCD is powered on. I
increased that to 20s for good measure since it tries to attach to the mount for guiding.


Jerome A Yesavage
 

Ray,

Perhaps ACP is not shutting down perfectly cleanly.  It is, however, right at the top of the shutdown script. 

I will give this added attention and watch it. 

I have the startup delays at 30s, with a second delay of 20s after Maxim starts, before the system connects to FocusMax. 

It goes:

PowerOn-delay30s->APCC delay20s-> Maxim (same AP driver) ->FocusMax (was ACP Telescope Hub (ASCOM))  

Both Maxim and FocusMax use the mount.  I noticed that FM was using an ACP driver?  I changed this to the AP driver... maybe this was an issue. 

I'll monitor this carefully and see if I can get a consistent picture. 


eckhard.voelcker@...
 

I just had the same or a similar problem.

The virtual ports in APCC were Com20, Com21 and Com22. The ASCOM Driver is configured to use Com20. Yesterday the ASCOM driver could not connect to APCC. The driver configuration showed Com20 but the APCC configuration showed no virtual port. Com20, Com21, and Com 22 were not listed in the dropdown box where you set the virtual ports so I could not set these anymore. 

The Devicemanager showed under COM / LPT three virtual com ports (20, 21 and 22). These ports were being installed independently of APCC as these appeared after a reboot without starting APCC. I used the Devicemanager to uninstall these virtual com ports. Afterwards APCC would see these ports as being available again and I could select Com20, Com21 and Com22 as virtual ports. The ASCOM driver connects and is happy again.

It looks as if some Windows or another install routine has seen these ports and decided to install a permanent driver / setting for those ports (I use an external USB hub). So  APCC is seeing Com20, 21 and 22 as already taked ("in use") and thus the error.

Maybe you have a similar issue, Jerome. 

Best,
Eckhard


Jerome A Yesavage
 

I think I have moved this a long way down the field. 

First, the start-up side of the problem is primarily due to my upgrade from W7 to W10 and the fact that ACP needs to have a command line instruction run to open a particular port.  There was an error thrown in the ACP log... I reread it carefully and found the error and Bob's solution.  My BAD. 

Second, on the port and repeated start-up with new ports.  Yesterday I spent the afternoon running the startup and shutdown scripts in ACP (separate from ExpertScheduler).  What I discovered is that the AP V2 driver is not shut down by the shutdown script, though the other software and drivers are.  There is js code and a routine to do this.  Looking more closely I found that in the Task Manager the driver is suspended with this notice: "This UWP process group is suspending processes to improve system performance".  You cannot shut this down with a powershell taskkill but you can kill it in the Task Manager. 

I think that if this driver is still running when APCC restarts, you get the additional ports... guess if it shuts down clean the ports become available for further use, but if you try to run APCC when the previous version is still running, you get new ports. 

I tested shutting it down in the task manager and restarting APCC and had no problems.

Further along, I noticed that if I did nothing for 5 minutes the AP driver vanished... I guess you can remain dormant only so long before W10 kills you... or maybe this is built into the driver.  In any case it vanishes, along with the residual port problem. 

When you test the startup and shutdown scripts one closely following the other, the AP drive does not appear to have time to did a natural death at the hands of W10 or whatever.

I am going to monitor this now and will report back if there are any other problems. 

Thanks to Ray and Steve for the support on this...and I will cross-post over at the ACP forum so people do not chase their tails there. 


Ray Gralak
 

Jerome,

I think that if this driver is still running when APCC restarts, you get the additional ports... guess if it shuts down
clean the ports become available for further use, but if you try to run APCC when the previous version is still
running, you get new ports.
The driver should not be left hanging like that. ACP or one of the other applications you are running is not disconnecting from the driver. Solve that problem and everything should be fine.

Make sure you UNCHECK Auto-connect in the AP V2 Driver section of APCC. This will prevent APCC from opening the driver and hanging on to it.

Lastly, make sure you have APCC Auto-shutdown configured in APCC's Advanced Settings. If you don't then APCC won't shutdown.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Jerome A Yesavage
Sent: Sunday, January 5, 2020 9:43 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

I think I have moved this a long way down the field.

First, the start-up side of the problem is primarily due to my upgrade from W7 to W10 and the fact that ACP needs
to have a command line instruction run to open a particular port. There was an error thrown in the ACP log... I
reread it carefully and found the error and Bob's solution. My BAD.

Second, on the port and repeated start-up with new ports. Yesterday I spent the afternoon running the startup and
shutdown scripts in ACP (separate from ExpertScheduler). What I discovered is that the AP V2 driver is not shut
down by the shutdown script, though the other software and drivers are. There is js code and a routine to do this.
Looking more closely I found that in the Task Manager the driver is suspended with this notice: "This UWP process
group is suspending processes to improve system performance". You cannot shut this down with a powershell
taskkill but you can kill it in the Task Manager.

I think that if this driver is still running when APCC restarts, you get the additional ports... guess if it shuts down
clean the ports become available for further use, but if you try to run APCC when the previous version is still
running, you get new ports.

I tested shutting it down in the task manager and restarting APCC and had no problems.

Further along, I noticed that if I did nothing for 5 minutes the AP driver vanished... I guess you can remain dormant
only so long before W10 kills you... or maybe this is built into the driver. In any case it vanishes, along with the
residual port problem.

When you test the startup and shutdown scripts one closely following the other, the AP drive does not appear to
have time to did a natural death at the hands of W10 or whatever.

I am going to monitor this now and will report back if there are any other problems.

Thanks to Ray and Steve for the support on this...and I will cross-post over at the ACP forum so people do not
chase their tails there.


Roland Christen
 

Excellent hunting!

Rolando



-----Original Message-----
From: Jerome A Yesavage <yesavage@...>
To: main <main@ap-gto.groups.io>
Sent: Sun, Jan 5, 2020 11:43 am
Subject: Re: [ap-gto] Cannot Seem to Keep the Same Virtual Ports

I think I have moved this a long way down the field. 

First, the start-up side of the problem is primarily due to my upgrade from W7 to W10 and the fact that ACP needs to have a command line instruction run to open a particular port.  There was an error thrown in the ACP log... I reread it carefully and found the error and Bob's solution.  My BAD. 

Second, on the port and repeated start-up with new ports.  Yesterday I spent the afternoon running the startup and shutdown scripts in ACP (separate from ExpertScheduler).  What I discovered is that the AP V2 driver is not shut down by the shutdown script, though the other software and drivers are.  There is js code and a routine to do this.  Looking more closely I found that in the Task Manager the driver is suspended with this notice: "This UWP process group is suspending processes to improve system performance".  You cannot shut this down with a powershell taskkill but you can kill it in the Task Manager. 

I think that if this driver is still running when APCC restarts, you get the additional ports... guess if it shuts down clean the ports become available for further use, but if you try to run APCC when the previous version is still running, you get new ports. 

I tested shutting it down in the task manager and restarting APCC and had no problems.

Further along, I noticed that if I did nothing for 5 minutes the AP driver vanished... I guess you can remain dormant only so long before W10 kills you... or maybe this is built into the driver.  In any case it vanishes, along with the residual port problem. 

When you test the startup and shutdown scripts one closely following the other, the AP drive does not appear to have time to did a natural death at the hands of W10 or whatever.

I am going to monitor this now and will report back if there are any other problems. 

Thanks to Ray and Steve for the support on this...and I will cross-post over at the ACP forum so people do not chase their tails there.