Ascom 6 / Saving Elevation setting: Weird behavior


Rodolphe G.
 

Hello

I'm really new to this group, so please pardon my ignorance if this topic has already been addressed (I did search the forum before posting).

I was fortunate enough to acquire a second hand Mach1 + CP4 lately, and I'm absolutely delighted by the mount .


I face a small issue with the ASCOM driver (using the latest version: 5.20.09, firmware VCP4-P01-13), though:

  1. If I set the elevation in the ASCOM driver (645 m in my case), close the driver, then reload it, it then shows 6450 m
  2. if I close the driver, not changing anything, then reopen it, then it displays 64500m
  3. If I do 2. again, then I get an error, Elevation field highlighted.
Am I doing anything wrong?

My setup, just in case there could be an influence:
Running Win10, EN-US version, located in Switzerland.
Locale settings: 
  • Country: Switzerland
  • Regional format: English (Switzerland)
  • Decimal symbol: "," (comma) -- this is the standard format
Thanks in advance for any suggestion/help.

Regards
Rodolphe


Ray Gralak
 

* Country: Switzerland
* Regional format: English (Switzerland)
* Decimal symbol: "," (comma) -- this is the standard format
Are you entering the elevation as "645,0"? If so try reentering the elevation without a comma.

If that doesn't help then if you change the Decimal symbol to "." does the problem go away? If so, it could be a bug in the way Windows wants to interpret a value in your regional setting. Maybe try using Windows update to make sure you have the latest updates.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: ap-gto@yahoogroups.com [mailto:ap-gto@yahoogroups.com]
Sent: Sunday, August 18, 2019 2:30 AM
To: ap-gto@yahoogroups.com
Subject: [ap-gto] Ascom 6 / Saving Elevation setting: Weird behavior



Hello

I'm really new to this group, so please pardon my ignorance if this topic has already been addressed (I did search
the forum before posting).

I was fortunate enough to acquire a second hand Mach1 + CP4 lately, and I'm absolutely delighted by the mount
<https://s.yimg.com/ok/u/assets/img/emoticons/emo1.gif> .




I face a small issue with the ASCOM driver (using the latest version: 5.20.09, firmware VCP4-P01-13), though:

1. If I set the elevation in the ASCOM driver (645 m in my case), close the driver, then reload it, it then shows
6450 m
2. if I close the driver, not changing anything, then reopen it, then it displays 64500m
3. If I do 2. again, then I get an error, Elevation field highlighted.

Am I doing anything wrong?

My setup, just in case there could be an influence:
Running Win10, EN-US ver sion, located in Switzerland.
Locale settings:

* Country: Switzerland
* Regional format: English (Switzerland)
* Decimal symbol: "," (comma) -- this is the standard format

Thanks in advance for any suggestion/help.

Regards
Rodolphe


Rodolphe G.
 

Hi Ray
Thanks for the suggestion.
I already tried 645,0 and it didn't work either.
But will try changing the locale settings.
I'm on the latest w10 release.
I'll report here about the results.
Thanks


Rodolphe G.
 

Forgot to mention that I actually tried 645 and 645,0.
Both variations fail.


Ray Gralak
 

Forgot to mention that I actually tried 645 and 645,0.
Both variations fail.
Did you have a chance to try the other two suggestions I made? That is:

1. Changing the Decimal symbol to "." in Windows regional settings.
2. Using Windows update to make sure you have the latest updates.

BTW, which version of Windows 10 are you using? You can find out by typing "winver" from the Windows 10 search box.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: ap-gto@yahoogroups.com [mailto:ap-gto@yahoogroups.com]
Sent: Sunday, August 18, 2019 11:56 PM
To: ap-gto@yahoogroups.com
Subject: [ap-gto] Re: Ascom 6 / Saving Elevation setting: Weird behavior



Forgot to mention that I actually tried 645 and 645,0.
Both variations fail.


Rodolphe G.
 

Okay.

I found a "smart" workaround but using the bug to my benefit: I enter 65, save location, and it turns into 650, which is fine ;)

The value no longer changes (as I don't have to save the location any further).

To your question, Winver:
  • Version 1903 (OS Build 18362.295)
I tried reinstalling the ASCOM version (standard, not the EU specific one), same issue.

Hope it helps.