Inconsistent results with APPM Tracking Model


marco cosmacini
 

Dear all ,

after several tests and several pointing models done with inconsistent results with encoders, I decided to make new tests thanks to the new APCC version just released and the good weather of these days.

Just as a brief note, I would like to underline that the latest release is again a BETA. Ray, when are you going to release a public version? The latest public is dated July 2017, nearly two years ago! I would expect a public release once per year, it is not so much easy to always see if there is a new beta in this group.

I have nothing against the beta versions, but the way that they are difficult to find: please decide to publish also the Beta versions of AP website. 

I also use the new ascom driver just released.


NOW the important point:I have made some tests using the encoders ON and OFF and the tracking model ON and OFF (as a result of a model of 350 points with APPM). This is the 7th pointing model I do over some months, and I had always the same results.


The results are seen in the image attached. Basically the encoders works fine ONLY if the tracking model is OFF. The tracking model degrades the tracking both when encoders are ON or OFF.


The image is available at this dropbox link:

https://www.dropbox.com/s/3ydk3kwqo51m8z2/Test%20with%20Encoders%20and%20APPM%20Tracking%20Model.jpg?dl=0


Ray, I would like especially a your feedback, why do you think I have these results??


Thanks and regards


Marco

Italy


Ray Gralak
 

Hi Marco,

after several tests and several pointing models done with inconsistent results with
encoders, I decided to make new
tests thanks to the new APCC version just released and the good
weather of these days.
I don't recall your setup so what image scale and type of telescope are you using? The feedback from some others has been that unguided tracking has been very good in the latest 1.7.0.x betas, but image scale and telescope type matters. Thus, the unguided tracking performance you will get depend will depend very much on your setup, including how consistent pointing is, and how well the data collected fits the model.

BTW, did you look at your pointing model and exclude any outliers from the model? This can dramatically improve tracking. You can do that with the latest 1.7 release. Also, there are some interesting new graphs that you can look at to determine potential problems.

So, I think the best way to move forward is for us to get your logs and we'll do some analysis offline. We will need all details about your setup including your telescope model, camera(s), the software you are using, and if possible a picture of your setup to see if there might be anything like cabling causing a potential problem.

You can use the APCC log zipper to bundle all your log and settings files, including PNT files. I see you are using drop box so please provide a link to the zip file and your setup details. You can either post publicly or email the details and link privately (recommended) to GROUPS3 at GRALAK dot COM and HOWARD at ASTRO-PHYSICS dot COM.

I have nothing against the beta versions, but the way that they are difficult to find:
please decide to publish also the Beta versions of AP website.
I don't have access to the AP web site so the only place to publish links is this forum. I think AP may be planning some changes to their web site so that might change.

The latest public is dated July 2017, nearly two years ago!
There are a couple reasons for this. One reason is that I needed to finish PEMPro V3 so I was focused on that for many months. Also, I have been spending a lot of my free time answering public posts and private emails which eats into the time I can spend developing the software.

BTW, Astro-Physics also has not been charging the annual subscription for APCC despite that there have been a number of beta releases with new features last year and this year.

Just as a brief note, I would like to underline that the latest release is again a BETA.
Ray, when are you going to release a public version?
It's up to Astro-Physics when APCC will 1.7.x be officially released. However, since I rewrote some of the modeling logic for 1.7 there have been some issues with pointing accuracy that I have been trying to fix. Unfortunately the weather has not been cooperating. I haven't been able to test much with the unusually rainy and cloudy weather my area has had this winter. At least for this week the weather pattern is supposed to change so I think it should be clear enough for me to resume outdoor testing.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: ap-gto@yahoogroups.com [mailto:ap-gto@yahoogroups.com]
Sent: Monday, February 18, 2019 6:12 AM
To: ap-gto@yahoogroups.com
Subject: [ap-gto] Inconsistent results with APPM Tracking Model



Dear all ,

after several tests and several pointing models done with inconsistent results with encoders, I decided to make new
tests thanks to the new APCC version just released and the good weather of these days.

Just as a brief note, I would like to underline that the latest release is again a BETA. Ray, when are you going to
release a public version? The latest public is dated July 2017, nearly two years ago! I would expect a public release
once per year, it is not so much easy to always see if there is a new beta in this group.

I have nothing against the beta versions, but the way that they are difficult to find: please decide to publish also the
Beta versions of AP website.

I also use the new ascom driver just released.




NOW the important point:I have made some tests using the encoders ON and OFF and the tracking model ON and
OFF (as a result of a model of 350 points with APPM). This is the 7th pointing model I do over some months, and I
had always the same results.




The results are seen in the image attached. Basically the encoders works fine ONLY if the tracking model is OFF.
The tracking model degrades the tracking both when encoders are ON or OFF.




The image is available at this dropbox link:

https://www.dropbox.com/s/3ydk3kwqo51m8z2/Test%20with%20Encoders%20and%20APPM%20Tracking%20Mo
del.jpg?dl=0




Ray, I would like especially a your feedback, why do you think I have these results??




Thanks and regards




Marco

Italy


Joe Zeglinski
 

Hi Ray,
 
    You wrote:
“Unfortunately the weather has not been cooperating. I haven't been able to test much with the unusually rainy and cloudy weather my area has had this winter. “
 
    I don’t understand the problem – I thought you could use just about any remote observatory, (as a guest), to run APCC BETA tests. One such (company) site  might be in Hawaii – or  another in Chile. While we don’t want to risk “burning you out” by adding to your already far too highly intensive workload, at least a couple of worldwide east/west remotes might offer more daily, (or daytime),  opportunities and ease your test schedule.
 
    We all very much appreciate the work you do for us, and for your dedication to improving this hobby with your products, your skills & knowledge.
 
Joe Z.


Ray Gralak
 

Hi Joe,

I don’t understand the problem – I thought you could use just about any remote observatory,
(as a guest), to run APCC BETA tests.
I wish it were that simple, First, I do not have access to any other setups with Astro-Physics mounts besides my own. Plus, usually testing is not always just running APCC. I would need to install and run Microsoft Visual Studio and APCC source files on a remote computer that I don't own. I wouldn't feel comfortable with that, and I doubt AP would either. Also, some of the third party components and tools that I use have licensing restrictions that would not allow me to install them on a computer I don't own.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: ap-gto@yahoogroups.com [mailto:ap-gto@yahoogroups.com]
Sent: Monday, February 18, 2019 9:19 AM
To: ap-gto@yahoogroups.com
Subject: Re: [ap-gto] Inconsistent results with APPM Tracking Model



Hi Ray,

You wrote:
“Unfortunately the weather has not been cooperating. I haven't been able to test much with the unusually rainy and
cloudy weather my area has had this winter. “

I don’t understand the problem – I thought you could use just about any remote observatory, (as a guest), to run
APCC BETA tests. One such (company) site might be in Hawaii – or another in Chile. While we don’t want to risk
“burning you out” by adding to your already far too highly intensive workload, at least a couple of worldwide
east/west remotes might offer more daily, (or daytime), opportunities and ease your test schedule.

We all very much appreciate the work you do for us, and for your dedication to improving this hobby with your
products, your skills & knowledge.

Joe Z.


Craig Young
 

Hi Marco,

I can confirm I also, over the last several months, do have tracking issues when using APPM corrections.  My plate scale is 0.57 arc-sec/pixel with absolute encoders, so the system is a bit sensitive to both mechanical and atmospheric changes during the tracking period.

Ray and I have been working together for months now and he has made some very significant progress in addressing issues in APCC that caused both tracking and pointing issues.  But there do remain some more and I know Ray is working to resolve them.

I ended up writing my own program that adjusts the tracking rate based on real time analysis of light frames.  In other words, I use no guider, no model and no refraction correction.  The result is I get sub arc-second tracking (rms) and pointing over several hours.  This testifies to the quality of the hardware and sets the target for APCC once Ray has fixed the code.

But also, no matter how good the model is and APCC is fixed, tracking and pointing will never be perfect.  At this plate scale and given the complexity of the hardware and seeing conditions always changing, there will always be some need for real time corrections, whether using a guider or an adaptive system such as the one I wrote.  The tracking and pointing systems of large professional systems cost hundreds of thousands of dollars and requires a ton of equipment (literally) and experienced technicians running that telescope.  As amateurs we are a long ways from that.  In fact, I am actually very impressed with software like APCC and the Astro-Physics hardware at what we can achieve, given the real time issues we face.

Hang in there, Ray is making great progress, and you are not alone.  Feel free to work with us on the forum, especially spotting things on your system that are related to these issues, that can help all of us and especially Ray.  APCC and the AP mounts are excellent, but very complex.

Craig


marco cosmacini
 

Hello Craig,

first thank you for your feedback . Compliments for the real time adaptive system you have built, I would love a such system.

I understand the complexity of these things and the fact that here we are all speaking about amateur astronomy and not professional astronomy but on the other hand I think that AP is not the only working with absolute encoders and this technology is followed also by other companies with good results.


I started my test with my prime setup which gives 1.07 arcsec/pixel and I did not have good results (maybe also because I was using APCC 1.6.x) 

So now I have done the model and the image tests with the second scope, a AP130GTX at 2.13 arcsec/pixel  (873mm focal lenght, pixel of 9 micron).


Honestly I think that this setup is fair to test the AE and if all works properly, this resolution can be well managed by the encoders.


Anyway I have re-done my tests this evening because the situation seems to be not easy as in my first message. From what I see now, after all the tests, the quality of the tracking changes if I point in the East part of the sky (before meridian) or west part (after meridian).

Basically in the east part, pinpoint stars are achieved with Encoders ON and Rate correction ON; in west part pinpoint are achieved always with Encoders ON but rate correction OFF.


that's really strange to me, especially on west where the scope prefers the rate correction OFF to have pinpoint stars (and yesterday I made some 20min pictures...) . I am preparing the photos and the descriptions to submit tomorrow to Ray by email and then we will see.


BTW: I am a AP lover since 25 years so no way to consider other mounts or scopes :-) , so I am more than happy to help if I can


Marco




marco cosmacini
 

Hi Ray,

I am preparing all details for you. Yu will have tomorrow at the email you gave me


Marco


Ray Gralak
 

Hi Marco,

Have you tried looking at the data points and filtering any outliers?

To do so, on APCC's Pointing Model tab, click "Model...".

Then, look for the "Exclude points with RA greater than..." and "Exclude points with Dec greater than..." and enter maybe 60.00 (arc-sec) for both and enable both by clicking their checkboxes.

If the Max error or RMS error becomes much smaller then it is likely the tracking rate modeling will work better.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver

-----Original Message-----
From: ap-gto@yahoogroups.com [mailto:ap-gto@yahoogroups.com]
Sent: Monday, February 18, 2019 2:23 PM
To: ap-gto@yahoogroups.com
Subject: RE: [ap-gto] Inconsistent results with APPM Tracking Model



Hi Ray,

I am preparing all details for you. Yu will have tomorrow at the email you gave me




Marco



Craig Young
 

My adaptive tracking program logs all the tracking corrections each night so I can analyze it the next day using a spreadsheet program.  And indeed, I also see a difference in tracking rates depending on whether I am on the East side or West side of the sky.  RA shows the largest variance with DEC showing only a small difference.  I have not done any thorough analysis of why this is, but hope to do so in the coming months.  It is consistent though across nights, enough so that I can predict the tracking correction values for a given hour angle.

Craig


marco cosmacini
 

Hi Ray,

I am going to send you an email with all answers today. then we can see which is the next step to do.

thanks

marco 


Ray Gralak
 

Hi Marco,

I am going to send you an email with all answers today. then we can see which is the next step to do.
Ok, thanks!

-Ray Gralak
Author of APCC (Astro-Physics Command Center): http://www.astro-physics.com/index.htm?products/accessories/software/apcc/apcc
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: ap-gto@yahoogroups.com [mailto:ap-gto@yahoogroups.com]
Sent: Tuesday, February 19, 2019 3:25 AM
To: ap-gto@yahoogroups.com
Subject: RE: [ap-gto] Inconsistent results with APPM Tracking Model



Hi Ray,

I am going to send you an email with all answers today. then we can see which is the next step to do.

thanks

marco