ASCOM/ACP interface set offline...


C. G. Anderson
 

Hello again!


I tried to find the proper tech forum for this ACSCOM AP v2 5.09.01 error, and all signs point here.  So here goes. (If there is a better forum, please direct me there!). Maybe this is purely an ASCOM or Digital Dome Works problem rather than with the AP V2 driver. Don't know yet...


I am currently using Technical Innovations/Homedome Digital Dome Works (v.5.2) to slave my dome rotation to my AP900 mount. Some hiccups notwithstanding, so far so good. However, I have encountered a problem with DDW and the interface it uses to communicate with the mount, ASCOM Astrophysics V2 5.09.01. Here's what happens...


When I initiate DDW, it invokes the AP V2 5.09.01 driver window. All the fields populate (I presume) with data from the mount. All the buttons on the AP driver (NSEW, etc) work fine. I can slave the dome to anywhere the mount is slewed (via keypad) to. All is good. 


However, after consistently slaving the scope for, say, four or five hours, I get an error in DDW:


ASCOM/.ACP interface set offline


https://goo.gl/photos/xM7p9Z1DyLLYhj3H7


and DDW reports operation failed, which I think means DDW could not slave the dome because it no longer is receiving a data stream from the mount. Further, the RA and DEC fields of the AP V2 drive are rendered blank, although all other fields are present. The TIME, however, seems to "freeze" at the moment the failure occurs. 


The only way to recover from this is to end and restart DDW, thus reinvoking the AP V2 driver. 


Technical Innovations is looking into this as I write, but I thought I'd post it here, too. I Googled the error and didn't come up with anything similar. For some reason, somewhere along the line, the handshake between ASCOM and DDW is being broken. There is no timeout as far as I know. 


If there is a place in the ASCOM driver set to check for errors, I am not sure where they would be. Everything is up to date also.


Any suggestions would be greatly appreciated!


Chris


Steve Reilly
 

Chris,

 

Are you using ACP in the mix? That’s what it looks like with ASCOM/.ACP interface set offline. If I saw this and was using ACP I would make sure ACP is still connected to the telescope driver. Just a guess.

 

Steve

 

 

From: ap-gto@... [mailto:ap-gto@...]
Sent: Tuesday, September 13, 2016 7:02 PM
To: ap-gto@...
Subject: [ap-gto] ASCOM/ACP interface set offline...

 

 

Hello again!

 

I tried to find the proper tech forum for this ACSCOM AP v2 5.09.01 error, and all signs point here.  So here goes. (If there is a better forum, please direct me there!). Maybe this is purely an ASCOM or Digital Dome Works problem rather than with the AP V2 driver. Don't know yet...

 

I am currently using Technical Innovations/Homedome Digital Dome Works (v.5.2) to slave my dome rotation to my AP900 mount. Some hiccups notwithstanding, so far so good. However, I have encountered a problem with DDW and the interface it uses to communicate with the mount, ASCOM Astrophysics V2 5.09.01. Here's what happens...

 

When I initiate DDW, it invokes the AP V2 5.09.01 driver window. All the fields populate (I presume) with data from the mount. All the buttons on the AP driver (NSEW, etc) work fine. I can slave the dome to anywhere the mount is slewed (via keypad) to. All is good. 

 

However, after consistently slaving the scope for, say, four or five hours, I get an error in DDW:

 

ASCOM/.ACP interface set offline

 

https://goo.gl/photos/xM7p9Z1DyLLYhj3H7

 

and DDW reports operation failed, which I think means DDW could not slave the dome because it no longer is receiving a data stream from the mount. Further, the RA and DEC fields of the AP V2 drive are rendered blank, although all other fields are present. The TIME, however, seems to "freeze" at the moment the failure occurs. 

 

The only way to recover from this is to end and restart DDW, thus reinvoking the AP V2 driver. 

 

Technical Innovations is looking into this as I write, but I thought I'd post it here, too. I Googled the error and didn't come up with anything similar. For some reason, somewhere along the line, the handshake between ASCOM and DDW is being broken. There is no timeout as far as I know. 



If there is a place in the ASCOM driver set to check for errors, I am not sure where they would be. Everything is up to date also.



Any suggestions would be greatly appreciated!



Chris


Steve Reilly
 

Chris,

 

Are you using ACP in the mix? That’s what it looks like with ASCOM/.ACP interface set offline. If I saw this and was using ACP I would make sure ACP is still connected to the telescope driver. Just a guess.

 

Steve


Steve Reilly
 

Certainly sounds like you lost communications with the driver. What other programs are being used and how do you connect to the scope, direct serial port connection or USB to Serial convertor….

 

Steve

 

 

From: ap-gto@... [mailto:ap-gto@...]
Sent: Tuesday, September 13, 2016 7:02 PM
To: ap-gto@...
Subject: [ap-gto] ASCOM/ACP interface set offline...

 

 

Hello again!

 

I tried to find the proper tech forum for this ACSCOM AP v2 5.09.01 error, and all signs point here.  So here goes. (If there is a better forum, please direct me there!). Maybe this is purely an ASCOM or Digital Dome Works problem rather than with the AP V2 driver. Don't know yet...

 

I am currently using Technical Innovations/Homedome Digital Dome Works (v.5.2) to slave my dome rotation to my AP900 mount. Some hiccups notwithstanding, so far so good. However, I have encountered a problem with DDW and the interface it uses to communicate with the mount, ASCOM Astrophysics V2 5.09.01. Here's what happens...

 

When I initiate DDW, it invokes the AP V2 5.09.01 driver window. All the fields populate (I presume) with data from the mount. All the buttons on the AP driver (NSEW, etc) work fine. I can slave the dome to anywhere the mount is slewed (via keypad) to. All is good. 

 

However, after consistently slaving the scope for, say, four or five hours, I get an error in DDW:

 

ASCOM/.ACP interface set offline

 

https://goo.gl/photos/xM7p9Z1DyLLYhj3H7

 

and DDW reports operation failed, which I think means DDW could not slave the dome because it no longer is receiving a data stream from the mount. Further, the RA and DEC fields of the AP V2 drive are rendered blank, although all other fields are present. The TIME, however, seems to "freeze" at the moment the failure occurs. 

 

The only way to recover from this is to end and restart DDW, thus reinvoking the AP V2 driver. 

 

Technical Innovations is looking into this as I write, but I thought I'd post it here, too. I Googled the error and didn't come up with anything similar. For some reason, somewhere along the line, the handshake between ASCOM and DDW is being broken. There is no timeout as far as I know. 



If there is a place in the ASCOM driver set to check for errors, I am not sure where they would be. Everything is up to date also.



Any suggestions would be greatly appreciated!



Chris


Steve Reilly
 

Certainly sounds like you lost communications with the driver. What other programs are being used and how do you connect to the scope, direct serial port connection or USB to Serial convertor….

 

Steve


C. G. Anderson
 

Steve, I am NOT using ACP. I must admit, up until Googling it, wasn't sure what ACP was....!  CG


C. G. Anderson
 

Programs?  Well, just Google browser in the background, and Digital Dome Works, plus Windows. 

I am using a USB connection from the CP4 to a Icron Ethernet "hub" then direct USB back into my computer. This has worked very well with the AP CP4 and my SBIG STT-8300/FW8G/Atlas focuser. So if that is an issue, it doesn't seem to manifest in any other the other systems. 

Curiously, my tests of the dome slave setup today running for about seven hours did not produce the same fault, so I guess it is random now....  I really expected that it would happen again. I am doing another test run tomorrow to try and capture another error. CG