Date   

Re: PlateSolve2 vs. TheSkyX Image Link for APPM Point Mapping

Dean Jacobsen
 

So, an update.

After starting over as per Ray's SGP/PlateSolve2 tutorial, I have it working again and have been enjoying the goodness of imaging without a guide scope.

The Mach2 is working perfectly.

I did try to get TheSkyX working as my plate solver first and kept getting a message about not being able to start an ActiveX element or session or whatever.  I will take a screen shot of the error message next time I go out in a few days.
--
Dean Jacobsen
http://astrophoto.net/wp/
Image Gallery - http://astrophoto.net/wp/image-gallery/
Astrobin - https://www.astrobin.com/users/deanjacobsen/ 


Re: Changing Keypad battery

George
 

Geoff,

 

Please reference our Tech Support page.

https://astro-physics.info/tech_support/mounts/keypad/keypad-maintenance-instructions.pdf

 

Regards,

 

George

 

George Whitney

Astro-Physics, Inc.

Phone:  815-222-6538 (direct line)

Phone:  815-282-1513 (office)

Email:  george@...

 

From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Geoff Smith
Sent: Thursday, July 16, 2020 8:32 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] Changing Keypad battery

 

This is probably going to be a "doh" moment, but I am puzzled by the following line on P11 of the keypad maintenance manual

"Unplug the lithium battery connector. Note the Real Time Clock (RTC ) Module. This is NOT the battery!! Do NOT attempt
to remove this! (See photo top of following page)"

What is the lithium battery connector and how do I unplug it?
Geoff


Re: Issue with starting ASCOM driver from SGP #ASCOM_V2_Driver

Ray Gralak
 

Hi Paul,

The issue is repeatable i.e. it happens every time I try to connect from SGP.
1. Make sure that you are not starting APCC "as Administrator". You do not need to run APCC with admin privileges.
2. Make sure that you are not starting SGP "as administrator". That will start a second instance of the driver when SGP connects to the AP V2 driver.
3. Enable the "Auto-Config" option in the "AP V2 Driver" group box in APCC. This will always reconfigure the AP V2 driver even if APCC's virtual com ports change.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of DiscoDuck
Sent: Thursday, July 16, 2020 9:10 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] Issue with starting ASCOM driver from SGP #ASCOM_V2_Driver

This may well be an SGP issue, but let me ask here just in case anyone has seen this ... or hopefully Ray might
have some insight.

I have an issue where
- I start APCC and connect it to the mount and initialise the mount
- I start SGP
- I click on connect to mount in SGP

Normally, this fires up the AP ASCOM driver, which connects to APCC (virtual com port) and all is good. However,
it now brings up the ASCOM driver with "default values" and you can see it flashing while trying to connect to
APCC and then eventually fails and the ASCOM driver disappears and I get an error message from SGP that the
mount failed to connect. It has previously worked fine [though I have had this issue before and it went away when
I reinstalled the ASCOM driver. Could do that again now, but thought since it has resurfaced it is worth asking]

The issue is repeatable i.e. it happens every time I try to connect from SGP.

Current workaround is to connect to the ASCOM driver from APCC. Then when I click connect from SGP it simply
connects to the (already running and initialised) ASCOM driver and all is good.

Ideas/comments appreciated.
Thanks,
Paul


Re: Changing Keypad battery

Geoff Smith
 

Thanks Konstantin. That figures.
I’ll look into doing that.


Re: Changing Keypad battery

Konstantin von Poschinger
 

Hi,

You have to reload the database.

Grüsse

Konstantin v. Poschinger


Hammerichstr. 5
22605 Hamburg
040/8805747
0171/1983476

Am 17.07.2020 um 09:05 schrieb Geoff Smith <ghsmith45@...>:

Ok, I misread one of the later instructions and thought there were two battery connectors that had to be removed. 
I installed a new battery, but the data base refuses to point properly, so I still have a problem.


Re: Changing Keypad battery

Geoff Smith
 

Ok, I misread one of the later instructions and thought there were two battery connectors that had to be removed. 
I installed a new battery, but the data base refuses to point properly, so I still have a problem.


Re: Issue with starting ASCOM driver from SGP #ASCOM_V2_Driver

DiscoDuck
 

Thanks. My understanding is that APCC talks directly to the mount, and the ASCOM driver sits above APCC and the apps (SGP) talk to that. I haven't got APCC configured to auto-start the driver (I think you can). But it is odd that starting it from SGP used to work and now doesn't. Thanks for your comments though.


Re: Issue with starting ASCOM driver from SGP #ASCOM_V2_Driver

Worsel
 

Paul

When I start up APCC the driver ALWAYS starts automatically...I think the driver MUST start to connect to the mount.  I never have to start the driver on its own. I am unsure why this does not seem to happen for your config.  Ray Gralak likely has more insight.

Bryan


Re: Changing Keypad battery

Geoff Smith
 

So is the lithium battery connector just the white plug with the blue and yellow wires? 


Issue with starting ASCOM driver from SGP #ASCOM_V2_Driver

DiscoDuck
 

This may well be an SGP issue, but let me ask here just in case anyone has seen this ... or hopefully Ray might have some insight.

I have an issue where
- I start APCC and connect it to the mount and initialise the mount
- I start SGP
- I click on connect to mount in SGP

Normally, this fires up the AP ASCOM driver, which connects to APCC (virtual com port) and all is good. However, it now brings up the ASCOM driver with "default values" and you can see it flashing while trying to connect to APCC and then eventually fails and the ASCOM driver disappears and I get an error message from SGP that the mount failed to connect. It has previously worked fine [though I have had this issue before and it went away when I reinstalled the ASCOM driver. Could do that again now, but thought since it has resurfaced it is worth asking]

The issue is repeatable i.e. it happens every time I try to connect from SGP.

Current workaround is to connect to the ASCOM driver from APCC. Then when I click connect from SGP it simply connects to the (already running and initialised) ASCOM driver and all is good.

Ideas/comments appreciated.
Thanks,
Paul


Re: Changing Keypad battery

Mike Dodd
 

On 7/16/2020 9:32 PM, Geoff Smith wrote:
What is the lithium battery connector and how do I unplug it?
The attached photo shows the coin cell and where the wires plug into the box.

--- Mike


Changing Keypad battery

Geoff Smith
 

This is probably going to be a "doh" moment, but I am puzzled by the following line on P11 of the keypad maintenance manual

"Unplug the lithium battery connector. Note the Real Time Clock (RTC ) Module. This is NOT the battery!! Do NOT attempt
to remove this! (See photo top of following page)"

What is the lithium battery connector and how do I unplug it?
Geoff


Re: [ap-ug] RS-232

Ray Gralak
 

Hi Peter,

Are you saying that I have compromised Windows 10 performance by running it in Parallels on my Mac OS?
Would Windows operate more fully on a real PC?
It's not a performance issue. It's a compatibility issue.

You will not be able to use some USB devices on a Mac with Parallels that you would be able to use with Fusion. That's because Fusion supposedly does a better job virtualizing Windows USB devices.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Peter Natscher
Sent: Thursday, July 16, 2020 1:05 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] [ap-ug] RS-232

Hi Ray,

Are you saying that I have compromised Windows 10 performance by running it in Parallels on my Mac OS?
Would Windows operate more fully on a real PC?


Re: [ap-ug] RS-232

Peter Natscher
 
Edited

I used to use Bootcamp but opted to try out Parallels when I changed my MacBook Pro to run Win 10 last January.  I do like Parallels simplicity without having to restart to the Boocamp Windows partition. I was using Win 7 on Bootcamp up until then.  Trouble is My 2012 MacBook Pro is limited to running MacOS 10.13.6 (High Sierra).  I can't operate a newer version Bootcamp to run Win 10 on it. Maybe it's time to retire the nice big screen 17" MacBook Pro and partition my 2016 27" iMac and go back to Bootcamp and Windows 10 with that computer.


Re: [ap-ug] RS-232

Thorsten Lockert
 

Yes, it is still around. But won’t be for the next release of macOS (Big Sur), or for Apple Silicon based future Mac systems.

Thorsten

On Jul 16, 2020, at 13:31, Dean Jacobsen <deanjacobsen@...> wrote:

Not compromised but when I used it sometimes the Parallels instance of Win 10 Dodd’s have trouble connecting to external devices though USB.  

VMWare Fusion is an excellent product but was expensive.

VirtualBox was good too, and free, but you sort of have to be adventurous to use it.

Bootcamp is what I would recommend.  Is Bootcamp still around with the latest macOS versions?
--
Dean Jacobsen
http://astrophoto.net/wp/
Image Gallery - http://astrophoto.net/wp/image-gallery/
Astrobin - https://www.astrobin.com/users/deanjacobsen/ 



Re: [ap-ug] RS-232

Dean Jacobsen
 
Edited

Not compromised but when I used it sometimes the Parallels instance of Win 10 did have trouble connecting to external devices though USB.  

VMWare Fusion is an excellent product but was expensive.

VirtualBox was good too, and free, but you sort of have to be adventurous to use it.

Bootcamp is what I would recommend.  Is Bootcamp still around with the latest macOS versions?
--
Dean Jacobsen
http://astrophoto.net/wp/
Image Gallery - http://astrophoto.net/wp/image-gallery/
Astrobin - https://www.astrobin.com/users/deanjacobsen/ 


Re: [ap-ug] RS-232

Thorsten Lockert
 

It *is* a “real” PC — you can run Windows natively on it, via Bootcamp.

Neither of those choices will really exist once the new Apple Silicon based ones come out.

Thorsten

On Jul 16, 2020, at 13:04, Peter Natscher <natscher@...> wrote:

Hi Ray,

Are you saying that I have compromised Windows 10 performance by running it in Parallels on my Mac OS?  Would Windows operate more fully on a real PC?


Re: [ap-ug] RS-232

Peter Natscher
 

Hi Ray,

Are you saying that I have compromised Windows 10 performance by running it in Parallels on my Mac OS?  Would Windows operate more fully on a real PC?


Re: [ap-ug] RS-232

Ray Gralak
 

MacBook Pro (17" 2012) partitioned with Parallels running Win 10 Pro 64.
That might be part of the problem. Running Parallels does not guarantee that a Windows USB driver is going to work on Macs. I've heard that VMWare Fusion works much better than Parallels with regards to successfully using USB devices on a Mac.

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Peter Natscher
Sent: Thursday, July 16, 2020 12:34 PM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] [ap-ug] RS-232

As stated earlier with trying to replace the corrupted database in my Keypad, I had problems connecting with a
cable between my MacBook Pro (17" 2012) partitioned with Parallels running Win 10 Pro 64. I was using a
TripLite RS-232 (9 pin)-to-USB(A) cable connector (with its own board inside). This required a driver. Win 7 and
Win 10 couldn't find a driver for this cable, so I downloaded and installed a current one found online. After
installing the driver, Win 10 still couldn't acknowledge the connection between the PC laptop and CP4. Could
anyone please recommend a proven USB(A)-to-RS232 cable to me that will connect between USB(A) port laptop
and the CP4?


Re: [ap-ug] RS-232

Peter Natscher
 

I'd like to thank all who responded to my questions about my personal hurdles using RS-232 in connection to managing my wonderful Astro-Physics Mach1 mount and Keypad.  Apparently, I am ignorant to the still important use of RS-232 and Serial in general use of Astro-Physics mounts and many other technical devices.   My orientation is more in line with consumer level electronic products that rely more or less on USB technology.

7441 - 7460 of 79126