Date   

Re: Help installing ASCOM driver - Win98??

tucstargzr
 

Bob,

Is there a version that works with Win98? Doing a first time
installation I made it up to the specific AP driver 4.1.25, and rec'd
an error message "need NT or later". Everything else was self
explanatory and I had no problems. If it means anything, trying to
interface Virtual Moon Atlas Pro via Ascom with an AP600 / CP2.

What can I say? the old puter in the Obs runs and runs and runs ;-)

Tom
Tucson, AZ


Re: Help installing ASCOM driver

Bob Denny
 

Daniel Verschatse wrote:
Thanks for the prompt reply.
I looked into Regedit and it indeed gives 5.0 for the platform
Version on the second line.
There are two more lines:
(Default) REG SZ (Value not set)
SetTraceFile REG SZ

Looks to me like everything is OK. Yet I still get the error message.
Should I run your reg fixup file anyway to see what happens ?
No, don't bother with that. It's correct. I promise I checked that
installer on several systems (2K, XP, Vista) before posting it...

Well, to get you going I have built a special installer that has the
Platform 5 version check removed. Download

AstroPhysics(4.1.25)SetupNoPlatCheck.exe

from the file section of this group, Bob Denny folder. Run it. You
cannot get THAT error message. But something isn't right, and I hope
that the true cause of the platform check won't show up after that!
Hopefully this will get you going.

I don't want to drag you through some long multi-day installer
debugging mess... so I'll keep my eye on this and see if it happens to
anyone else, maybe someone I can work with on the phone. The installer
is so simple, I'm surprised it doesn't just work!

-- Bob


Horsehead region in Hydrogen Alpha

Tom Carrico
 

Hi all,
We had a break in the rain and snow here in the pacific northwet, so it was time for my yearly attempt at objects in Orion. Naturally, the moon was full, but that is just plain not allowed to be a deterrent. After 4.5 hours of exposure, I ended up with the horsehead image in the link below. I would have like more (and color) but there was just not enough time between the trees and neighbors houses. The horsehead just does not get high enough to clear local buildings. Bummer.
I spent quite a bit of time during processing working on different areas to highlight them individually. This is definitely a pretty picture version, not at all representing relative brightnesses.
My original intent had been to go very deep to acquire all the nebulosity that fills the frame, hence the kind of odd framing. The image that is linked here is about half the full frame. On my web site you can see the full frame image. If you stretch that a lot you can see that there is nebulosity filling the frame, but just a bit too noisy. More exposure and color will likely have to wait until next year.
Before imaging the horsehead, I wanted to test out my new extender-q and the latest version of PemPro on my 1.5 year old AP 900. What a kick that was! Using my ST-10XME with the extender q allowed me to make reasonably accurate measurements of my periodic error. I acquired 7 complete worm cycles and let PemPro work its magic. It was able to reduce the periodic from 10 arcsecs peak to peak to 2.3 arcseconds peak to peak. New technology is so cool.

Here is the image. Comments and suggestions always welcome.

http://www.ccdargo.com/hh_fsq_halpha.htm

Thanks
Tom Carrico
http://www.ccdargo.com/


Re: Horsehead region in Hydrogen Alpha

Roland Christen
 

In a message dated 1/26/2008 5:51:41 PM Central Standard Time,
tom@... writes:


Here is the image. Comments and suggestions always welcome.

http://www.ccdargo.com/hh_fsq_halpha.htm
That is an excellent image. Huge field and very good resolution.

Rolando


**************
Biggest Grammy Award surprises of all time on AOL Music.


(http://music.aol.com/grammys/pictures/never-won-a-grammy?NCID=aolcmp00300000002548)


Re: Help installing ASCOM driver

Daniel Verschatse
 

Hi Bob,

Thanks for the prompt reply.
I looked into Regedit and it indeed gives 5.0 for the platform
Version on the second line.
There are two more lines:
(Default) REG SZ (Value not set)
SetTraceFile REG SZ

Looks to me like everything is OK. Yet I still get the error message.
Should I run your reg fixup file anyway to see what happens ?

Thanks again for your attention and help.

rgds,

Daniel V.

--- In ap-gto@..., "Bob Denny" <rdenny@...> wrote:

Daniel Verschatse:
When trying to install the new installer AstroPhysics(4.1.25)
Setup.exe
(426kb) on my Ascom 4.1, I got an error message saying "The ASCOM
Platform 5 is required for this driver".
So, with some apprehension (I'm not an early adopter <G>), I
installed
ASCOM 5 over 4.1 (no uninstall) successfully.
To my surprise I now still get the same message, even after
rebooting
the computer. Same goes for RoboFocus(3.0.7)Setup.exe, BTW.
If you know how, look in the registry at

HKEY_LOCAL_MACHINE&#92;Software&#92;ASCOM

In the right hand pane of RegEdit, look for the PlatformVersion. Is
it
5.0? Is should be after installing the Platform 5.0. That's what the
AP installer is looking for. If it is not 5.0, I'm not sure why not,
as the Platform 5 installer is definitely set to update that value!

In order to help get you going, I have created a registry fixup file
that you can use even if you couldn't do the above. Look in the
files
section of this group, in the Bob Denny folder. There is a file
FixPlatform5.zip. Download it, unzip and read ReadMe.txt in that
zipfile for further instructions. It's really simple.

Let us know idf that did it.


Re: Help installing ASCOM driver

Chris Curran <curran.chris@...>
 

Bob,

Thanks for the reply, but I'm good. I'm on 4.1 and not trying to
install anything from ASCOM web site - I got my 4.1.25 driver from
Ray's site last month (and only did so to get PEMPro v2 working). I
have no desire to jump on this 5.0 bandwagon just yet... :)

cheers,
Chris

--- In ap-gto@..., "Bob Denny" <rdenny@...> wrote:

Chris Curran wrote:

Well, that is confusing...
Yes, my mistake. I am sorry! I dod SO MUCH over the last couple of
weeks to get the whole new ASCOM site and Platform going... I just
missed this. I thought the file Ajai sent was an installer. It wasn't
it was just the bare driver.

Go back to the ASCOM site and get the driver setup again. It is really
an installer now. See my other messages

http://tech.groups.yahoo.com/group/ap-gto/message/20838

and

http://tech.groups.yahoo.com/group/ap-gto/message/20839

Again, I apologize!!! I made an assumption abobout the file sent to me
and it was wrong.

-- Bob


Re: Help installing ASCOM driver

Bob Denny
 

ancient.sull wrote:

With a different mount (Takahashi Temma) and ASCOM 4 you had to
double click on the driver, "Temma.exe"

When double clicked the "Not a windows program, cannot be run without
ASCOM" message would pop up but double clicking caused the driver to
be installed in the Registry.
Very old news, and no longer true. All drivers listed on the new ASCOM
site come with their own installers that do everything for you.

That may be a general feature of ASCOM 5 now. You may have to double
click on the AstroPhysics Driver.exe file so the Registry can
recognize/locate it.
No. You never have to even look into the drivers folders. The
installers do everything for you. Just follow the directions on the
site and you'll be OK.

Daniel V. has a strange problem (in this same thread) with the
Platform installation where the version is either missing or wrong.
Different issue, and I'm trying to help him with that. Keep the two
apart in your mind :-)

-- Bob


Re: Help installing ASCOM driver

Bob Denny
 

hewholooks wrote:
I believe that you can simply remove the old AP driver from the
Common Files/ASCOM/Telescope folder and replace it with the new one
by dragging it into the folder. At least it worked when I simulated
it on my computer.
Do not do this now. The file is now a real installer. Double-click it
to install.

I did find that when I downloaded the new ASCOM 5.0 platform, some of
the drivers that were listed in the ASCOM Telescope Chooser window
could not be selected because the "OK" button wouldn't be active.
This should only happen to drivers that have never been used. If a
driver existed from the old 4.1 Platform, and it had been used, it
will remember that it has been configured once, and still let you
click OK without going into Properties. The new Platform installer
does NOT touch any of that info.

-- Bob


Re: Help installing ASCOM driver

Bob Denny
 

Chris Curran wrote:

Well, that is confusing...
Yes, my mistake. I am sorry! I dod SO MUCH over the last couple of
weeks to get the whole new ASCOM site and Platform going... I just
missed this. I thought the file Ajai sent was an installer. It wasn't
it was just the bare driver.

Go back to the ASCOM site and get the driver setup again. It is really
an installer now. See my other messages

http://tech.groups.yahoo.com/group/ap-gto/message/20838

and

http://tech.groups.yahoo.com/group/ap-gto/message/20839

Again, I apologize!!! I made an assumption abobout the file sent to me
and it was wrong.

-- Bob


Re: Help installing ASCOM driver

Bob Denny
 

Daniel Verschatse:
When trying to install the new installer AstroPhysics(4.1.25)Setup.exe
(426kb) on my Ascom 4.1, I got an error message saying "The ASCOM
Platform 5 is required for this driver".
So, with some apprehension (I'm not an early adopter <G>), I installed
ASCOM 5 over 4.1 (no uninstall) successfully.
To my surprise I now still get the same message, even after rebooting
the computer. Same goes for RoboFocus(3.0.7)Setup.exe, BTW.
If you know how, look in the registry at

HKEY_LOCAL_MACHINE&#92;Software&#92;ASCOM

In the right hand pane of RegEdit, look for the PlatformVersion. Is it
5.0? Is should be after installing the Platform 5.0. That's what the
AP installer is looking for. If it is not 5.0, I'm not sure why not,
as the Platform 5 installer is definitely set to update that value!

In order to help get you going, I have created a registry fixup file
that you can use even if you couldn't do the above. Look in the files
section of this group, in the Bob Denny folder. There is a file
FixPlatform5.zip. Download it, unzip and read ReadMe.txt in that
zipfile for further instructions. It's really simple.

Let us know idf that did it.


Re: Help installing ASCOM driver

Klein, Adam <atk@...>
 

I received the same message -



________________________________

From: ap-gto@... [mailto:ap-gto@...] On Behalf
Of Daniel Verschatse
Sent: Friday, January 25, 2008 3:41 PM
To: ap-gto@...
Subject: [ap-gto] Re: Help installing ASCOM driver



Hi Bob,

When trying to install the new installer AstroPhysics(4.1.25)Setup.exe
(426kb) on my Ascom 4.1, I got an error message saying "The ASCOM
Platform 5 is required for this driver".
So, with some apprehension (I'm not an early adopter <G>), I installed
ASCOM 5 over 4.1 (no uninstall) successfully.
To my surprise I now still get the same message, even after rebooting
the computer. Same goes for RoboFocus(3.0.7)Setup.exe, BTW.

Help !

rgds,

Daniel Verschatse
Santiago - Chile
http://www.verschatse.cl <http://www.verschatse.cl>

--- In ap-gto@... <mailto:ap-gto%40yahoogroups.com> , "Bob
Denny" <rdenny@...> wrote:

Me:
I'll make up a proper installer for this driver now and
post when I have updated it on the ASCOM Download Center.
Done. The download from the ASCOM Download Center now consists of a
proper installer for the driver, instead of the driver EXE itself. It
will do everything needed (including the DCOM stuff needed for use
from TheSky/TeleAPI), and will remove all traces on uninstall. I
apologize for this, I just forgot that Ajai's latest EXE was the bare
driver.

-- Bob


Re: Help installing ASCOM driver

Daniel Verschatse
 

Hi Bob,

When trying to install the new installer AstroPhysics(4.1.25)Setup.exe
(426kb) on my Ascom 4.1, I got an error message saying "The ASCOM
Platform 5 is required for this driver".
So, with some apprehension (I'm not an early adopter <G>), I installed
ASCOM 5 over 4.1 (no uninstall) successfully.
To my surprise I now still get the same message, even after rebooting
the computer. Same goes for RoboFocus(3.0.7)Setup.exe, BTW.

Help !

rgds,

Daniel Verschatse
Santiago - Chile
http://www.verschatse.cl

--- In ap-gto@..., "Bob Denny" <rdenny@...> wrote:

Me:
I'll make up a proper installer for this driver now and
post when I have updated it on the ASCOM Download Center.
Done. The download from the ASCOM Download Center now consists of a
proper installer for the driver, instead of the driver EXE itself. It
will do everything needed (including the DCOM stuff needed for use
from TheSky/TeleAPI), and will remove all traces on uninstall. I
apologize for this, I just forgot that Ajai's latest EXE was the bare
driver.

-- Bob


Re: Help installing ASCOM driver

Ray Gralak <rgr@...>
 

Oh, geeze, I forgot that the package Ajai gave me was just the driver
executable. I'll make up a proper installer for this driver now and
post when I have updated it on the ASCOM Download Center. I don't want
folks to be installing the years-old Platform 4 just to get a driver
installed :-)))))
Ok, thanks Bob!

-Ray


Re: Help installing ASCOM driver

Bob Denny
 

Me:
I'll make up a proper installer for this driver now and
post when I have updated it on the ASCOM Download Center.
Done. The download from the ASCOM Download Center now consists of a
proper installer for the driver, instead of the driver EXE itself. It
will do everything needed (including the DCOM stuff needed for use
from TheSky/TeleAPI), and will remove all traces on uninstall. I
apologize for this, I just forgot that Ajai's latest EXE was the bare
driver.

-- Bob


Re: Help installing ASCOM driver

Bob Denny
 

--- In ap-gto@..., "Ray Gralak" <rgr@...> wrote:
Until I have released the new AP ASCOM driver you will need to
install the
ASCOM 4.1 platform first, then copy the 4.1.25 AP driver over the
platform's
version.
Oh, geeze, I forgot that the package Ajai gave me was just the driver
executable. I'll make up a proper installer for this driver now and
post when I have updated it on the ASCOM Download Center. I don't want
folks to be installing the years-old Platform 4 just to get a driver
installed :-)))))

-- Bob


Re: Help installing ASCOM driver

Ray Gralak <rgr@...>
 

The issue is that an ASCOM driver needs to be installed in order to
set various registry settings etc. All the other downloadable
drivers are really setup executables which install the driver. There
is no way for anybody to use this driver without having a prior
earlier installed version which doesn't exist in ASCOM 5.0. I'm
still looking for a solution to install it (i.e. create all the
appropriate registry keys etc.)
Until I have released the new AP ASCOM driver you will need to install the
ASCOM 4.1 platform first, then copy the 4.1.25 AP driver over the platform's
version.

You can get the 4.1 platform, old AP ASCOM driver, and updated Helper DLL
from here:

http://www.siriusimaging.com/ASCOM

-Ray


Re: Help installing ASCOM driver

hewholooks
 

Just a followup on this theory of mine.

From another group, Bob Denny of the ASCOM initiative confirmed the
need to go into the "Properties" menu the first time a new driver is
used - he said:
=============================================================
"Yes, that has been the behavior since the very first Platform in
2002.
It forces you to see the driver's configuration window at least once
after the driver is installed. Once you visit the driver's config
window once, the OK button will immediately light on selecting that
driver. We found during initial testing that people whoud never set
their COM port (like it was magic or something) and complain that
"ASCOM doesn't work!". So we force them to see that window at least
once. It eliminated most of those problems."
==========================================================

So keep this in mind when you have trouble activating your drivers.

Hunter


--- In ap-gto@..., "hewholooks" <hewholooks@...> wrote:

I tried that as well when I couldn't get the drivers to activate in
ASCOM v5, and it didn't work for me. Very strange. Could be just
my
situation, but the ONLY way the drivers activated for me was
the "Properties" route. I reasoned that it was a safeguard of some
type to get you to configure your driver prior to using it - but I
have no evidence to support that theory.

Hunter

--- In ap-gto@..., "ancient.sull" <ancient.sull@>
wrote:

With a different mount (Takahashi Temma) and ASCOM 4 you had to
double click on the driver, "Temma.exe"

When double clicked the "Not a windows program, cannot be run
without
ASCOM" message would pop up but double clicking caused the driver
to
be installed in the Registry.

That may be a general feature of ASCOM 5 now. You may have to
double
click on the AstroPhysics Driver.exe file so the Registry can
recognize/locate it.

(I am still using ASCOM 4, not 5)


--- In ap-gto@..., "hewholooks" <hewholooks@> wrote:

I believe that you can simply remove the old AP driver from the
Common Files/ASCOM/Telescope folder and replace it with the new
one
by dragging it into the folder. At least it worked when I
simulated
it on my computer.

I did find that when I downloaded the new ASCOM 5.0 platform,
some
of
the drivers that were listed in the ASCOM Telescope Chooser
window
could not be selected because the "OK" button wouldn't be
active.
In
order to get the "OK" button to activate, I would choose the
driver
(eg. AP Driver) and then select "Properties" to the right of
that
selection. The properties window would come up and even if I
didn't
change anything in it, if I clicked "OK" in that window, when I
got
back to the main ASCOM Telescope Chooser window, the main "OK"
button
would now be active and I could choose the driver.

Keep this in mind if you "OK" button is not activated at first.

Hunter

--- In ap-gto@..., "Chris Curran" <curran.chris@>
wrote:

Well, that is confusing...

First off, I downloaded a zip 'APDriver-4-1-25.zip' and it
contains
'AstroPhysicsDriver.exe'. To use that driver, you do not run
the
file
- you simply copy it to 'C:&#92;Program Files/Common
Files/ASCOM/Telescope'.

This new link to 'AstroPhysics(4.1.25)Setup.exe' - I suppose
you're
to
do the same as above, but that "Setup.exe" suffix sure is
misleading... I'm also not sure if you should rename
'AstroPhysics(4.1.25)Setup.exe'
to 'AstroPhysicsDriver.exe'....

good luck!
Chris


--- In ap-gto@..., "leszekm1" <leszek@> wrote:

Hi,

I'm trying to install the AP ASCOM driver. I downloaded
the
official
http://download.ascom-standards.org/drivers/AstroPhysics
(4.1.25)
Setup.exe
but whenever I try to run that setup program I get the
error:
This is an ASCOM driver, it cannot be run stand-alone.


Re: Help installing ASCOM driver

leszekm1
 

--- In ap-gto@..., "ancient.sull" <ancient.sull@...>
wrote:

You don't run it directly. You use it as a driver for other
applications so they can use it to connect to the mount.

For example if you are using TheSky6 set TheSky6, under Telescope >
Setup to "Astrophysics GTO Equitorial Mount"

Then when you have TheSky connect to the mount it will use that
driver.


--- In ap-gto@..., "leszekm1" <leszek@> wrote:

Hi,

I'm trying to install the AP ASCOM driver. I downloaded the
official
http://download.ascom-standards.org/drivers/AstroPhysics(4.1.25)
Setup.exe
but whenever I try to run that setup program I get the error:
This is an ASCOM driver, it cannot be run stand-alone.
The issue is that an ASCOM driver needs to be installed in order to
set various registry settings etc. All the other downloadable
drivers are really setup executables which install the driver. There
is no way for anybody to use this driver without having a prior
earlier installed version which doesn't exist in ASCOM 5.0. I'm
still looking for a solution to install it (i.e. create all the
appropriate registry keys etc.)


Re: Help installing ASCOM driver

hewholooks
 

I tried that as well when I couldn't get the drivers to activate in
ASCOM v5, and it didn't work for me. Very strange. Could be just my
situation, but the ONLY way the drivers activated for me was
the "Properties" route. I reasoned that it was a safeguard of some
type to get you to configure your driver prior to using it - but I
have no evidence to support that theory.

Hunter

--- In ap-gto@..., "ancient.sull" <ancient.sull@...>
wrote:

With a different mount (Takahashi Temma) and ASCOM 4 you had to
double click on the driver, "Temma.exe"

When double clicked the "Not a windows program, cannot be run
without
ASCOM" message would pop up but double clicking caused the driver
to
be installed in the Registry.

That may be a general feature of ASCOM 5 now. You may have to
double
click on the AstroPhysics Driver.exe file so the Registry can
recognize/locate it.

(I am still using ASCOM 4, not 5)


--- In ap-gto@..., "hewholooks" <hewholooks@> wrote:

I believe that you can simply remove the old AP driver from the
Common Files/ASCOM/Telescope folder and replace it with the new
one
by dragging it into the folder. At least it worked when I
simulated
it on my computer.

I did find that when I downloaded the new ASCOM 5.0 platform,
some
of
the drivers that were listed in the ASCOM Telescope Chooser
window
could not be selected because the "OK" button wouldn't be
active.
In
order to get the "OK" button to activate, I would choose the
driver
(eg. AP Driver) and then select "Properties" to the right of that
selection. The properties window would come up and even if I
didn't
change anything in it, if I clicked "OK" in that window, when I
got
back to the main ASCOM Telescope Chooser window, the main "OK"
button
would now be active and I could choose the driver.

Keep this in mind if you "OK" button is not activated at first.

Hunter

--- In ap-gto@..., "Chris Curran" <curran.chris@>
wrote:

Well, that is confusing...

First off, I downloaded a zip 'APDriver-4-1-25.zip' and it
contains
'AstroPhysicsDriver.exe'. To use that driver, you do not run
the
file
- you simply copy it to 'C:&#92;Program Files/Common
Files/ASCOM/Telescope'.

This new link to 'AstroPhysics(4.1.25)Setup.exe' - I suppose
you're
to
do the same as above, but that "Setup.exe" suffix sure is
misleading... I'm also not sure if you should rename
'AstroPhysics(4.1.25)Setup.exe' to 'AstroPhysicsDriver.exe'....

good luck!
Chris


--- In ap-gto@..., "leszekm1" <leszek@> wrote:

Hi,

I'm trying to install the AP ASCOM driver. I downloaded the
official
http://download.ascom-standards.org/drivers/AstroPhysics
(4.1.25)
Setup.exe
but whenever I try to run that setup program I get the error:
This is an ASCOM driver, it cannot be run stand-alone.


Re: Help installing ASCOM driver

ancient.sull
 

With a different mount (Takahashi Temma) and ASCOM 4 you had to
double click on the driver, "Temma.exe"

When double clicked the "Not a windows program, cannot be run without
ASCOM" message would pop up but double clicking caused the driver to
be installed in the Registry.

That may be a general feature of ASCOM 5 now. You may have to double
click on the AstroPhysics Driver.exe file so the Registry can
recognize/locate it.

(I am still using ASCOM 4, not 5)


--- In ap-gto@..., "hewholooks" <hewholooks@...> wrote:

I believe that you can simply remove the old AP driver from the
Common Files/ASCOM/Telescope folder and replace it with the new one
by dragging it into the folder. At least it worked when I
simulated
it on my computer.

I did find that when I downloaded the new ASCOM 5.0 platform, some
of
the drivers that were listed in the ASCOM Telescope Chooser window
could not be selected because the "OK" button wouldn't be active.
In
order to get the "OK" button to activate, I would choose the driver
(eg. AP Driver) and then select "Properties" to the right of that
selection. The properties window would come up and even if I
didn't
change anything in it, if I clicked "OK" in that window, when I got
back to the main ASCOM Telescope Chooser window, the main "OK"
button
would now be active and I could choose the driver.

Keep this in mind if you "OK" button is not activated at first.

Hunter

--- In ap-gto@..., "Chris Curran" <curran.chris@>
wrote:

Well, that is confusing...

First off, I downloaded a zip 'APDriver-4-1-25.zip' and it
contains
'AstroPhysicsDriver.exe'. To use that driver, you do not run the
file
- you simply copy it to 'C:&#92;Program Files/Common
Files/ASCOM/Telescope'.

This new link to 'AstroPhysics(4.1.25)Setup.exe' - I suppose
you're
to
do the same as above, but that "Setup.exe" suffix sure is
misleading... I'm also not sure if you should rename
'AstroPhysics(4.1.25)Setup.exe' to 'AstroPhysicsDriver.exe'....

good luck!
Chris


--- In ap-gto@..., "leszekm1" <leszek@> wrote:

Hi,

I'm trying to install the AP ASCOM driver. I downloaded the
official
http://download.ascom-standards.org/drivers/AstroPhysics(4.1.25)
Setup.exe
but whenever I try to run that setup program I get the error:
This is an ASCOM driver, it cannot be run stand-alone.