Re: ZWO color camera problem


Frank Widmann
 

From the MDL manual:

Many cameras produce images that are offset slightly from the nominal starting position. This results in a misalignment of the Bayer pattern, which in turn produces grossly incorrect colors. This can be corrected in the Convert Color command by adjusting the Offset X and Offset Y values; simply dial in different values until you get reasonable looking color. More often you simply need to tweak the color balance; this can be done in the Convert Color command as well.

Frank

On May 18, 2022, at 11:55 AM, Roland Christen via groups.io <chris1011@...> wrote:


Hi astro-imagers,

I have been using a ZWO 6200C color camera here at our factory observatory to test scopes, flatteners etc. I recently aimed it at a nearby blue water tower and was shocked to find that the color image showed the tower red, along with a red sky. The red lights on top of the tower came out blue. The green grass came out green. I did the color conversion in MaximDL from the raw image. After splitting the color image into RGB channels, I mapped the red to the blue channel and vice versa. That resulted in a proper color image.

I can't for the life of me figure out how Maxim-DL could mix up the conversion or whether it's something in the ZWO ASCOM driver that is amiss. Clearly the red pixels are being assigned to the blue channel, and the blue to the red channel in the color image.

Anyone know where to look for a solution, other than re-mapping every image?

Rolando


Join main@ap-gto.groups.io to automatically receive all group messages.