Re: NINA not Parking my 1100


Dale Ghent
 


Have you checked to make sure that APCC is indeed set to park at your desired park position instead of "Current Position", which is in fact a valid park location?

Yes, there are no notions of park positions when it comes to ASCOM. NINA and other apps just call the driver's Park() method, and it's up to the driver and the mount to interpret what that means and move the mount there. I do plan on adding advanced sequencer instructions to my NINA plugin that implement the A-P driver's Park 1-5 positions. For now, it's limited to parking the mount and whatever is configured in APCC/the ASCOM driver.


On Jan 10, 2022, at 01:13, Alex <groups@...> wrote:

I’ve been using SGP to automate my rig for a while now, but I thought I’d give NINA a try.  Things mostly seemed to work, but one issue is that the scope wasn’t parked in its usual position at the end of the sequence. Instead of returning the scope to park position 1, which I normally use, the scoped was parked in the position it when it was the end of the sequence.  When using SGP, it always retuned to the scope to park position 1.
 
I know NINA parked the scope from the NINA log:
 
2022-01-09T05:48:34.9198|INFO|SequenceItem.cs|Run|195|Starting Category: Telescope, Item: ParkScope
2022-01-09T05:48:34.9218|INFO|SequenceItem.cs|Run|195|Starting Category: Rotator, Item: MoveRotatorMechanical, Mechanical Position: 90
2022-01-09T05:48:34.9238|INFO|TelescopeVM.cs|ParkTelescope|130|Telescope has been commanded to park
2022-01-09T05:48:35.4005|INFO|StarDetection.cs|Detect|221|Average HFR: 3.1397415442436, HFR σ: 1.15009080928962, Detected Stars 167
2022-01-09T05:48:35.5920|INFO|BaseImageData.cs|FinalizeSave|144|Saving image at C:\Users\Alex Ranous\Documents\Imaging\Markarian's Chain\2022-01-08\LIGHT\Markarian's Chain_2022-01-09_05-45-31_Blue_LIGHT_-5.00c_gain0_180.00s_0012.xisf
2022-01-09T05:48:38.2074|INFO|SequenceItem.cs|Run|213|Finishing Category: Telescope, Item: ParkScope
And this is the bit from the APCC log mentioning parking:
 
0391883 2022-01-09 05:48:35.731:       Info, VPortCheckVPort1(COM4), (RX: :Rc#), TX: APCC,2,4070237,0#
0391884 2022-01-09 05:48:35.732:       Info,    VPort1(COM4), RX: :APCC,4070238,*PARK,0#
0391885 2022-01-09 05:48:35.736:       Info, ProcessVPortCommand, RX from VPort 1: :APCC,4070238,*PARK,0#
0391886 2022-01-09 05:48:35.736:       Info, ProcessVPortCommand, APCC Seq= 4070238, CMD=*PARK,0#
I was running with the advanced sequencer with the beta 26 version of NINA.  I’m running the 1.9.3.1 version of APCC. My understanding of ASCOM is that it doesn't have a notion of park positions, and given a command to park, the AP ASCOM driver should have parked to the last park position.  Anyone have any suggestions as to what I’m doing wrong?
 
Alex
 

Join main@ap-gto.groups.io to automatically receive all group messages.