Re: APPM with ASI6200 and TSX Imagelink - bogus image data


Bill Long
 

Hmm interesting. I always get an error when I try to use ASCOM. I'll try it again later after a clean boot and see what happens.


From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Ray Gralak <iogroups@...>
Sent: Monday, August 2, 2021 6:41 AM
To: main@ap-gto.groups.io <main@ap-gto.groups.io>
Subject: Re: [ap-gto] APPM with ASI6200 and TSX Imagelink - bogus image data
 

Bill,

 

> The Kepler driver package installs a driver for non Kepler cameras as well.

 

Thanks, I didn't know that! They should make that clearer on the website.

 

I just downloaded it and took an image indoors with APPM using the FLI ASCOM Camera driver. There is a camera lens on my ProLine 16803 but I didn’t try to focus it.

 

I can take more images or capture a video as proof if you want?

 

 

> -----Original Message-----

> From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Bill Long

> Sent: Monday, August 2, 2021 5:45 AM

> To: main@ap-gto.groups.io

> Subject: Re: [ap-gto] APPM with ASI6200 and TSX Imagelink - bogus image data

>

> The Kepler driver package installs a driver for non Kepler cameras as well.

>

> ________________________________

>

> From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Ray Gralak <iogroups@...>

> Sent: Monday, August 2, 2021 5:43 AM

> To: main@ap-gto.groups.io <main@ap-gto.groups.io>

> Subject: Re: [ap-gto] APPM with ASI6200 and TSX Imagelink - bogus image data

>

> Hi Bill,

>

> >> I'm not sure what you are trying to say, but all ASCOM drivers are supposed to work the same. Was the FLI

> >> ASCOM driver you used officially developed by FLI?

> > Yes it was.

>

> Were you using a Kepler camera? There is no official FLI ASCOM Camera driver except for Kepler cameras:

>

> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.flicamera.com%2Fsoftware%2Findex.ht

> ml&amp;data=04%7C01%7C%7C1d2a321736324278c45a08d955b3340c%7C84df9e7fe9f640afb435aaaaaaaaaaaa

> %7C1%7C0%7C637635050418593944%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luM

> zIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=cMI9jcw2OnHE26CEYGf0u2PB79UCMytVwXGBPz

> xNvFw%3D&amp;reserved=0

>

> > Not sure why that matters.

>

> It matters because many of the ASCOM drivers have been written by amateur software developers, using a

> language, libraries, and development environment with which they are inexperienced. The result is that their drivers

> may work to some extent but are not 100% compatible with the ASCOM specification.

>

> > I think there is a legit problem with APPM working with ASCOM Camera. In fact, I tried 3 other cameras and it

> > doesnt work at all. Cant get an image from the camera at all.

>

> If APPM doesn't work with ASCOM cameras, then it shouIdn't work with the ASCOM Camera Simulator either (but

> it does). The point of the ASCOM Camera simulator is to be a reference driver so developers don't have to buy and

> test every single camera.

>

> A few months ago I purchased an ASI294MM specifically for the purpose of debugging the "out of memory" problem

> with the ASI Camera driver. I am able to get images with that camera as long as they are not full frame images. And

> that is because of how inefficiently the ASI ASCOM driver uses memory (almost 1GB of memory for a single 46MP

> monochrome image!).

>

> -Ray

>

> > -----Original Message-----

> > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Bill Long

> > Sent: Sunday, August 1, 2021 11:28 PM

> > To: main@ap-gto.groups.io

> > Subject: Re: [ap-gto] APPM with ASI6200 and TSX Imagelink - bogus image data

> >

> > Yes it was. Not sure why that matters.

> >

> > I think there is a legit problem with APPM working with ASCOM Camera. In fact, I tried 3 other cameras and it

> > doesnt work at all. Cant get an image from the camera at all.

> >

> > ________________________________

> >

> > From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Ray Gralak <iogroups@...>

> > Sent: Sunday, August 1, 2021 11:08 PM

> > To: main@ap-gto.groups.io <main@ap-gto.groups.io>

> > Subject: Re: [ap-gto] APPM with ASI6200 and TSX Imagelink - bogus image data

> >

> > > Okay but I tested it with an FLI camera and its ASCOM driver. 🙁

> >

> > I'm not sure what you are trying to say, but all ASCOM drivers are supposed to work the same. Was the FLI

> > ASCOM driver you used officially developed by FLI?

> >

> > There is no special code in an ASCOM Client application like APPM that treats one ASCOM Camera driver

> > differently from another. The same actions are applied by a client application, with the main difference being the

> > width and height of the image array. So, if one ASCOM camera driver works but another doesn't, then it's likely

> > something is wrong with the ASCOM driver that doesn't work.

> >

> > -Ray

> >

> > > -----Original Message-----

> > > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Bill Long

> > > Sent: Sunday, August 1, 2021 10:41 PM

> > > To: main@ap-gto.groups.io

> > > Subject: Re: [ap-gto] APPM with ASI6200 and TSX Imagelink - bogus image data

> > >

> > > Okay but I tested it with an FLI camera and its ASCOM driver. 🙁

> > >

> > > ________________________________

> > >

> > > From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Ray Gralak

> <iogroups@...>

> > > Sent: Sunday, August 1, 2021 10:26 PM

> > > To: main@ap-gto.groups.io <main@ap-gto.groups.io>

> > > Subject: Re: [ap-gto] APPM with ASI6200 and TSX Imagelink - bogus image data

> > >

> > > > ASCOM Camera just throws the same errors he mentioned when used directly.

> > > > The SIM might work but a real camera doesn't seem to.

> > >

> > > Yes, I believe that.

> > >

> > > The point was that it's the ASI ASCOM Driver that's the issue, not APPM. APPM acts the same way for all

> > ASCOM

> > > cameras.

> > >

> > > -Ray

> > >

> > > > -----Original Message-----

> > > > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Bill Long

> > > > Sent: Sunday, August 1, 2021 9:04 PM

> > > > To: main@ap-gto.groups.io

> > > > Subject: Re: [ap-gto] APPM with ASI6200 and TSX Imagelink - bogus image data

> > > >

> > > > ASCOM Camera just throws the same errors he mentioned when used directly. The SIM might work but a real

> > > > camera doesn't seem to.

> > > >

> > > > ________________________________

> > > >

> > > > From: main@ap-gto.groups.io <main@ap-gto.groups.io> on behalf of Ray Gralak

> > <iogroups@...>

> > > > Sent: Sunday, August 1, 2021 8:38 PM

> > > > To: main@ap-gto.groups.io <main@ap-gto.groups.io>

> > > > Subject: Re: [ap-gto] APPM with ASI6200 and TSX Imagelink - bogus image data

> > > >

> > > >

> > > > I'm glad it's working!

> > > >

> > > >

> > > >

> > > > It's too bad you couldn't get around to proving APPM's ASCOM interface also works with the ASCOM Camera

> > > > Simulator, as I know it does. Here's a screenshot as proof:  :-)

> > > >

> > > >

> > > >

> > > >

> > > >

> > > > -Ray

> > > >

> > > >

> > > >

> > > > > -----Original Message-----

> > > >

> > > > > From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of ap@...

> > > >

> > > > > Sent: Sunday, August 1, 2021 8:19 PM

> > > >

> > > > > To: main@ap-gto.groups.io

> > > >

> > > > > Subject: Re: [ap-gto] APPM with ASI6200 and TSX Imagelink - bogus image data

> > > >

> > > > >

> > > >

> > > > > As a minor update, I had a bit of time before my target was high enough after I got all the other setup done

> > so...

> > > >

> > > > >

> > > >

> > > > > I set up TSX, Image link and APPM so that APPM used TSX's Camera, which used my ASI6200 binned 2.

> It

> > > > might

> > > >

> > > > > do bin 1 but pointless.

> > > >

> > > > >

> > > >

> > > > > It's running nicely, I was doing only 37 points and it's on 18 and has not missed a single one.

> > > >

> > > > >

> > > >

> > > > > And it's using the same ASI ASCOM camera driver.

> > > >

> > > > >

> > > >

> > > > > So I have a workable system, at least until I sell my MyT.

> > > >

> > > > >

> > > >

> > > > > I still don't know what is wrong the other way, but this works fine, if a bit round-about..

> > > >

> > > > >

> > > >

> > > > > 22 successful and counting....

> > > >

> > > > >

> > > >

> > > > > Linwood

> > > >

> > > > >

> > > >

> > > > >

> > > >

> > > > >

> > > >

> > > > >

> > > >

> > > > >

> > > >

> > > >

> > > >

> > > >

> > >

> > >

> > >

> > >

> > >

> > >

> > >

> > >

> >

> >

> >

> >

> >

> >

> >

> >

>

>

>

>

>

>

>

Join main@ap-gto.groups.io to automatically receive all group messages.