Re: Possible CP5 Wi-Fi module failure #WiFi


Eric Weiner
 

***SOLVED***

I did some investigation and testing after reading about how some other folks have had similar Wi-Fi issues with the CP5.  I made several incremental settings changes to my home mesh network which now allows me to initialize the mount using RS232 (or anything else), then connect SkySafari through my iPhone via my home network Wi-Fi connection.  These modified settings also fixed the connectivity issues I was having with the CP5's built in access point.  These new settings have been completely reliable over several iterations of complete power-down power-on testing. 

I believe there were a few things going on beside what some have claimed to be RF interference and/or too much power out at the CP5 antenna.  The solutions I came up with do not require covering the antenna with foil or otherwise making changes to the CP5 Wi-Fi hardware. 

First, there was indeed indication of interference when using different channels for the home Wi-Fi network and the CP5.  Try selecting the same channel for both, such as 2.4GHz channel 1.

Second, reducing transmit power of the home network to 50% (I also tried 25%) significantly improved reliability of connections.

Third, reducing the CTS/RTS Threshold to something lower than max also significantly improved connection stability.  I changed from 2346 to 500.

Speed tests at 2.4GHz and 5GHz after making these settings showed improved download speeds across my entire home mesh network.

The APCC "Find CP4/5" tool still does not locate my CP5 Wi-Fi IP address, but if you have access to your router's device manager the CP5 is listed as "Sychip Router."  You can grab the IP from there if your router resets and changes it.

Hopefully someone else finds this information useful.

Cheers,

Eric

Join main@ap-gto.groups.io to automatically receive all group messages.