Re: APCC Pro with MSGBox V2


W Hilmo
 

…And now that I’ve seen it work with the ASCOM test app, it’s now working correctly with APCC.  I love it when a problem disappears on its own (sarcasm).

 

The only thing that I can think of, is that perhaps the ASCOM test app made some change to the configuration.  I’m just grasping at straws now, but I would love to understand what actually happened, so that I can correct it when it (inevitably) happens in the field when I have no contact with the outside world.

 

From: main@ap-gto.groups.io <main@ap-gto.groups.io> On Behalf Of W Hilmo
Sent: Friday, May 28, 2021 8:58 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] APCC Pro with MSGBox V2

 

Yes, I am connecting to “ASCOM ObservingConditions” as the source.

 

In the “Select Driver” box, I have tried “ASCOM.OCH.ObservingConditions”, followed by setting the ASCOM driver for the MGBox V2 in the appropriate properties for the observing conditions hub.  I have also tried selecting “Astromi.ch MGBox Observing Conditions” in the Select Driver box.

 

Both methods give the same results.

 

I have also tried enabling “Trace on” in the MGBox driver, but I haven’t figured out yet where I can go to read the trace.

 

Finally, I just found the ASCOM “Observing conditions Hub test harness”.  When I run that tool and connect to the observing conditions hub, it shows the correct information (below).  I was originally thinking that this would probably be a problem with the MGBox ASCOM driver (and I asked about it here to see how others were getting it to work with APCC), but now I suspect that it actually *is* an APCC problem, since the ASCOM test app works correctly:

 

5/28/2021 8:54:41 AM

ASCOM Observing Conditions Hub (OCH). Version: 6.5.1.0

AveragePeriod : 0.0

CloudCover - This property is not implemented

DewPoint : 2.7

Humidity : 34.0

Pressure : 933.8

RainRate - This property is not implemented

SkyBrightness - This property is not implemented

SkyQuality - This property is not implemented

SkyTemperature - This property is not implemented

StarFWHM - This property is not implemented

Temperature : 18.9

WindDirection - This property is not implemented

WindGust - This property is not implemented

WindSpeed - This property is not implemented

 

CloudCover is not implemented

DewPoint Description : MGBox uses a Bosch BME280 sensor

Humidity Description : MGBox uses a Bosch BME280 sensor

Pressure Description : MGBox uses a Bosch BME280 sensor

RainRate is not implemented

SkyBrightness is not implemented

SkyQuality is not implemented

SkyTemperature is not implemented

StarFWHM is not implemented

Temperature Description : MGBox uses a Bosch BME280 sensor

WindDirection is not implemented

WindGust is not implemented

WindSpeed is not implemented

 

From: main@ap-gto.groups.io <main@ap-gto.groups.io> On Behalf Of Phillip Klein
Sent: Friday, May 28, 2021 8:46 AM
To: main@ap-gto.groups.io
Subject: Re: [ap-gto] APCC Pro with MSGBox V2

 

Hi Wade,

 

Under Data Source have you selected Ascom?

 

Phil

 

 

On Fri, May 28, 2021 at 8:36 AM W Hilmo <y.groups@...> wrote:

In my quest for unguided imaging, I've picked up an MGBox V2 so that I can get temp, pressure, humidity and dew point.

I have installed the MGBox V2 and verified that it is working correctly in its own application.  I've also installed the ASCOM driver 1.6 for the MGBox V2.  The problem is that I cannot get it to work correctly with APCC.  All of my attempts to test it cause APCC to display -237.2C (absolute zero) for both temperature and dew point, and zeros for pressure and humidity.  I have tried connecting directly through the ASCOM ObservingConditions selection in APCC, and also by connecting to the ASCOM Observing Conditions Hub and selecting the MGBox V2 for the relevant specific devices.

Does anyone have any suggestions or troubleshooting steps to figure this out?

Thanks,
-Wade

Attachments:

Join main@ap-gto.groups.io to automatically receive all group messages.