Re: Weird issues - ASCOM driver (5.30.10) - Mach1 - APCC and PHD2 #APCC #ASCOM_V2_Driver #Guiding


Ray Gralak
 

Hi Rodolfe,

1. When starting a new frame capture in SCG Pro, PHD2 sends out a warning "Please disable the Synchronous
PulseGuide option in the mount's ASCOM driver settings. Enabling the setting can cause unpredictable results".
--> But the ASCOM settings are "Synchronous PulseGuide calls" disabled (box unchecked).
That's the PHD2 developers' attempt to blame the AP V2 ASCOM driver for a COM interop threading issue in the PHD2 code. :-)

Disabling "Synchronous PulseGuide Calls" does not resolve the threading issue in PHD2, but it might make it less likely to occur.

2,. When using APCC through its virtual ports, I get an error message slewing the mount (not after the initial slew,
but when SGP attempts to center the target) : "VPort2 / Fault / SyncTarget: Valid ALT/Az, RA/Dec, HA/Dec has not
been received!" - and the 3D view blinks in red.
--> I thus bypassed APCC as a temporary solution, going straight through the ASCOM driver, until I find a
reason/fix for it.
That means APCC is having trouble communicating with either the mount or the driver.

How are you connecting to the mount?

Which control box are you using? (e.g. GTOCP4)

What version of firmware?

What version of APCC?

-Ray Gralak
Author of APCC (Astro-Physics Command Center): https://www.astro-physics.com/apcc-pro
Author of PEMPro V3: https://www.ccdware.com
Author of Astro-Physics V2 ASCOM Driver: https://www.siriusimaging.com/apdriver


-----Original Message-----
From: main@ap-gto.groups.io [mailto:main@ap-gto.groups.io] On Behalf Of Rodolphe
Sent: Tuesday, June 23, 2020 2:37 PM
To: main@ap-gto.groups.io
Subject: [ap-gto] Weird issues - ASCOM driver (5.30.10) - Mach1 - APCC and PHD2 #ASCOM_V2_Driver
#Guiding #APCC

Hello
I observed in my recent sessions several issues - not sure if they are connected or not.

Running Win10 Pro, 8GB Ram, plenty of disk space.

1. When starting a new frame capture in SCG Pro, PHD2 sends out a warning "Please disable the Synchronous
PulseGuide option in the mount's ASCOM driver settings. Enabling the setting can cause unpredictable results".
--> But the ASCOM settings are "Synchronous PulseGuide calls" disabled (box unchecked).

2,. When using APCC through its virtual ports, I get an error message slewing the mount (not after the initial slew,
but when SGP attempts to center the target) : "VPort2 / Fault / SyncTarget: Valid ALT/Az, RA/Dec, HA/Dec has not
been received!" - and the 3D view blinks in red.
--> I thus bypassed APCC as a temporary solution, going straight through the ASCOM driver, until I find a
reason/fix for it.

Has anyone an idea?
If more details are needed, happy to provide.
Thanks in advance for your support.
Rodolphe

Join main@ap-gto.groups.io to automatically receive all group messages.