Re: Tele API connection


Yves Laroche
 

Hi Rick,

First, you cannot use MaxPoint directly with TheSky, only TPOINT (Software Bisque).

Second, to connect your mount with TheSky via ASCOM driver, you must select TeleAPI from the telescope list. This TeleAPI is not the same as the one who come with TheSky installation. You must copy TeleAPI.dll from C:\Program Files\Common Files\ASCOM\Telescope\Planetarium Plug-Ins\TheSky to C:\Program Files\Common Files\System. After selecting TeleAPI from TheSky, press settings and select Astro-Physics GTO Mount in ASCOM Telescope Chooser. Press the properties button to set the parameters you want. Please verify that the version driver is 4.1.15, if not download the whole ASCOM package again or download only the driver from http://ascom-standards.org/downloads.html Also, don't forget to download Updated Helper2 Component (4.0.3)


Updated Helper2 Component (4.0.3)
This was slipstreamed into the ASCOM Platform 4.1 on 13-Apr-05, so if you downloaded the Platform 4.1 thereafter, you have it. Corrects the Util.GetTimeZoneOffset() method. This is used by the AstroPhysics driver (and probably other drivers). Replace C:\Program Files\Common Files\ASCOM\helper2.dll with the one in this zip file. Don't do anything tricky, replace the file!
Updated AstroPhysics Driver (4.1.15)
This was slipstreamed into the ASCOM Platform 4.1 on 21-Mar-05, so if you downloaded the Platform 4.1 thereafter, you have it. Replace C:\Program Files\Common Files\ASCOM\Telescope\AstroPhysics Driver.exe with the one in this zip file. Don't do anything tricky, replace the file!


Regards,
Yves

----- Original Message -----
From: "Rick K" <JunkMailGoesHere@...>
To: <ap-gto@...>
Sent: Friday, April 15, 2005 6:52 PM
Subject: [ap-gto] Re: Tele API connection




OK, so, just for laughs, I loaded up my work laptop with MaximDL V4.10
and MaxPoint with the lastest ASCOM drivers. Started MaxPoint and
connected to the Telescope Simulator. Connected both MaximDL and
Starry Night Pro 4.5 to MaxPoint and everything works just like you
said. Wonderful, I have reduced the linkage by one level by removing
POTH. For pointing this out, I thank you Ajai, BUT, the question
remains, just how do I connect TheSky v6.0.0.33 to MaxPoint?!?! I
bring up the telescope setup list and there is no Maxim, no MaxPoint,
no POTH (not that I have it running anymore, but I was looking for it
when I did), I have been on the Bisque website and looking for ASCOM
under the search tool results in quite literally nothing - not even a
mention of its existence. So, what are people doing to connect TheSky
to ASCOM?

Rick.


--- In ap-gto@..., "Ajai Sehgal" <ajai@s...> wrote:
If you have MaxPoint connected to the mount you DON'T NEED the POTH as
MaxPoint IS a hub in itself. Just connect everything that you want
to talk
to the scope to MaxPoint.

Ajai

-----Original Message-----
From: ap-gto@... [mailto:ap-gto@...] On
Behalf Of
Rick K
Sent: Friday, April 15, 2005 12:31 PM
To: ap-gto@...
Subject: [ap-gto] Re: Tele API connection



Good grief - is this ever convoluted. Why doesn't TheSky just support
ASCOM and link to POTH directly? Anyway, I am still confused. I have
on the bottom, MaxPoint connected to the mount, then POTH on top of
that connected to Maxpoint. On top of POTH I have MaxIM DL connected.
I also connected StarryNight Pro 4.5 to POTH to see if it would work
and it did, seamlessly. I am waiting on receiving SNP 5.0. My fervent
wish is for the StarryNight display engine and Megastar data and data
display to merge - now that would be incredible. Maybe SNP5 gets
closer. Anyway, back to matters at hand, I only glanced at it quickly
and couldn't see anything obvious but just how does one connect
TheSky6 to POTH?

Rick.

--- In ap-gto@..., Yves Laroche <yves.laroche@v...> wrote:
Hi Joe,

You must install Helper2.dll file. Please follow the instructions
below and
download the file at
http://ascom-standards.org/download/Helper2-4-0-3.zip

"This was slipstreamed into the ASCOM Platform 4.1 on 13-Apr-05, so
if you
downloaded the Platform 4.1 thereafter, you have it. Corrects the
Util.GetTimeZoneOffset() method. This is used by the AstroPhysics
driver
(and probably other drivers). Replace C:&#92;Program Files&#92;Common
Files&#92;ASCOM&#92;helper2.dll with the one in this zip file. Don't do
anything
tricky, replace the file! "

Regards,
Yves



----- Original Message -----
From: "Joe Morris" <joemorris@s...>
To: "ap-gto" <ap-gto@...>
Sent: Friday, April 15, 2005 12:28 PM
Subject: [ap-gto] Tele API connection



If I try to connect The Sky 6.0.0.33 to my AP 600 GTO mount using
Tele API
through ASCOM's(version 4.1 with the most recent AP diver) POTH, a
link
occurs but the crosshairs on The Sky are incorrect (different than
POTH's
RA
and Dec) and nothing happens when a slew command is given. My
keypad is
set
to EXT. Any thoughts? Should I be disconnecting the keypad?







To UNSUBSCRIBE, or for general information on the ap-gto list
see http://groups.yahoo.com/group/ap-gto
Yahoo! Groups Links




To UNSUBSCRIBE, or for general information on the ap-gto list
see http://groups.yahoo.com/group/ap-gto
Yahoo! Groups Links






Join main@ap-gto.groups.io to automatically receive all group messages.